Sub-Boards in 'YaBB 2 - Bugs [Fixed]' Topics Posts Last Post
YaBB 2 - Bugs [Fixed Archive]
YaBB 2 - Bugs [Fixed Archive]  (2 Viewing)
These are bugs in YaBB 2 that have already been fixed and are included in the latest release. The purpose of the board is to document things recently fixed to inform visitors to upgrade to the latest release for these fixes.
Moderator Groups: YaBB Moderators, Development Team, Legacy Dev Team, Support Team
676 5,582 Last Post Aug 10th, 2013 at 3:20pm
In: Re: Downloads.pl
By: Dandello
YaBB 2 - Bugs [Fixed] YaBB 2 - Bugs [Fixed]
These are bugs fixed in YaBB 2 since the latest release. Please check this board before making a new bug report.
(Moderator Groups: YaBB Moderators, Development Team, Legacy Dev Team, Support Team)
Topics: 118
Posts: 674
Pages Pages: 1 [2] 3 4 
There are no actions to perform.
 
Subject / Started By Replies Views Last Post Sort (Z-A)
Normal Topic
Broadcast Messages to Groups
This happens in my 2.4 test install, 2.5AE and 2.5.2 test installs and occasionally people have commented on it: Broadcast Messages sent to groups revert to 'New' after the user has logged out and log...

Started Apr 19th, 2013 at 3:19am by Dandello
4 639 Last Post Mar 4th, 2014 at 2:08pm
By: JonB
Normal Topic
LastPost poster link and Guests
2.4/2.5AE/2.5.2
Guests still get a link to the last poster's profile from the BoardIndex, even though Guest viewing of profiles is not allowed.

Started Apr 21st, 2013 at 8:22pm by Dandello
5 1,064 Last Post Mar 4th, 2014 at 2:08pm
By: JonB
Normal Topic
Edit tag issues
When using the 'edit' tag to highlight edits, it doesn't nest properly. As in
[CODE]
comes out as:
Edited:
Edited:
test
test

while Quote  
[CODE]
does:
Quote:
Quote:
test
test

This is true at least as far back as 2.4

Started Jul 5th, 2013 at 5:17pm by Dandello
4 551 Last Post Mar 4th, 2014 at 2:08pm
By: JonB
Hot Topic (More than 10 Replies)
GreyBox images bugs
[IMAGE]
For example, see the source code of this message:
<img src="http://www.yabbforum.com/img/header2_left.png" name="signat_img_resize_1" alt="..." title="..." border="0" style="display: inline; " width="4...

Started Aug 17th, 2010 at 7:55am by Fduch
« Pages 1 2 »
This topic contains 1 attachment
18 9,896 Last Post Apr 13th, 2013 at 4:32pm
By: Bill Myers
Normal Topic
No Subject error in ModifyMessage
When attempting to modify a message, the Warning 'No subject' appears when trying to save.
The cause, no default maximum Subject length when $set_subjectMaxLength is set to 0.
solution: In M...

Started Feb 18th, 2013 at 1:42am by Dandello
0 516 Last Post Feb 18th, 2013 at 1:42am
By: Dandello
Hot Topic (More than 10 Replies)
Extended profile fields not saved correctly
I activated extended profile fields. Then I created a multiline text box. No matter what I write into that text box in my profile, after I save the profile, it contains only a number and everything I ...

Started Feb 11th, 2013 at 4:55pm by Homer J. S.
« Pages 1 2 »
This topic contains 1 attachment
16 3,343 Last Post Feb 12th, 2013 at 2:52pm
By: xnoddyx
Normal Topic
Admin/MailMembers.pl throws javascript errors
This shows up in 2.5.2 and in the 3.0 versions of MailMembers in the YaBB svn. It doesn't show up in 2.5AE because the select groups section of MailMembers is broken there.
Specifically - in the...

Started Nov 29th, 2012 at 4:05pm by Dandello
1 1,354 Last Post Jan 23rd, 2013 at 11:22pm
By: Dandello
Normal Topic
2.5.2 Guest names not properly formated
In 2.5.2 : when Guests are allowed to post, the Guest's name is not properly formatted, shows them as an ex-member, and the email address is missing in the mini-profile
in Display.pl find
[CODE perl]
Replace ...

Started Jan 11th, 2013 at 7:49pm by Dandello
0 651 Last Post Jan 11th, 2013 at 7:49pm
By: Dandello
Normal Topic
Negative incrementing of IM numbers with AlertModerator
This goes back to at least 2.5AE and possibly before.
When the 'AlertModerator' function is active and is used, the recipient's new posts' shows negative number. The reason: The file that keeps t...

Started Jan 11th, 2013 at 7:41pm by Dandello
0 747 Last Post Jan 11th, 2013 at 7:41pm
By: Dandello
Hot Topic (More than 10 Replies)
Media center and Youtube
It has been brought to our attention that YouTube short tags don't work with YaBB's media tag.
Here is a fix - still in Alpha
in .Sources/MediaCenter.pl find
[CODE perl]
add beneath [CODE perl]
this should properly embed video where the ...

Started Aug 14th, 2012 at 2:01am by Dandello
« Pages 1 2 »
17 4,895 Last Post Nov 16th, 2012 at 7:59pm
By: Miss Emily
Normal Topic
Additional Extended Profiles issues
Specifically, if an Extended Profile field is set to 'Required on Registration' but not set to 'Active', it blocks Registration as the required field does not display and cannot be filled in. I didn't...

Started Aug 11th, 2012 at 10:09pm by Dandello
3 1,426 Last Post Nov 6th, 2012 at 9:33pm
By: Dandello
Normal Topic
Extended Profiles date issues
The date section of Extended Profiles doesn't go through data validation or save the input. (Thus generating an error in Register2 when the field is required on registration.)
the fix:
in ....

Started Aug 15th, 2012 at 1:47am by Dandello
1 6 Last Post Nov 6th, 2012 at 9:33pm
By: Dandello
Normal Topic
noparse issues with News-scroller
Something I just noticed with both 2.5AE and the version of 3.0 I have running for testing.
In the Message display - if the last post in the thread has 'UBB and smilies disabled' it disables the ...

Started Aug 14th, 2012 at 12:31am by Dandello
4 1,510 Last Post Nov 6th, 2012 at 9:33pm
By: Dandello
Normal Topic
email domain filter "*." bug
If I enter the string "*.ru" (instead of ".ru") in the email domain filter, it filters out any email addresses with the string "ru" anywhere in them, eg "nevillekrudd@gmail.com".
The error messag...

Started Feb 23rd, 2012 at 10:08am by freediver
2 3,142 Last Post Nov 6th, 2012 at 9:33pm
By: Dandello
Normal Topic
Attachments
Attachments dont seem to be working i just made a post with a Attachment and it all went ok till after it went back to the post and wam it shows Attachment but when going to load it 404s  Huh

Started Mar 8th, 2012 at 1:44am by xnoddyx
1 1,122 Last Post Nov 6th, 2012 at 9:33pm
By: Dandello
Normal Topic
Fixfile.pl
The 2.4/2.5 versions of fixfile.pl doesn't properly convert the files it's supposed to. This is on the todo list for future upgrades.
In the meantime, the fix is: on attempting to upgrade a v1 fo...

Started Aug 2nd, 2012 at 6:51pm by Dandello
1 946 Last Post Nov 6th, 2012 at 9:33pm
By: Dandello
Normal Topic
output to sub permtimer
Just passing this along:
I have the warnings pragma turned on for my test-bed copy of YaBB2.5AE and YaBB3.0 running on Perl5.12 (can't upgrade to 5.14 until a couple modules I need get updated) a...

Started May 8th, 2012 at 12:36am by Dandello
1 1,106 Last Post Nov 6th, 2012 at 9:33pm
By: Dandello
Normal Topic
Broadcast message to Admin's
with Broadcast message to Admin's  when a admin opens it up it will still alert / Notify all admins until the last admin views it or it is deleted may cores problems if more than one admin is looking ...

Started Aug 16th, 2012 at 5:17pm by xnoddyx
1 1,130 Last Post Nov 6th, 2012 at 9:33pm
By: Dandello
Normal Topic
YaBB 'Next Edition' Baclup
When you try to run YaBB Backup in the current forum installed on YaBBforum.com -
An Error Has Occurred! Use of qw(...) as parentheses is deprecated at /home/yabbforum/cgi-bin/community/Admin/...
Lips Sealed

Started May 3rd, 2012 at 11:37pm by JonB
This topic contains 1 attachment
4 1,911 Last Post Nov 6th, 2012 at 9:33pm
By: Dandello
Normal Topic
Perl 5.12 warning tosser
Defined hashes are deprecated in Perl 5.12. (But they don't break things - yet.)
There are 2 in .Sources/Subs.pl
Find: [CODE]
Replace with: [CODE]
The logic here, as near as I can tell, is that asking if a hash (which is ...

Started Aug 3rd, 2012 at 11:55pm by Dandello
1 1,015 Last Post Nov 6th, 2012 at 9:33pm
By: Dandello
Normal Topic
admin approval bug
If I turn off admin approval I can no longer approve accounts that were registered and validated by email. They do not show up in the member list so I assume they still need admin approval. When I cli...

Started Jan 14th, 2012 at 2:46am by freediver
7 2,550 Last Post Nov 6th, 2012 at 9:33pm
By: Dandello
Hot Topic (More than 10 Replies)
Adding Extended Profile fields 'locks' Members
Adding a  'new' required for registration field to the registration process locks the profiles of pre-existing members.
this topic -
http://www.yabbforum.com/community/YaBB.pl?num=1320402825...

Started Dec 28th, 2011 at 7:22pm by JonB
This topic contains 1 attachment
11 3,398 Last Post Nov 6th, 2012 at 9:33pm
By: Dandello
Normal Topic
Functionality Issue - "/me"
In YaBB versions prior to 2.4 the /me element in the compose window italicized the entire line and set the text color to #FF0000.  Deti changed it literally on a whim. (I know because Corey asked him ...

Started Aug 9th, 2012 at 3:44pm by JonB
4 1,528 Last Post Nov 6th, 2012 at 9:33pm
By: Dandello
Very Hot Topic (More than 25 Replies)
Update Session
V2.5AE - I never have gotten "Update Session" to work. The answer to the question is never recognized as correct.
I went into the control panel to change the answer, just an attempt I've probably...

Started Feb 20th, 2012 at 3:31pm by Tanner
« Pages 1 2 3 »
33 8,719 Last Post Nov 6th, 2012 at 9:33pm
By: Dandello
Normal Topic
Perl 5.12/5.14 incompatability
Luckily most hosting services are running Perl 5.08 to 5.10.
BUT there is depreciated syntax in  .Admin/BackUp.pl, as well as other files, which will keep your existing forum from making backups ...

Started Aug 3rd, 2012 at 7:16pm by Dandello
9 2,673 Last Post Nov 6th, 2012 at 9:31pm
By: Dandello
Normal Topic
Encode Passwords in memberlist.inactive
Passwords aren't being encrypted in the memberlist.inactive file - obviously passwords should never be revealed to website owners.
In Register.pl find:
[CODE perl]
And add after:
[CODE perl]
Find:
[CODE perl]
And replace:
[CODE perl]

Started Aug 23rd, 2012 at 2:50am by Derek Barnstorm
1 1,000 Last Post Nov 6th, 2012 at 9:31pm
By: Dandello
Normal Topic
Forum Jump accessible in Maintenance mode
xnoddyx found this one: The Forum Jump box is still active when the forum in is maintenance mode. While this may not be an issue most of the time, this is still probably not a good thing.
In ./So...

Started Sep 1st, 2012 at 5:53am by Dandello
1 798 Last Post Nov 6th, 2012 at 9:31pm
By: Dandello
Normal Topic
Send Topic can be accessed when disabled
The Send Topic feature can still be accessed if it is totally disabled or if you only allow topics to be sent via the user's own email program.
In Sources/SendTopic.pl find:
[CODE perl]
And add after:
[CODE perl]
I guess JS alerts may as w...

Started Aug 26th, 2012 at 2:47pm by Derek Barnstorm
1 1,043 Last Post Nov 6th, 2012 at 9:31pm
By: Dandello
Normal Topic
YaBB.js Called Twice (YaBB 2.5)
YaBB.js is being called twice. It crept in when the Syntax Highlighter mod was added.
In Sources/Subs.pl find and remove:
[CODE]

Started Aug 28th, 2012 at 6:25pm by Derek Barnstorm
5 1,758 Last Post Nov 6th, 2012 at 9:31pm
By: Dandello
Normal Topic
PM Subject Length
Regarding this post:
http://www.yabbforum.com/community/YaBB.pl?num=1345733397/13#13
"0 = default(50)" for the "Maximum Allowed Characters in Post Subject" doesn't work For PMs:
In S... find:
[CODE perl]
And add after:
[CODE perl]
And seeing as PMs work from the sa

Started Aug 27th, 2012 at 12:12am by Derek Barnstorm
9 2,661 Last Post Nov 6th, 2012 at 9:31pm
By: Dandello
Pages Pages: 1 [2] 3 4 
There are no actions to perform.
 
Normal Topic Normal Topic
Sticky Topic Sticky Topic
Locked Topic Locked Topic
Locked Topic Sticky Locked Topic
Moved Topic Moved Topic
Global Announcement Global Announcement
Locked Global Announcement Locked Global Announcement
Hot Topic (More than 10 Replies) Hot Topic (More than 10 Replies)
Very Hot Topic (More than 25 Replies) Very Hot Topic (More than 25 Replies)
You can view Topics in this Board.

You cannot post replies to Topics in this Board.
You cannot start new Topics in this Board.
You cannot post Attachments in this Board.
You cannot start Polls in this Board.
 
  ‹ Board Index    ^Top