Page Index Toggle Pages: 1 [2] 3 4 
Topic Tools
 25 Arabic (Read 32,350 times)
Mohammad Rasti
YaBB Newcomer
*
Offline



Posts: 4
Location: Firoooooooooozabad
Re: Arabic
Reply #38 - Feb 25th, 2008 at 1:54pm
Post Tools
hi again to all.
thanks to all, last problem was solved,
but now, i have two new problem,
first problem is this : http://firoozabad.com/forum/YaBB.pl
like you see, board's name are not RTL, and they are Left to right, how i can move it and make that RTL ?

and second problem;
font is not clear to user, i want change font, but i can't fournd where the font name are defined.

thanks again for all.
  
Back to top
 
IP Logged
 
Carsten
Ex Member


Re: Arabic
Reply #37 - Feb 22nd, 2008 at 2:50pm
Post Tools
Basically, to change everything from 'left to right' to 'right to left' you'll just have to add: dir="rtl" to your 'html' tag:

In "default.html" find:
Code
Select All
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en"> 


and change it to:
Code
Select All
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en" dir="rtl"> 



Not sure that's all you need to do - but at least that should be a start  Smiley
« Last Edit: Feb 22nd, 2008 at 2:52pm by »  
Back to top
 
IP Logged
 
Mohammad Rasti
YaBB Newcomer
*
Offline



Posts: 4
Location: Firoooooooooozabad
Re: Arabic
Reply #36 - Feb 22nd, 2008 at 9:32am
Post Tools
alsalam o alaik,
Hello to all
i want change my YaBBforum alignT from english to arabic template. my forum template, now is this : http://www.firoozabad.com/forum/YaBB.pl like you have seen, it's made left to right, but arabic's forums like this : http://alekrat.com/yabb/YaBB.pl made right to left. now i want make my forum right to left, but i don't know what can i do to do it,
can you help me ?
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Arabic
Reply #35 - Feb 18th, 2008 at 4:06am
Post Tools
  
Back to top
 
IP Logged
 
ToScAnA
YaBB Newcomer
*
Offline



Posts: 1
Re: Arabic
Reply #34 - Nov 26th, 2007 at 8:12pm
Post Tools
I HOPE TO FOUND THE FIX OF THIS PROBLEM AND FIND THE TRUE TRANSLATION ARABIC LANGAUGE
AL JAREEH YOUR SITE DOESN`T WORK  Undecided
SEE YOU
اراكم على خير ياشباب
  
Back to top
 
IP Logged
 
xslim12
YaBB Newcomer
*
Offline



Posts: 1
Re: Arabic
Reply #33 - Aug 23rd, 2007 at 1:44am
Post Tools
is the full version uploaded yet? If so can someone please upload? I am in desperate need for the patch!!!!!!!!!!!!!!!!!!!!
  
Back to top
 
IP Logged
 
BIG-SIZE-OF-GHORZH
YaBB Newcomer
*
Offline



Posts: 1
Re: Arabic
Reply #32 - Aug 17th, 2007 at 5:24pm
Post Tools
hi

i'm from egypt

i have site http://www.ghorzh.com ; i can  be your reseales in egypt and

arabic world i will make new site the name of the team arabian team

we will Develop alot of kind of board
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Arabic
Reply #31 - Jul 25th, 2007 at 9:54pm
Post Tools
Your Welcome...  Very Nice Board !!  Now you can build !!
  
Back to top
 
IP Logged
 
asdbabl
YaBB Newcomer
*
Offline



Posts: 10
Re: Arabic
Reply #30 - Jul 25th, 2007 at 8:05pm
Post Tools
Grin
thank u Mishdan you are great and your notes true 100%
and thank you vary much Captain John to help me

my forum try on this url
http://www.almalafpress.net/cgi-bin/yabb2/YaBB.pl

  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Arabic
Reply #29 - Jul 23rd, 2007 at 1:01pm
Post Tools
Thanks Mishdan.. for your input.

asdbabl

We hope you upload and attach the translated lanquage pack, after you have tested and feel it is complete, to benefit others who wish to use the Arabic language.
  
Back to top
 
IP Logged
 
MishDan
Full Member
***
Offline



Posts: 228
Location: Kyiv, Ukraine
Re: Arabic
Reply #28 - Jul 22nd, 2007 at 9:33pm
Post Tools
Hmm, your web-server also should specify proper value in page headers, so, if You are using apache, specify in YaBB's dir's .htaccess 'AddDefaultCharset windows-1256', maybe, this helps...
Edited:
P.S. I see, that You modified template around beginning meta tags. Are You specified encoding directly in template? You should not do that. Just specify your encoding in language pack, in variable $yycharset at the beginning of Main.lng and Admin.lng. Then YaBB will substitute '<yabb charset>' with proper value.
« Last Edit: Jul 22nd, 2007 at 9:42pm by MishDan »  

P.S. Sorry, my English is not so good, as I wish
Back to top
WWWGTalkICQ  
IP Logged
 
Captain John
Ex Member


Re: Arabic
Reply #27 - Jul 22nd, 2007 at 8:33pm
Post Tools
[quote author=4641444C4741534D200 link=1157217487/15#22 date=1185040842]Thank you Captain John.
But I was put this code in head but my forum dont show the arabic character if I dont chose the encoding from view menu .
iwant sho the arabic character by automatic encoding   without chose from view menu

the question how sit the encoding without chose from view menu
ex. this forum :http://alekrat.com/yabb/YaBB.pl

note: my forum is http://www.riadyjaded.com/cgi-bin/yabb2/YaBB.pl[/quote]

  I just visited your site again... Arabic characters are being displayed, without my changing the browser encoding.....  Did you refresh your browser, so your not viewing a cached page ?
  You presently have a lot of english words, but every instance of Arabic displays correctly. Yes ?
  
Back to top
 
IP Logged
 
asdbabl
YaBB Newcomer
*
Offline



Posts: 10
Re: Arabic
Reply #26 - Jul 22nd, 2007 at 6:40pm
Post Tools
Hello
Captain John
i put this code and no successful
Code
Select All
<meta http-equiv="Content-Type" content="text/html; charset=windows-1256" >
<meta http-equiv="Content-Language" content="ar-sy" >
 



there are many Persons waite my to complete  this forum translate and I am without any Results

i am asking you and every one he can help me to gife me answers

thanck you Captain John

  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Arabic
Reply #25 - Jul 22nd, 2007 at 2:25am
Post Tools
These are the meta tags in your sight as of right now ...

Code
Select All
<meta http-equiv="Content-Type" content="text/html; charset=windows-1256">
<meta http-equiv="Content-Language" content="ar-sy>" > 



Should be content="ar-sy">

Why did you change from the utf-8 ?
« Last Edit: Jul 22nd, 2007 at 2:31am by »  
Back to top
 
IP Logged
 
asdbabl
YaBB Newcomer
*
Offline



Posts: 10
Re: Arabic
Reply #24 - Jul 21st, 2007 at 8:05pm
Post Tools
Captain John Pls help me I try different   meta code but the characters dont show. you can view the source of my forum and look the meta code

meta http-equiv="Content-Type" content="text/html; charset=windows-1256

pls. I have loss along time to translate this forum and I dont want loss it

thanck you
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1 [2] 3 4 
Topic Tools
 
  « Board Index ‹ Board  ^Top