Page Index Toggle Pages: 1 [2] 
Topic Tools
Hot Topic (More than 10 Replies) Font Not Working (Read 8,213 times)
Captain John
Ex Member


Re: Font Not Working
Reply #6 - Jan 24th, 2008 at 8:51pm
Post Tools
the problem seems to be No Font named Sans-Serif

Code
Select All
[font=Sans-Serif]abcdefgABCDEFG[/font]
[font=Verdana]abcdefgABCDEFG[/font]
[font=Arial]abcdefgABCDEFG[/font]
[font=Serif]abcdefgABCDEFG[/font]
[font=Courier]abcdefgABCDEFG[/font]
[font=Courier New]abcdefgABCDEFG[/font]
[font=monospace]abcdefgABCDEFG[/font]

[font=Global Sans Serif]abcdefgABCDEFG[/font]
[font=MS Sans Serif]abcdefgABCDEFG[/font] 



abcdefgABCDEFG
abcdefgABCDEFG
abcdefgABCDEFG
abcdefgABCDEFG
abcdefgABCDEFG
abcdefgABCDEFG
abcdefgABCDEFG

abcdefgABCDEFG
abcdefgABCDEFG
« Last Edit: Jan 24th, 2008 at 8:56pm by »  
Back to top
 
IP Logged
 
Jet Li
Legacy Dev Team
Development Team
****
Offline



Posts: 6,588
Location: Hong Kong
Re: Font Not Working
Reply #5 - Jan 24th, 2008 at 8:46pm
Post Tools
  

PM me for YaBB Installation Service
Back to top
WWWGTalkFacebook  
IP Logged
 
Carsten
Ex Member


Re: Font Not Working
Reply #4 - Jan 24th, 2008 at 8:43pm
Post Tools
working on all my (5) test boards.
  
Back to top
 
IP Logged
 
smith21
Support Team
****
Offline



Posts: 4,660
Location: Stockton - on - Tees,  England

None
Re: Font Not Working
Reply #3 - Jan 24th, 2008 at 8:18pm
Post Tools
Quote:
Confirmed.

In YaBBC.pl change:

Code
Select All
	$message =~ s~\[font=([A-Za-z0-9# ]+)\](.+?)\[/font\]~<span style="font-family:$1;">$2</span>~isg; 


to:
Code
Select All
	$message =~ s~\[font=([A-Za-z0-9# -]+)\](.+?)\[/font\]~<span style="font-family:$1;">$2</span>~isg; 




Still Not working guys on my forum

Test Font
« Last Edit: Jan 24th, 2008 at 8:20pm by smith21 »  

Cheers
Back to top
IP Logged
 
Jet Li
Legacy Dev Team
Development Team
****
Offline



Posts: 6,588
Location: Hong Kong
Re: Font Not Working
Reply #2 - Jan 24th, 2008 at 4:11pm
Post Tools
Hi
New YaBBC.pl in CVS.  Wink
  

PM me for YaBB Installation Service
Back to top
WWWGTalkFacebook  
IP Logged
 
Carsten
Ex Member


Re: Font Not Working
Reply #1 - Jan 24th, 2008 at 3:59pm
Post Tools
Confirmed.

In YaBBC.pl change:

Code
Select All
	$message =~ s~\[font=([A-Za-z0-9# ]+)\](.+?)\[/font\]~<span style="font-family:$1;">$2</span>~isg; 


to:
Code
Select All
	$message =~ s~\[font=([A-Za-z0-9# -]+)\](.+?)\[/font\]~<span style="font-family:$1;">$2</span>~isg; 


  
Back to top
 
IP Logged
 
smith21
Support Team
****
Offline



Posts: 4,660
Location: Stockton - on - Tees,  England

None
Font Not Working
Jan 24th, 2008 at 2:09pm
Post Tools
When Using the Sans-Serif font tag it does not work

Testing the font Sans-Serif

Testing the font Courier New
« Last Edit: Jan 24th, 2008 at 2:11pm by smith21 »  

Cheers
Back to top
IP Logged
 
Page Index Toggle Pages: 1 [2] 
Topic Tools
 
  « Board Index ‹ Board  ^Top