YaBB Community and Support Forum
YaBB Home About YaBB Download YaBB YaBB Support Customize Your Forum Development Contribute to the Project
  Welcome, Guest. Please Login or Register


 
Page Index Toggle Pages: 1
Topic Tools
 
README !! 'Installations via cPanel' must know !! (Read 7,193 times)
 Oct 15th, 2008 at 7:02pm
There are no actions to perform.  

Dan Muey 
YaBB Friends
Offline
Posts: 6


None
README !! 'Installations via cPanel' must know !!
Hello,

My name is Dan and I am the cPanel developer that works with YaBB on the cPanel based installer.

I hope to clear up some confusion that I see a lot in this area of the forum.

cPanel installs YaBB for you via a "cPAddon". A "cPAddon" is a way to package up a given website script so as to facilitate 1 click install/update/uninstall and otherwise manage all instances of the given script via the cPanel interface.

With that in mind here are some points to remember:

 a) No manual steps should be necessary after 'Installations via cPanel' (and upgrades as well).

    running Setup.pl, chmod'ing, etc should not be necessary.
    If you find they are then please let me know (tickets.cpanel.net subject 'ATTN: Dan YaBB install/upgrade') so we can adjust the YaBB cPAddon to look for and handle said situation.

 b) Upgrades and uninstalls of 'Installations via cPanel' should be done via cPanel not manually

     If they are done manually then you are unable to manage them via cPanel and the data presented in cPanel about your installation will likely be incorrect (E.g. it may say its 2.2.3 but you've manually updated it to 2.3)

     If you have trouble upgrading then the installation has been manually changed. A starting point is to look at the 'failed patch' output and see if its an issue caused by manual changes or if it's a problem you wouldn't mind 'forcing' to be applied as per the 'Do you want to force this update' dialog.

 c) Manual installs done on your cPanel account are not 'Installations via cPanel'

     As such, issues would not belong in the 'Installations via cPanel' section of the forum

   Edited:
This is the correct board to request help and info on upgrading an Installation of YaBB via cPanel, when your Host does not supply a cPanel cPAddon upgrade or does not provide a cPanel cPAddon to install a YaBB Forum One Button Install.
« Last Edit: Oct 21st, 2008 at 4:28pm by N/A »  
 
IP Logged  
 Reply #1 - Oct 15th, 2008 at 7:27pm
There are no actions to perform.  
Captain John 
Ex Member


None
Re: README !! 'Installations via cPanel' must know !!
Hi Dan ... Glad to see you guys visit this site every now and then ...  Agree with what you state ... EXCEPT  Wink  A lot of Hosts do not nor make available upgrades, probably due to the fact that Cpanel does not make available every version update we release with a New cPAddon.
 This board is exactly why it exists and the problems are users run into when trying to manually upgrade an existing cPanel cPAddon install.
  I once (a couple years ago) requested info on how a cPAddon installed YaBB ... No reply.  Still don't know, but at least over this time, we have learned the install file structure (small accomplishment).  We still don't know why manually installing, replacing existing files, doesn't work.  Usually causing 403 errors.
 We have found (by trial and error) that not overwriting thml files, but uploading the yabbfiles html folder directly into the main installation folder allows it to upgrade, with our path settings modified on some servers.
  The above and the posts (in such a new support board for us) verifies the problems users have in updating/upgrading and we try to help.

Edited:
Manual installs done on your cPanel account are not 'Installations via cPanel'  No, their Manual Installs (upgrades) "of" Installations via cPanel
« Last Edit: Oct 15th, 2008 at 7:44pm by N/A »  
 
IP Logged  
 Reply #2 - Oct 2nd, 2012 at 8:59pm
There are no actions to perform.  

Elfen 
Full Member
***
Offline
Posts: 450


None
Re: README !! 'Installations via cPanel' must know !!
Thread Necromacy!

I agree with the former member, and have to say that my site is on Host Gator and I have never seen YaBB as a forum cPanel install on their system and wrote up how to manually do it. phpBB and Simple Machines are the two options for forum on HostGator's system, and not YaBB.

Working on somebody else's site hosted by Godaddy, I see on their Cpanel system that YaBB is not there either.
 
 
IP Logged  
 Reply #3 - Oct 2nd, 2012 at 9:24pm
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 1,856
Earth


YaBB 2.5
Re: README !! 'Installations via cPanel' must know !!
Knownhost has YaBB 2.3.1 as a cPanel software add-on. But frankly, it's probably easier to do it by hand using the standard defaults if you're on Knownhost, especially as you're going to want to upgrade for security and features. (I had my first two YaBB installs up and running before I even realized cPanel had it as an add on.)
 
WWW  
IP Logged  
 Reply #4 - Oct 2nd, 2012 at 9:31pm
There are no actions to perform.  

depablo 
YaBB Moderators
YaBB Next Team
Beta Testers
***
Offline
Posts: 577
UK


YaBB 2.5
Re: README !! 'Installations via cPanel' must know !!
Elfen wrote on Oct 2nd, 2012 at 8:59pm:
I see on their Cpanel system that YaBB is not there either.

Im sure the host has an option to tweak what is available to end users. Some see it as a resource hog others do not, I have seen it in the past but it installed into the root directory.
 
Taking a peek behind the mask Wink
 
IP Logged  
 Reply #5 - Oct 3rd, 2012 at 7:19pm
There are no actions to perform.  

Elfen 
Full Member
***
Offline
Posts: 450


None
Re: README !! 'Installations via cPanel' must know !!
depablo wrote on Oct 2nd, 2012 at 9:31pm:
Elfen wrote on Oct 2nd, 2012 at 8:59pm:
I see on their Cpanel system that YaBB is not there either.

Im sure the host has an option to tweak what is available to end users. Some see it as a resource hog others do not, I have seen it in the past but it installed into the root directory.

I know that in past YaBB versions (Around 2.1)  there were problems that made it accidentally eat up system resources. But those have been long fixed.
 
 
IP Logged  
 Reply #6 - Oct 3rd, 2012 at 7:34pm
There are no actions to perform.  

Elfen 
Full Member
***
Offline
Posts: 450


None
Re: README !! 'Installations via cPanel' must know !!
I will state my evidence:
...


Host Gator has never given me problems except for installing YaBB. Thus I decided to install YaBB myself and in doing so wrote the manual installation of YaBB on Cpanel that is some where in this forum.
 
 
IP Logged  
 Reply #7 - Oct 3rd, 2012 at 7:34pm
There are no actions to perform.  

depablo 
YaBB Moderators
YaBB Next Team
Beta Testers
***
Offline
Posts: 577
UK


YaBB 2.5
Re: README !! 'Installations via cPanel' must know !!
Elfen wrote on Oct 3rd, 2012 at 7:19pm:
I know that in past YaBB versions (Around 2.1)  there were problems that made it accidentally eat up system resources. But those have been long fixed.

Trouble is convincing hosts, also try telling the end users who where forced to switch to mySQL forums.
Edit: I have seen YaBB in cpanel.
« Last Edit: Oct 3rd, 2012 at 7:37pm by depablo »  
Taking a peek behind the mask Wink
 
IP Logged  
 Reply #8 - Oct 3rd, 2012 at 7:53pm
There are no actions to perform.  

Elfen 
Full Member
***
Offline
Posts: 450


None
Re: README !! 'Installations via cPanel' must know !!
depablo wrote on Oct 3rd, 2012 at 7:34pm:
Trouble is convincing hosts, also try telling the end users who where forced to switch to mySQL forums.
Edit: I have seen YaBB in cpanel.

I've seen YaBB in Cpanel as well, even on Host Gator before that problem came up years ago and it as fixed.

MySQL forums are neither better or hack proof as YaBB is. I seen many MySQL forums hacked until rendered useless, and emails of the users compromised to spam bots.

Which forum one uses should be because of preference and not what you need to have on a server. I'm here on YaBB, phpBB and other forum community support forums and I have to say that this place has a better atmosphere and communications to its members. Also You can easily upgrade your mods when your forum upgrades. forum software like VBulletin and simple Machines wants you to submit your forum over to them for mods to be installed. What a load of crock that is!
 
 
IP Logged  
 Reply #9 - Mar 25th, 2014 at 8:40am
There are no actions to perform.  

Rod Schrivener 
YaBB Newbie
*
Offline
Posts: 2


YaBB 2.3
Re: README !! 'Installations via cPanel' must know !!
I had at one time a YABB forum on my siste, which is hoisted by Web Hosting Buzz. It was installed via their cpanel. Recently, I have had notices to upgrade,however, the upgrade fails, and I am at a loss trying to find where all this forum stuff is in the site. I discontinued use o f the forum some time back, however, it will not uninstall through cPanel. Can someone give me an idea where the files are usually installed and how to get them removed. Thanks.......

Rod
 
 
IP Logged  
 Reply #10 - Mar 25th, 2014 at 6:05pm
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 1,856
Earth


YaBB 2.5
Re: README !! 'Installations via cPanel' must know !!
cPanel doesn't currently have the newest version of YaBB available for install. The newest stable version is 2.5.2. Let your host know that there is a very old version of YaBB in their cPanel and the problems you're having - I believe they can disable the warnings for you. In the event you want to update, you should be able to do so manually through file manager.

Edited:
Normally you should be able to find the YaBB install under cgi-bin/yabb2 - your host should be able to tell you where their system put it if it's not there.
« Last Edit: Mar 25th, 2014 at 6:07pm by Dandello »  
WWW  
IP Logged  
Page Index Toggle Pages: 1
Topic Tools
 

Get Yet another Bulletin Board at SourceForge.net. Fast, secure and Free Open Source software downloads Support This Project BoardMod - YaBB features and templates YaBB Codex - support on installation and usage YaBB Toolbar for your browser

YaBB Facebook Group Page

Vulnerability Scanner

Valid RSS Valid XHTML Valid CSS Powered by Perl
YaBB Chat and Support Community » Powered by YaBB 3.0 Beta!
YaBB Forum Software © 2000-2011. All Rights Reserved.