Page Index Toggle Pages: 1
Topic Tools
Normal Topic pl => cgi extension (Read 6,099 times)
OH Eng
Past Team Members
Documentation Team
Offline



Posts: 4,026
Location: Pensacola, Florida USA
Re: pl => cgi extension
Reply #7 - Apr 15th, 2009 at 10:22pm
Post Tools
The last 6 Posts were moved here from Installation and Setup on Linux, UNIX, Mac, and BSD Servers [move by] OH Eng.
  

 
Back to top
 
IP Logged
 
deti
Legacy Dev Team
Development Team
****
Offline



Posts: 2,650
Location: Prien am Chiemsee, Germany
Re: Setup with .cgi, not .pl files
Reply #6 - Apr 15th, 2009 at 9:43pm
Post Tools
New Setup.pl in CVS.

Moderator please splice this into
http://www.yabbforum.com/community/YaBB.pl?num=1239741788
« Last Edit: Apr 15th, 2009 at 9:54pm by deti »  

Was immer Du tun kannst
oder erträumst tun zu können,
beginne es.
Kühnheit besitzt Genie,
Macht und magische Kraft.
Beginne es jetzt.
Whatever you can do
or dream you can,
begin it.
Boldness has genius,
power and magic in it.
Begin it now.
J. W. Goethe
Back to top
WWW  
IP Logged
 
agh
YaBB Newcomer
*
Offline



Posts: 40
Re: Setup with .cgi, not .pl files
Reply #5 - Apr 15th, 2009 at 9:18pm
Post Tools
Hello there,

Good news: I was able to get my forum going  Cheesy

The key thing was that I had uploaded the new forum on top of the old one (I thought it wasn't gonna hurt that much and I forgot to mention it here, shame on me  Embarrassed).

Anyway, these are the changes I did to work with cgi files instead of pl ones:

Setup.pl -> Setup.cgi
AdminIndex.pl -> AdminIndex.cgi
YaBB.pl -> YaBB.cgi

And these are the modifications I did to Setup.pl, the only one of these files I modified:

< else { $yyext = "pl"; }
> else { $yyext = "cgi"; }
(yes, I know, but I reaally wanted to make sure  Roll Eyes)

< <form action="YaBB.pl" method="post" style="display: inline;">
> <form action="YaBB.cgi" method="post" style="display: inline;">

< elsif (-e "$INFO{'nextstep'}.pl") { $yySetLocation = qq~$INFO{'nextstep'}.pl?action=revalidatesession~; }
> elsif (-e "$INFO{'nextstep'}.pl") { $yySetLocation = qq~$INFO{'nextstep'}.cgi?action=revalidatesession~; }

< <form action="$boardurl/YaBB.pl" method="post" style="display: inline;">
> <form action="$boardurl/YaBB.cgi" method="post" style="display: inline;">

While going through the last steps of the Setup I had a couple of errors, one at the revalidatesession step (which I solved), and then another one which I didn't bother to fix because I considered it harmless (I didn't even write down the exact step).

(I didn't modify any .html files)

Thanks everyone, time for me to customize my brand new 2.3.1 YaBB forum!  Wink

agh
  
Back to top
 
IP Logged
 
deti
Legacy Dev Team
Development Team
****
Offline



Posts: 2,650
Location: Prien am Chiemsee, Germany
Re: Setup with .cgi, not .pl files
Reply #4 - Apr 14th, 2009 at 8:33pm
Post Tools
You are right I did't notice this. Replace the YaBB.pl with YaBB.$yyext in Setup.pl and replace in all index.html also the YaBB.pl with YaBB.cgi
  

Was immer Du tun kannst
oder erträumst tun zu können,
beginne es.
Kühnheit besitzt Genie,
Macht und magische Kraft.
Beginne es jetzt.
Whatever you can do
or dream you can,
begin it.
Boldness has genius,
power and magic in it.
Begin it now.
J. W. Goethe
Back to top
WWW  
IP Logged
 
agh
YaBB Newcomer
*
Offline



Posts: 40
Re: Setup with .cgi, not .pl files
Reply #3 - Apr 14th, 2009 at 8:23pm
Post Tools
Hello again, some more info (sorry for the update),

I have the following three files replicated as cgi:
Setup.cgi
YaBB.cgi
AdminIndex.cgi

It's in the Setup file where there are a couple of references to YaBB.pl (in the "form action" part)

I get the 404 error when accesing the Setup.cgi URL.
If I specify the YaBB.cgi or AdminIndex.cgi URLs I get redirected directyl to my homepage (the behavior expected for a 404 error). I guess this is because I haven't managed to run Setup.cgi properly yet.

However, the symptom looks a bit different depending on the browser.

With Chrome, I get this 404 error window, which stays.
With Explorer, first it took a few seconds but in the end I was redirected to my homepage. Now it's behaving like Crhome. (?)
With Firefox, it takes a few seconds and ends up with a blank page (no redirection, no 404 error message).

I'm confident PERL path references are correct (same as yesterday) and the cgibin path is correct. Remember I've been running Yabb forums for a few years on this and other servers.  Wink

Thanks again!

agh
  
Back to top
 
IP Logged
 
deti
Legacy Dev Team
Development Team
****
Offline



Posts: 2,650
Location: Prien am Chiemsee, Germany
Re: Setup with .cgi, not .pl files
Reply #2 - Apr 14th, 2009 at 8:00pm
Post Tools
agh wrote on Apr 14th, 2009 at 7:47pm:
Exactly what files I have to replicate ? (.pl -> .cgi)

Normally only YaBB.pl, AdminIndex.pl and Setup.pl

There is a new YaBB version since today! YaBB 2.4
  

Was immer Du tun kannst
oder erträumst tun zu können,
beginne es.
Kühnheit besitzt Genie,
Macht und magische Kraft.
Beginne es jetzt.
Whatever you can do
or dream you can,
begin it.
Boldness has genius,
power and magic in it.
Begin it now.
J. W. Goethe
Back to top
WWW  
IP Logged
 
agh
YaBB Newcomer
*
Offline



Posts: 40
Setup with .cgi, not .pl files
Reply #1 - Apr 14th, 2009 at 7:47pm
Post Tools
Hi there,

I've been using Yabb for a few years now. I've decided to upgrade from 2.1 to 2.3. Since 2006 I didn't update/mod at all my forum(s). But I'm still not able to make my Setup file to work.  Cry

In the past, I always had to modify the YaBB.pl and AdminIndex.pl to YaBB.cgi and AdminIndex.cgi (because of my server settings I suspect, .pl files get opened as plain text files in a browser). That simple trick worked for me.

But with 2.3, doing the same for these files and specially also for Setup.pl (-> Setup.cgi) doesn't work. I get the infamous 404 error.  Embarrassed

I know the URL is correct because otherwise I'd be redirected to the homepage (I have the server configured for this).

I've tried to edit the cgi files modifying some cross references here and there due to their new name (which I don't recall doing it last time when I installed 2.1, btw). But no success.  Cry

I've looked in the forum but none of the threads I've seen that dealt with this symptom has worked for me.

So, my general question would be:
How do I set up my YaBB 2.3 using cgi files ?
Exactly what files I have to replicate ? (.pl -> .cgi)
Exactly what files should I edit because of this ? (and how)

Thanks in advance!

(and sorry if this precise topic has been already covered, I did search... Wink)

agh
  
Back to top
 
IP Logged
 
deti
Legacy Dev Team
Development Team
****
Offline



Posts: 2,650
Location: Prien am Chiemsee, Germany
pl => cgi extension
Apr 14th, 2009 at 8:43pm
Post Tools
New
Admin\Settings_Advanced.pl
Setup.pl

in CVS.

If the extension was changed from pl to cgi this change was not overtaken in all files.
  

Was immer Du tun kannst
oder erträumst tun zu können,
beginne es.
Kühnheit besitzt Genie,
Macht und magische Kraft.
Beginne es jetzt.
Whatever you can do
or dream you can,
begin it.
Boldness has genius,
power and magic in it.
Begin it now.
J. W. Goethe
Back to top
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Topic Tools
 
  « Board Index ‹ Board  ^Top