Page Index Toggle Pages: 1
Topic Tools
Hot Topic (More than 10 Replies) Conversion problem (Read 12,327 times)
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,821
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Conversion problem
Reply #12 - Sep 11th, 2009 at 2:32pm
Post Tools
Well, Tim, I do have an idea for you - its kinda clunky, but it should work.

Turn on Preregistration with admin approval in Admin Center > Forum Controls > Members.

Now logout and use the Register option to create a new 'dummy' user.  Just do the pre-registration, accept the Agreement so YaBB would want to send a validation e-mail.  The result will be a pre-registration file.

Now - using FTP (or whatever) look in /Members for the .pre file that was generated  yournewloginname.pre.  Download the file.

its all plain text INCLUDING the target password. 

This file can be a template for getting your users in.

Simply edit the info, rename the file to membersYabbloginname.pre and upload to your /Members folder.

In my working theory, when you login as Admin you should get a notification that you have a new unvalidated registrant.  You can then use the Registration Log to Instant Validate, and then Instant Approve the 'new'(imported) member.

When you approve the member, the .pre file (which is really a .vars file template) will become membersYabbloginname.vars.

I have not tested this, but I did a pretty thorough analysis of registration a while ago when the module was being re-written and I think it will likely work.  If you have a LOT of members, use an advanced editor, if you are a whiz on scripts - you might want to write a script for this.  IF you do - please let us know - others might find it useful.

I'lll mention at this point that after pre-registration, YaBB converts passwords to a hash, so they cannot easily be recovered. (look in your admin.vars file)   That is the reasoning behind this method.

Good Luck
Smiley
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
TimD
YaBB Newcomer
*
Offline



Posts: 12
Re: Conversion problem
Reply #11 - Sep 11th, 2009 at 12:55am
Post Tools
My main interest is the member list.  I got the data out of the database and have in text and spreadsheet form. If I knew where to put the names, addresses and passwords I would be all set.

??
  
Back to top
 
IP Logged
 
TimD
YaBB Newcomer
*
Offline



Posts: 12
Re: Conversion problem
Reply #10 - Sep 10th, 2009 at 7:11pm
Post Tools
I checked with the host company and they said that there is no prefix. Just the database name and the individual tables inside.

Any ideas?
  

Image4.jpg (Attachment deleted)
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,821
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Conversion problem
Reply #9 - Sep 9th, 2009 at 8:04pm
Post Tools
I'll give you a GUESS (based on experience with shared MySQL databases).

The 'prefix' is usually a set of characters that are added (prepended) to a MySQL database to discriminate beteeen otherwise identical data.  Like 2 or 3 WordPress Blogs or PHPbb installs on the same server.  Or dozens, even hundreds on a webhost farm.

They are added to the Database schema name.  In this example from one of my servers - I added 'add_' to 'wptest' so I would be able to easily identify the dataset.  Its a test WordPress blog's database with a mnemonic title of 'add' to remind me of the client.

Inside the schema (dataset) are all the basic WP tables and data.   If you are on a hosted server you can proabably find this info either in your control panel, in the Admin part of PHPbb, or in whatever tool you may have for MySQL administration (often phpMyAdmin).  If this sounds like Greek, ask your hosting provider's support desk, they will be able to help you.

The value for prefix may have been automatically generated during the webost setup, its often things like your account or domain name.

Good Luck.

Smiley
  

MySQL_prefix-2.jpg (Attachment deleted)

I find your lack of faith disturbing.
Back to top
IP Logged
 
TimD
YaBB Newcomer
*
Offline



Posts: 12
Re: Conversion problem
Reply #8 - Sep 9th, 2009 at 6:36pm
Post Tools
Jon,

Yes I did upload Modules/Math/Fleximal.pl and set CHMOD to 755.

In the converted folder there are three folders; Boards, Members and Messages. The Messages folder is empty. The Members folder has two text files of 0 bytes length; membersinfo.txt and memberslist.txt. The Boards folder has two files; forum.control (0 bytes) and forum.master (40 bytes).

What am I supposed to put in the Prefix box when I run this converter. It clearly accepts the name and password for the database, but I have no idea what the Prefix is supposed to be.

Cheesy
  
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,821
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Conversion problem
Reply #7 - Sep 9th, 2009 at 6:27pm
Post Tools
Hi Tim

OK I setup the converted (but have no data to work with) - and read the 'read.me's.

You apparently chose the right driver.  Did you catch that part about uploading Modules/Math/Fleximal.pl?

Also - did you check in Converted and its subfolders to see what was there?

Good Luck
Smiley
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
TimD
YaBB Newcomer
*
Offline



Posts: 12
Re: Conversion problem
Reply #6 - Sep 8th, 2009 at 9:49pm
Post Tools
I'm up against a brick wall here.

Anybody?
  
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,821
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Conversion problem
Reply #5 - Sep 8th, 2009 at 6:06am
Post Tools
Sorry Tim, but I have no personal experience with the YaBB converter.  All the advice I have hand out in this area is based on general database knowledge + YaBB's characteristics operationally.

Is there a MySQL specific driver? (LOL, see how much I don't know?)

Good Luck
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
TimD
YaBB Newcomer
*
Offline



Posts: 12
Re: Conversion problem
Reply #4 - Sep 7th, 2009 at 7:38pm
Post Tools
No I'm afraid that did not help.

The database for our old forum (DC Forum) was was written in Php, uses a MySql database on our server, so I should be using the phpBB2.pl driver, is that correct?

When running converter.pl there is a field called "Prefix". What is this for and what is supposed to be entered there?

When I run the converter it tells me it took 0 seconds to run each script.

??

  
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,821
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Conversion problem
Reply #3 - Sep 7th, 2009 at 4:56pm
Post Tools
This is pretty much a guess - but we had problems with conversion/upgrades on V 2.4 if you attempted them while the board was in maintenance mode.   Guess what? - it didn't do them. I'm guessing the same logic applies here. Turn off Maintenance and give it a whirl.

Smiley
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
TimD
YaBB Newcomer
*
Offline



Posts: 12
Re: Conversion problem
Reply #2 - Sep 7th, 2009 at 4:05am
Post Tools
Yes it is.
  
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,821
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Conversion problem
Reply #1 - Sep 6th, 2009 at 10:21pm
Post Tools
Was the target YaBB board in Maintenance mode?

Huh

  

I find your lack of faith disturbing.
Back to top
IP Logged
 
TimD
YaBB Newcomer
*
Offline



Posts: 12
Conversion problem
Sep 6th, 2009 at 8:52pm
Post Tools
I have successfully installed YaBB 2.4 and have run conversion beta 4 for a PhPBB MySql database used in a previous forum (DC Forum software). I ran converter.pl and followed all of the steps, and during the process everything seemed to convert successfully. No error messages were encountered. I then went into the forum admin tools and rebuilt the maintenance controls. But nothing seems to have been imported into the forum.

Anys suggestions would be helpful.
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Topic Tools
 
  « Board Index ‹ Board  ^Top