YaBB Community and Support Forum
YaBB Home About YaBB Download YaBB YaBB Support Customize Your Forum Development Contribute to the Project
  Welcome, Guest. Please Login or Register


 
Pages: 1 2 3 
Topic Tools
 
Upgradeing from 2.1 to 2.4 (Read 16,533 times)
 Oct 2nd, 2009 at 9:06pm
There are no actions to perform.  

graffincDOTcom 
YaBB Newbie
*
Offline
Posts: 36


None
Upgradeing from 2.1 to 2.4
I followed the steps needed to update my Yabb forum but I have came up with this error from http://graffinc.com/yabb2/YaBB.pl,

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@graffinc.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


....where did I go wrong with this update?! I followed the steps one by one, but I'm novice with website building and this coding is out of my league. please help
 
 
IP Logged  
 Reply #1 - Oct 2nd, 2009 at 9:37pm
There are no actions to perform.  
Captain John 
Ex Member


None
Re: Upgradeing from 2.1 to 2.4
No need to code ....

What has probably happened was you failed to insure ALL the files under the yabb2 folder were transferred (uploaded) using AscII mode or you forgot to set the correct shebang (path to Perl) in the pl files as noted in the installation guide.

See the YaBB Codex http://codex.yabbforum.com/YaBB.pl?num=1190688617

Your site states Apache Server ... your running Windows ???
« Last Edit: Oct 2nd, 2009 at 9:40pm by N/A »  
 
IP Logged  
 Reply #2 - Oct 2nd, 2009 at 11:34pm
There are no actions to perform.  

graffincDOTcom 
YaBB Newbie
*
Offline
Posts: 36


None
Re: Upgradeing from 2.1 to 2.4
Quote:
No need to code ....

What has probably happened was you failed to insure ALL the files under the yabb2 folder were transferred (uploaded) using AscII mode or you forgot to set the correct shebang (path to Perl) in the pl files as noted in the installation guide.

See the YaBB Codex http://codex.yabbforum.com/YaBB.pl?num=1190688617

Your site states Apache Server ... your running Windows ???


honestly, I don't know... I'm using windows, I just host it off a site, I'm sorry if I mixed that up... I read the directions about the (path to perl), I dont even know what that is, and they were all listed as,
#!/usr/bin/perl --
and as described in the directions I assumed that was all that I didn't need to do anymore

and what is AscII mode?
I used my FTP to upload my files... was that wrong?

I'm sorry if these are basic silly questions but I've never had to do something like this
 
 
IP Logged  
 Reply #3 - Oct 3rd, 2009 at 5:25pm
There are no actions to perform.  
Captain John 
Ex Member


None
Re: Upgradeing from 2.1 to 2.4
graffincDOTcom wrote on Oct 2nd, 2009 at 9:06pm:
I followed the steps needed to update my Yabb forum


How did you install your forum to start with ?
Well .. lets guess your NOT hosting your site on a windows server.

See this post on the YaBB Codex, explaining FTP modes

http://codex.yabbforum.com/YaBB.pl?num=1192158230


 
 
IP Logged  
 Reply #4 - Oct 3rd, 2009 at 11:17pm
There are no actions to perform.  

graffincDOTcom 
YaBB Newbie
*
Offline
Posts: 36


None
Re: Upgradeing from 2.1 to 2.4
Quote:
graffincDOTcom wrote on Oct 2nd, 2009 at 9:06pm:
I followed the steps needed to update my Yabb forum


How did you install your forum to start with ?
Well .. lets guess your NOT hosting your site on a windows server.

See this post on the YaBB Codex, explaining FTP modes

http://codex.yabbforum.com/YaBB.pl?num=1192158230




It was a part of my hosting package, so I didnt have to do anything  Huh
 
 
IP Logged  
 Reply #5 - Oct 5th, 2009 at 8:39pm
There are no actions to perform.  

graffincDOTcom 
YaBB Newbie
*
Offline
Posts: 36


None
Re: Upgradeing from 2.1 to 2.4
Quote:
graffincDOTcom wrote on Oct 2nd, 2009 at 9:06pm:
I followed the steps needed to update my Yabb forum




How did you install your forum to start with ?
Well .. lets guess your NOT hosting your site on a windows server.

See this post on the YaBB Codex, explaining FTP modes

http://codex.yabbforum.com/YaBB.pl?num=1192158230



thats not the problem because I'm using WS_FTP LE which is listed on that link, I uploaded all files using that, any other suggestions?!
« Last Edit: Oct 5th, 2009 at 8:40pm by graffincDOTcom »  
 
IP Logged  
 Reply #6 - Oct 7th, 2009 at 8:30pm
There are no actions to perform.  
Captain John 
Ex Member


None
Re: Upgradeing from 2.1 to 2.4
graffincDOTcom wrote on Oct 5th, 2009 at 8:39pm:
thats not the problem because I'm using WS_FTP LE which is listed on that link


mmm That has NO relevance to the fact of Transfer Mode
 
 
IP Logged  
 Reply #7 - Oct 19th, 2009 at 12:55am
There are no actions to perform.  

graffincDOTcom 
YaBB Newbie
*
Offline
Posts: 36


None
Re: Upgradeing from 2.1 to 2.4
Quote:
graffincDOTcom wrote on Oct 5th, 2009 at 8:39pm:
thats not the problem because I'm using WS_FTP LE which is listed on that link


mmm That has NO relevance to the fact of Transfer Mode


ok, how do i do it in a proper transfer mode?
 
 
IP Logged  
 Reply #8 - Oct 19th, 2009 at 2:29pm
There are no actions to perform.  
Captain John 
Ex Member


None
Re: Upgradeing from 2.1 to 2.4
Each FTP program is different in relationship to their memu structure ... but somewhere there is usually options to Transfer as Binary, AscII or Auto transfer mode.
  Using Auto Transfer with most FTP's "will" cause corrupt files, due to it not recognizing the many different file extentions in YaBB.  A file that requires AscII, being transfer as Binary WILL corrupt and vice a versa with Binary files.
 
 
IP Logged  
 Reply #9 - Oct 28th, 2009 at 5:47pm
There are no actions to perform.  

graffincDOTcom 
YaBB Newbie
*
Offline
Posts: 36


None
Re: Upgradeing from 2.1 to 2.4
Quote:
Each FTP program is different in relationship to their memu structure ... but somewhere there is usually options to Transfer as Binary, AscII or Auto transfer mode.
   Using Auto Transfer with most FTP's "will" cause corrupt files, due to it not recognizing the many different file extentions in YaBB.  A file that requires AscII, being transfer as Binary WILL corrupt and vice a versa with Binary files.



ok, that makes sense and its helpful, for my YaBB update, which mode do I need to upload my files in?!
I appreciate your help so far
 
 
IP Logged  
 Reply #10 - Oct 28th, 2009 at 10:13pm
There are no actions to perform.  
Captain John 
Ex Member


None
Re: Upgradeing from 2.1 to 2.4
ALL the files under the yabb2 folder must be transferred in AscII mode
Under yabbfiles folder ALL images require Binary mode

All this info is readably available on the YaBB Codex or in The Quick Guide included in the YaBB software Forum downloads
 
 
IP Logged  
 Reply #11 - Feb 22nd, 2010 at 10:03pm
There are no actions to perform.  

graffincDOTcom 
YaBB Newbie
*
Offline
Posts: 36


None
Re: Upgradeing from 2.1 to 2.4
I'm about a day and a half from giving up... i followed the guides directions... uploaded all necessary files in AscII mode and whatever images in Binary mode... and im still receiving 500 internal server error,

unless there is an easier way, i may cancel and delete my forum, its been down for months and ive received complaints and disappointment from my members...

any last suggestions from anyone?
 
 
IP Logged  
 Reply #12 - Feb 22nd, 2010 at 11:45pm
There are no actions to perform.  

smith21 
Support Team
****
Offline
Posts: 4,659
Stockton - on - Tees,  England


YaBB 2.5
Re: Upgradeing from 2.1 to 2.4
graffincDOTcom wrote on Feb 22nd, 2010 at 10:03pm:
I'm about a day and a half from giving up...

Never Give In


graffincDOTcom wrote on Feb 22nd, 2010 at 10:03pm:
any last suggestions from anyone

Let someone else have a go for you
 
Cheers
...
WWW 1281257524  
IP Logged  
 Reply #13 - Feb 23rd, 2010 at 12:01am
There are no actions to perform.  
Captain John 
Ex Member


None
Re: Upgradeing from 2.1 to 2.4
smith21 wrote on Feb 22nd, 2010 at 11:45pm:
Let someone else have a go for you


  Send me a PM, I will need your ftp url, username/password
and your admin's password
 
 
IP Logged  
 Reply #14 - Feb 23rd, 2010 at 12:02am
There are no actions to perform.  

smith21 
Support Team
****
Offline
Posts: 4,659
Stockton - on - Tees,  England


YaBB 2.5
Re: Upgradeing from 2.1 to 2.4
There you go
@
graffincDOTcom sorted  Wink

 
Cheers
...
WWW 1281257524  
IP Logged  
Pages: 1 2 3 
Topic Tools
 

Get Yet another Bulletin Board at SourceForge.net. Fast, secure and Free Open Source software downloads Support This Project BoardMod - YaBB features and templates YaBB Codex - support on installation and usage YaBB Toolbar for your browser

YaBB Facebook Group Page

Vulnerability Scanner

Valid RSS Valid XHTML Valid CSS Powered by Perl
YaBB Chat and Support Community » Powered by YaBB 3.0 Beta!
YaBB Forum Software © 2000-2011. All Rights Reserved.