Page Index Toggle Pages: 1
Topic Tools
Normal Topic YaBB 2.4: Spell checker, detailed version check (Read 2,087 times)
Jet Li
Legacy Dev Team
Development Team
****
Offline



Posts: 6,588
Location: Hong Kong
Re: YaBB 2.4: Spell checker, detailed version check
Reply #2 - Jan 2nd, 2010 at 11:47am
Post Tools
@ Jens Brix Christiansen

New
SpellChecker.pl
in CVS.
  

PM me for YaBB Installation Service
Back to top
WWWGTalkFacebook  
IP Logged
 
deti
Legacy Dev Team
Development Team
****
Offline



Posts: 2,650
Location: Prien am Chiemsee, Germany
Re: YaBB 2.4: Spell checker, detailed version check
Reply #1 - Oct 19th, 2009 at 4:58pm
Post Tools
You are right Jens Brix Christiansen. Thanks for the advice!

We must change both to 'require' this will not cause other problems!
  

Was immer Du tun kannst
oder erträumst tun zu können,
beginne es.
Kühnheit besitzt Genie,
Macht und magische Kraft.
Beginne es jetzt.
Whatever you can do
or dream you can,
begin it.
Boldness has genius,
power and magic in it.
Begin it now.
J. W. Goethe
Back to top
WWW  
IP Logged
 
Jens Brix Christiansen
YaBB Newcomer
*
Offline



Posts: 26
Location: Frederiksberg, Denmark
YaBB 2.4: Spell checker, detailed version check
Oct 19th, 2009 at 9:32am
Post Tools
YaBB 2.4

SpellChecker.pl (YaBB 2.4, Revision 1.12) has a bug that sometimes breaks the detailed version check function.

On one of the sites that I run YaBB 2.4 on, LWP::UserAgent is not available. This implies that I can't use the SpellChecker, but that is not really a problem for that installation, so I haven't installed the missing module.  Here is the bug:

In line 27, the following code

Code
Select All
use LWP::UserAgent; 



is evaluated at BEGIN time, where it fails, crashing the detailed version function along with it.  Changing the code to

Code
Select All
require LWP::UserAgent; 



fixes the problem, allowing the detailed version function to complete successfully.

There is a similar problem in line 28:

Code
Select All
use HTTP::Request::Common; 



I don't know if the correction I have suggested causes other problems for SpellChecker.pl as such -- I don't have an installation to test that on.

  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Topic Tools
 
  « Board Index ‹ Board  ^Top