Page Index Toggle Pages: [1] 2 
Topic Tools
Hot Topic (More than 10 Replies) [Serious] IP not found from yabb im tag (Read 13,208 times)
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,818
Location: Land of the Blazing Sun!

YaBB 2.6.0
Re: [Serious] IP not found from yabb im tag
Reply #24 - Mar 4th, 2014 at 2:08pm
Post Tools
This Topic was moved here from YaBB 2 - Bugs [Open] [move by] JonB.
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
Captain John
Ex Member


Re: [Serious] IP not found from yabb im tag
Reply #23 - May 9th, 2010 at 1:24am
Post Tools
No .. disabled, but not fixed
  
Back to top
 
IP Logged
 
Matt Siegman
YaBB Legends (Inactive)
*
Offline



Posts: 3,380
Location: Wichita, KS
Re: [Serious] IP not found from yabb im tag
Reply #22 - May 8th, 2010 at 10:09pm
Post Tools
So is this fixed and commited?
  

-- Matt Siegman 8) Wish List
Back to top
 
IP Logged
 
Jet Li
Legacy Dev Team
Development Team
****
Offline



Posts: 6,588
Location: Hong Kong
Re: [Serious] IP not found from yabb im tag
Reply #21 - Apr 26th, 2010 at 7:01pm
Post Tools
Done
  

PM me for YaBB Installation Service
Back to top
WWWGTalkFacebook  
IP Logged
 
Captain John
Ex Member


Re: [Serious] IP not found from yabb im tag
Reply #20 - Apr 26th, 2010 at 6:53pm
Post Tools
Jet Li wrote on Apr 26th, 2010 at 6:20pm:
yes, should we remove it?


mmmmm .... maybe just add  #$user_ip
  till we get a solution
  
Back to top
 
IP Logged
 
Jet Li
Legacy Dev Team
Development Team
****
Offline



Posts: 6,588
Location: Hong Kong
Re: CVS Setup.pl
Reply #19 - Apr 26th, 2010 at 6:20pm
Post Tools
yes, should we remove it?
  

PM me for YaBB Installation Service
Back to top
WWWGTalkFacebook  
IP Logged
 
Captain John
Ex Member


Re: CVS Setup.pl
Reply #18 - Apr 26th, 2010 at 6:19pm
Post Tools
Jet Li wrote on Apr 26th, 2010 at 6:18pm:
I will check out what is wrong. update Session still there. Huh


cleared for me ....

Also should probably comment this line out in Main.lng (till we get a fix)

Quote:
IP not found, please change $user_ip in $lang/Main.lng
  
Back to top
 
IP Logged
 
Jet Li
Legacy Dev Team
Development Team
****
Offline



Posts: 6,588
Location: Hong Kong
Re: CVS Setup.pl
Reply #17 - Apr 26th, 2010 at 6:18pm
Post Tools
I will check out what is wrong. update Session still there. Huh
  

PM me for YaBB Installation Service
Back to top
WWWGTalkFacebook  
IP Logged
 
Captain John
Ex Member


Re: CVS Setup.pl
Reply #16 - Apr 26th, 2010 at 6:17pm
Post Tools
Jet Li wrote on Apr 26th, 2010 at 6:14pm:
Should Maintenance Mode by default off on after Setup? Then will works.


mmmmm according to upgrade in quick-guide, should be maintenance mode by default, but it should allow admin in.
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: CVS Setup.pl
Reply #15 - Apr 26th, 2010 at 6:16pm
Post Tools
went into Settings.pl disabled sessions and maintenance mode, got in.
  
Back to top
 
IP Logged
 
Jet Li
Legacy Dev Team
Development Team
****
Offline



Posts: 6,588
Location: Hong Kong
Re: CVS Setup.pl
Reply #14 - Apr 26th, 2010 at 6:14pm
Post Tools
Should Maintenance Mode by default off on after Setup? Then will works.
  

PM me for YaBB Installation Service
Back to top
WWWGTalkFacebook  
IP Logged
 
Captain John
Ex Member


CVS Setup.pl
Reply #13 - Apr 26th, 2010 at 6:05pm
Post Tools
  Run the New Setup.pl, finished successfully,
Screen went to Administrator Login, Top of forum Welcomed Administrator, so no need to login (right ? couldn't anyway) ... Showed Forum in Maintenance Mode, would Not accept clicking on User CP, Update Session, etc., or even Logout ....Continued to display login.
   Can't do anything ......

removed url ..........................
« Last Edit: Apr 26th, 2010 at 6:18pm by »  
Back to top
 
IP Logged
 
Jet Li
Legacy Dev Team
Development Team
****
Offline



Posts: 6,588
Location: Hong Kong
Re: [Serious] IP not found from yabb im tag
Reply #12 - Mar 27th, 2010 at 8:55pm
Post Tools
hm, now display "IP not found, please change $user_ip in $lang/Main.lng" on my Testforum.

More problems:
- Logout and login you get constant "Update Session" with an empty IP.
« Last Edit: Mar 27th, 2010 at 9:05pm by Jet Li »  

empty-ip.png ( 15 KB | 236 Downloads )
empty-ip.png

PM me for YaBB Installation Service
Back to top
WWWGTalkFacebook  
IP Logged
 
MF-B
Development Team
****
Offline



Posts: 2,405
Location: Moscow, Russia

YaBB 2.4
Re: [Serious] IP not found from yabb im tag
Reply #11 - Mar 27th, 2010 at 8:11pm
Post Tools
New Main.lng in CVS
  

Stand!
Back to top
IP Logged
 
Captain John
Ex Member


Re: IP not found from yabb im tag
Reply #10 - Mar 15th, 2010 at 4:45am
Post Tools
Then this one should be changed also .. to reflect where the change or entry should be made as well

Code
Select All
Error.lng
      Line 42: 'no_ip' => "IP not found, please change $user_ip in $lang",  



to
Code
Select All
Error.lng
      Line 42: 'no_ip' => "IP not found, please edit $user_ip in $lang/Main.lng", 




Edited:
Just trying to understand.  Hate to beat a dead horse or be asking so many questions, "but" if this is being thrown by admin's IP, why the error for ALL admins ?  Wouldn't or shouldn't it have looked at each individually ? or as I assumed it was generated by the admins Welcome message PM not being sent by a valid user (admin). Dev ????

   Note this was discovered on a Y2.1 forum, seems the code (even partially) still exists within Y2.4 (and possibly Y3).

in Load.pl, found:
Code
Select All
sub LoadIMs {
	return if ($iamguest || $PM_level == 0 || ($maintenance && !$iamadmin) || ($PM_level == 2 && (!$iamadmin && !$iamgmod && !$iammod)) || ($PM_level == 3 && (!$iamadmin && !$iamgmod)));

	&buildIMS($username, 'load') unless exists ${$username}{'PMmnum'};

	my $imnewtext;
	if (${$username}{'PMimnewcount'} == 1) { $imnewtext = qq~<a href="$scripturl?action=imshow;caller=1;id=-1">1 $load_txt{'155'}</a>~; }
	elsif (!${$username}{'PMimnewcount'}) { $imnewtext = $load_txt{'nonew'}; }
	else { $imnewtext = qq~<a href="$scripturl?action=imshow;caller=1;id=-1">${$username}{'PMimnewcount'} $load_txt{'154'}</a>~; }

	if (${$username}{'PMmnum'} == 1) { $yyim = qq~$load_txt{'152'} <a href="$scripturl?action=im">${$username}{'PMmnum'} $load_txt{'471'}</a>, $imnewtext~; }
	elsif (!${$username}{'PMmnum'} && !${$username}{'PMimnewcount'}) { $yyim = qq~$load_txt{'152'} <a href="$scripturl?action=im">${$username}{'PMmnum'} $load_txt{'153'}</a>~; }
	else { $yyim = qq~$load_txt{'152'} <a href="$scripturl?action=im">${$username}{'PMmnum'} $load_txt{'153'}</a>, $imnewtext~; }

	if (!$user_ip && $iamadmin) { $yyim .= qq~<br /><b>$load_txt{'773'}</b>~; }
} 



in BoardIndex.pl found:
Code
Select All
  foreach (@logentries) {
    ($name, $date1, $last_ip, $last_host) = split(/\|/, $_);
    if (!$last_ip) { $last_ip = qq~</i></span><span class="error">$boardindex_txt{'no_ip'}</span><span class="small"><i>~; }
    my $is_a_bot = &Is_Bot($last_host);
 

« Last Edit: Mar 27th, 2010 at 2:49am by »  
Back to top
 
IP Logged
 
Page Index Toggle Pages: [1] 2 
Topic Tools
 
  « Board Index ‹ Board  ^Top