Page Index Toggle Pages: [1] 2 
Topic Tools
Hot Topic (More than 10 Replies) sudden slow load times (Read 4,646 times)
sekrapa
YaBB Newcomer
*
Offline



Posts: 5
sudden slow load times
Apr 16th, 2010 at 9:23pm
Post Tools
Hi. Have just upgraded our forum from version 1.3 to the latest 2.4. What a difference, it feels great and has tons more features and better security. The upgrade was a breeze as well, I should have done it ages ago.

Anyway, all was running fine until today when all of a sudden each page takes about 6 seconds to load. I have turned off all the logging, disabled some security settings in the hope of returning it back to normal, but no avail. Even rebuilt all the member lists, thread etc.

The forum is at www.homewinemaking.co.uk/forum/YaBB.pl

I am at a loss. Has anyone ever had this happen, and if so how did you rectify it?

Any help would be appreciated as it would be great to have the speed again.

Andrew

EDIT:
Forgot to mention it is on a Unix server, and the main site www.homewinemaking.co.uk flies along, and the forum is in a directory of this site. I must have changed a setting somewhere, but cannot see where.  Undecided, Could I upload main YaBB.pl, and other files again, or would that stop the board working?
« Last Edit: Apr 16th, 2010 at 9:36pm by sekrapa »  
Back to top
 
IP Logged
 
OH Eng
Past Team Members
Documentation Team
Offline



Posts: 4,026
Location: Pensacola, Florida USA
Re: sudden slow load times
Reply #1 - Apr 16th, 2010 at 10:31pm
Post Tools
When I try to load your forum, my status bar (Firefox 3.0.15) says "waiting for www.homewinemaking.co.uk" for 9-10 seconds, then the forum loads in about 1 second or less.  Almost the same thing when I tried your main site the first two times... after that it loads very quickly.  I'm wondering if it might be a cache issue.

Just curious... what do you have set for the first three setting in your Admin Center/Advanced Settings/Advanced Tab?
  

 
Back to top
 
IP Logged
 
sekrapa
YaBB Newcomer
*
Offline



Posts: 5
Re: sudden slow load times
Reply #2 - Apr 16th, 2010 at 11:34pm
Post Tools
Thanks for replying so quickly. I have changed these to see if it would make a difference to speed, then changed them back.

Currently the first three settings are compression with Gzip, checked and then unchecked.

You are quite right. It is like it thinks about it and after 6-10 seconds, completes the task of fetching the data. I have opened 2 tabs, one the main site, the other the forum. The main site seems to fetch the pages quickly, but the forum currently waits and thinks about it before fetching them. Totally weird. Everything was fine until yesterday morning, double weird.
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: sudden slow load times
Reply #3 - Apr 17th, 2010 at 2:28am
Post Tools
sekrapa wrote on Apr 16th, 2010 at 11:34pm:
The main site seems to fetch the pages quickly,


but not as fast as it should for content ... there is a noticeable delay, yes, see the delay more for the forum, but 5, 10 times the content of the home page.

   I would send a ticket to your Host support ... note the delay .. but don't lead them to think it is the forum only.
  
Back to top
 
IP Logged
 
sekrapa
YaBB Newcomer
*
Offline



Posts: 5
Re: sudden slow load times
Reply #4 - Apr 17th, 2010 at 6:07am
Post Tools
OK, thanks for the advice, will do that.
  
Back to top
 
IP Logged
 
OH Eng
Past Team Members
Documentation Team
Offline



Posts: 4,026
Location: Pensacola, Florida USA
Re: sudden slow load times
Reply #5 - Apr 17th, 2010 at 3:20pm
Post Tools
sekrapa, the attached text file might be of use to you.  That is what I see in firebug (a FireFox plugin).  Notice some of those items take 4 or 5 seconds or so to respond to the request.  The graphics seem to load okay, it's the other stuff like getting the .css and such that take seconds.  I think that is why it appears to "hang" for a bit, then the site shows up in a burst.

This might help you/your host solve the issue.  Good luck.

  

homewinemakingcouk.txt ( 6 KB | 111 Downloads )

 
Back to top
 
IP Logged
 
sekrapa
YaBB Newcomer
*
Offline



Posts: 5
Re: sudden slow load times
Reply #6 - Apr 17th, 2010 at 9:59pm
Post Tools
Wow, thanks for the help, it really is much appreciated.
  
Back to top
 
IP Logged
 
sekrapa
YaBB Newcomer
*
Offline



Posts: 5
Re: sudden slow load times
Reply #7 - Apr 19th, 2010 at 7:24pm
Post Tools
Thanks for all your help, it was a server issue and all is corrected now.
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: sudden slow load times
Reply #8 - Apr 19th, 2010 at 7:58pm
Post Tools
Great .. glad they were able to fix, especially not blaming our software (we get that too much)  Wink
  
Back to top
 
IP Logged
 
BjB
YaBB Newcomer
*
Offline



Posts: 14
Re: sudden slow load times
Reply #9 - Apr 26th, 2010 at 2:23pm
Post Tools
Do you know what is was? Mine is doing exactly that on my Apache2 Ubuntu server box on the LAN! There are no errors anywhere and it just lags up to 6 seconds before doing anything and then loads straight away.

Any ideas?

Cheers

Bj
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: sudden slow load times
Reply #10 - Apr 26th, 2010 at 3:35pm
Post Tools
Do you have a Google script embeded in the Template ?
  
Back to top
 
IP Logged
 
BjB
YaBB Newcomer
*
Offline



Posts: 14
Re: sudden slow load times
Reply #11 - Apr 27th, 2010 at 8:38am
Post Tools
no it's stock out of the zip.
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: sudden slow load times
Reply #12 - Apr 27th, 2010 at 4:24pm
Post Tools
Is this a personal server or hosted ?  what's the URL to your site ?  Hard to guess what might be happening.
  
Back to top
 
IP Logged
 
BjB
YaBB Newcomer
*
Offline



Posts: 14
Re: sudden slow load times
Reply #13 - Apr 28th, 2010 at 1:13pm
Post Tools
It's just on my home server (ubuntu 9.04 server) running out to our neighbourhood wifi (not on the internet). I have YaBB2.1 working perfectly and fast, but 2.4 is very slow to respond just like sekrapa described in the first post.

Both YaBB2.1 and 2.4 are running on the same server but different virtual_hostnames and directories of course.


I could use DYNDNS and put it on the interweb if you need me to...

edit: 2.2 works fine it's just 2.4.....
« Last Edit: Apr 28th, 2010 at 3:46pm by BjB »  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: sudden slow load times
Reply #14 - Apr 28th, 2010 at 3:57pm
Post Tools
See this post http://www.yabbforum.com/community/YaBB.pl?num=1266621065/12#12

  This might at least narrow down the problem using that utility

See this page for info http://support.microsoft.com/kb/314868
« Last Edit: Apr 28th, 2010 at 4:00pm by »  
Back to top
 
IP Logged
 
Page Index Toggle Pages: [1] 2 
Topic Tools