Page Index Toggle Pages: [1] 2 
Topic Tools
Hot Topic (More than 10 Replies) 404 - again.. (HELP) (Read 4,731 times)
Captain John
Ex Member


Re: 404 - again.. (HELP)
Reply #23 - Jul 21st, 2010 at 2:46am
Post Tools
L_ith wrote on Jul 20th, 2010 at 7:16pm:
All cgi-bin folders on all the servers my host used is "down"


Yep ... a 404, since YaBB.pl could not be found.
  
Back to top
 
IP Logged
 
L_ith
Full Member
***
Offline



Posts: 246
Re: 404 - again.. (HELP)
Reply #22 - Jul 20th, 2010 at 7:16pm
Post Tools
Found out,

All cgi-bin folders on all the servers my host used is "down" and the server guys are doing there "best" to fix this problem.

Also, i have unlimited bandwidth.. i also think it could of been a refresh error this happend when i refresh the board once via (F5) thats when this happend..


anyway at the moment they are fixing this issue.
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: 404 - again.. (HELP)
Reply #21 - Jul 19th, 2010 at 6:35pm
Post Tools
« Last Edit: Jul 19th, 2010 at 6:35pm by »  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: 404 - again.. (HELP)
Reply #20 - Jul 19th, 2010 at 6:17pm
Post Tools
Quote:
HTTP 503 is the standard HTTP error that means "Service Unavailable."

503 Service Unavailable
Quote:
The server is currently unavailable (because it is overloaded or down for maintenance).[2] Generally, this is a temporary state.
and is more search engine friendly than a 404

Quote:
You often see HTTP 503 when a website has exceeded its monthly bandwidth allowance.

this is not a 503 it is norm 509
Quote:
509 Bandwidth Limit Exceeded (Apache bw/limited extension)
This status code, while used by many servers, is not specified in any RFCs.


Quote:
* The server may be forbidden from giving you the requested document

this is 401 or 403

you can see more here
http://en.wikipedia.org/wiki/List_of_HTTP_status_codes
and
http://www.askapache.com/htaccess/apache-status-code-headers-errordocument.html
thort i shud post the links in hope this helps
« Last Edit: Jul 19th, 2010 at 6:24pm by xnoddyx »  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Captain John
Ex Member


Re: 404 - again.. (HELP)
Reply #19 - Jul 19th, 2010 at 6:02pm
Post Tools
Of course that can be setup that way, "But" on a default setup, Perl is not called directly.  For example a url will direct to YaBB.pl, if that file is not found, you get a 404 error.   YaBB.pl uses the OS (which is Perl) and if not present, instead of the script running, it types the file to the output (screen) and displays the text of the script. No 404 error.

HTTP 503 is the standard HTTP error that means "Service Unavailable."

    * It can mean that a required program has not yet been started on the server or has crashed
    * HTTP 503 might indicate other types of network or server errors.
    * You often see HTTP 503 when a website has exceeded its monthly bandwidth allowance.
    * A Connection to a database has failed or is misconfigured
    * The server may be forbidden from giving you the requested document
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: 404 - again.. (HELP)
Reply #18 - Jul 19th, 2010 at 2:23am
Post Tools
Quote:
just be cause the Perl Interpreter is not available. Perl not found would cause, when calling a script (pl file), to download (print to screen), not a 404.

not on my server i have it set up when i have Perl and php off i get .pl and .php redirect to 503 as some hosts i have used do this but to 404 and not 503 and when i asked them why they say it lessons server load and thort i shud do this as well when i started my server up
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Captain John
Ex Member


Re: 404 - again.. (HELP)
Reply #17 - Jul 17th, 2010 at 8:00pm
Post Tools
L_ith wrote on Jul 16th, 2010 at 8:34pm:
i don't get it... she was fine before then BAM 404..... the sites fine but the forum? whats going on? any ideas?

i also just re-uplaoded a backed up version of "Varibles" folder still getting 404

@ L_ith You need to be more patient and also to state more clearly what the problem is.
   A 404 "means" 'Not Found', which is NOT an error, but a result from an error.  Knowing "what" can not be found is important !
   It is hard to get a 404, just be cause the Perl Interpreter is not available. Perl not found would cause, when calling a script (pl file), to download (print to screen), not a 404.
   "Usually" a 404 (Not Found) is caused by a file not being there (where the link directs to) OR the link itself is incorrect to directory (folder) where the file is.

  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: 404 - again.. (HELP)
Reply #16 - Jul 16th, 2010 at 10:13pm
Post Tools
glad to help you
I Can't Complain i am my host lol
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
L_ith
Full Member
***
Offline



Posts: 246
Re: 404 - again.. (HELP)
Reply #15 - Jul 16th, 2010 at 9:43pm
Post Tools
And

Just uploaded a "perl" contatc form and that wont work


all perl files are located in cgi-bin


darn HOST

i think its the host now yea? we both agree? lol

thanks for ya help !
  
Back to top
 
IP Logged
 
L_ith
Full Member
***
Offline



Posts: 246
Re: 404 - again.. (HELP)
Reply #14 - Jul 16th, 2010 at 9:35pm
Post Tools
Well i just uploaded a 1.4SP YaBB board as a test and that also gave me a 404


has to be my host..

  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: 404 - again.. (HELP)
Reply #13 - Jul 16th, 2010 at 9:28pm
Post Tools
it cant be The Guardian that is giving you the 404 as L_ith wrote on Jul 16th, 2010 at 8:18pm:
my .htaccess is empty

the printenv.pl was giving you the 404 as well and that file has nuthing to do with YaBB so it is your host that is having a prob
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
L_ith
Full Member
***
Offline



Posts: 246
Re: 404 - again.. (HELP)
Reply #12 - Jul 16th, 2010 at 9:23pm
Post Tools
I, cant do that,

my host only lets me "RUN" pelr in the "cgi-bin" Folder where the forum is located, if i add printenv.pl to my root.. it will just act like a download, i only have perl enabled in my cgi-bin folder and perl is enabled all the time (unless they want to upgrade)

i think the problem lies within "The Guardian" because you see, i have had this problem before but i fixed it by deleting the ips... but now i have deleted them and i still have this error... so this makes me believe that the guardian has banned/blocked something on its own and its caused this "F#%&* up etc.."

Any ideas?  where is the guardians banned files??

« Last Edit: Jul 16th, 2010 at 9:25pm by L_ith »  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: 404 - again.. (HELP)
Reply #11 - Jul 16th, 2010 at 9:16pm
Post Tools
ok upload the printenv.pl to your root Dir if it dont load there then perl is off on your server and and you shud call your host
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
L_ith
Full Member
***
Offline



Posts: 246
Re: 404 - again.. (HELP)
Reply #10 - Jul 16th, 2010 at 9:14pm
Post Tools
the whole website is fine downloads fine everything is fine

i just came on a few hours ago saw the forum was fine

(i was not logged in)


i refreshed because it was slow, then BAM 404 and its been like that since


i am baffled man.
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: 404 - again.. (HELP)
Reply #9 - Jul 16th, 2010 at 9:07pm
Post Tools
what is the url of your website?
is the rest of your website working???
i.e: if http://www.mywebsite.com/ is 404 as well then you shud call your host
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Page Index Toggle Pages: [1] 2 
Topic Tools
 
  « Board Index ‹ Board  ^Top