YaBB Community and Support Forum
YaBB Home About YaBB Download YaBB YaBB Support Customize Your Forum Development Contribute to the Project
  Welcome, Guest. Please Login or Register


 
Pages: 1 2 
Topic Tools
 
Problem with email on 2.5 (Read 9,596 times)
 Aug 11th, 2010 at 12:04am
There are no actions to perform.  

Bikerman 
YaBB Newbie
*
Offline
Posts: 43
Cheshire - UK


None
Problem with email on 2.5
Since we upgraded the Science Forums to 2.5 most things have been good but we only recently noticed that the monthly newsletter is no longer going out to members. Members select whether to subscribe to the newsletter by ticking on a group membership and we then send the newsletter to that group via the backend. When I go into admin and select email members/export group/download group I get only 2 entries - there should be many more. I can email a member from this facility, but if I try to email a group then it doesn't go (or perhaps it does, but the group membership list is somehow screwed up.
I checked the group selection and my user has the group selected but doesn't appear when I export/download the group listing.
Any ideas what could be wrong here? - I seem to be having a similar problem with other groups that show up OK for the members.
I should say that this problem has only materialised since the upgrade to 2.5

best wishes
Chris S
http://sciencefile.org/forums
 
WWW  
IP Logged  
 Reply #1 - Aug 11th, 2010 at 3:34am
There are no actions to perform.  
Captain John 
Ex Member


None
Re: Problem with email on 2.5
This membergroup is selectable in users/members profile ?

Have you run Maintenance Functions
# Rebuild Members List
# Recount Membership
# Rebuild Members History
# Rebuild Notifications Files

in Admin Center ?
 
 
IP Logged  
 Reply #2 - Aug 11th, 2010 at 4:22am
There are no actions to perform.  

Bikerman 
YaBB Newbie
*
Offline
Posts: 43
Cheshire - UK


None
Re: Problem with email on 2.5
I've run most if not all, but it would probably be as well to make sure and do them all again...do you think??

Yes - the group is selectable in the profile - the users have permission to add themselves to it - it seemed the easy way to let the users decide if they wanted the newsletter or not.

OK - I've rerun all the maintenance utils above - no change.
« Last Edit: Aug 11th, 2010 at 4:27am by Bikerman »  
WWW  
IP Logged  
 Reply #3 - Aug 11th, 2010 at 4:28am
There are no actions to perform.  

Bikerman 
YaBB Newbie
*
Offline
Posts: 43
Cheshire - UK


None
Re: Problem with email on 2.5
PS - I should add that the email stopped working altogether on the YaBB engine setting so I've currently got it set for unix sendmail.

Oh - and the other thought I had was maybe some permissions had got altered, so I ran a script to set them all to recommended values (but the problem predates that run, and the run hasn't solved it).
« Last Edit: Aug 11th, 2010 at 4:31am by Bikerman »  
WWW  
IP Logged  
 Reply #4 - Aug 11th, 2010 at 3:55pm
There are no actions to perform.  
Captain John 
Ex Member


None
Re: Problem with email on 2.5
I see you have 2 membergroups to select from ...
Newsletter Recipient
Newsletter Subscriber

I selected both ... email me
from my profile (Cj)
from Admin Center (directly)
check if member of membergroups
email to membergroup

 
 
IP Logged  
 Reply #5 - Aug 11th, 2010 at 7:29pm
There are no actions to perform.  

Bikerman 
YaBB Newbie
*
Offline
Posts: 43
Cheshire - UK


None
Re: Problem with email on 2.5
OK Cap...doing that now. I predict that the email to you as a member will be fine but you won't appear in either group. I setup the subscriber group as a test whilst trying to debug - the original group is the recipients one.
 
WWW  
IP Logged  
 Reply #6 - Aug 11th, 2010 at 7:38pm
There are no actions to perform.  

Bikerman 
YaBB Newbie
*
Offline
Posts: 43
Cheshire - UK


None
Re: Problem with email on 2.5
OK Cap'n - done both.
Something else has now developed. The back-end admin has lost all formatting - looks like the template has somehow failed. I just get a white screen with all the elements in the wrong place. Still usable, but pretty messed-up.
 
WWW  
IP Logged  
 Reply #7 - Aug 11th, 2010 at 8:30pm
There are no actions to perform.  

Bikerman 
YaBB Newbie
*
Offline
Posts: 43
Cheshire - UK


None
Re: Problem with email on 2.5
Update - sorted the backend - the script I ran to reset default permissions screwed up somewhere and set templates to 660 instead of 666. I'm hoping a similar error is causing the email problem. Just going through manually and setting the correct chmods...
 
WWW  
IP Logged  
 Reply #8 - Aug 11th, 2010 at 8:41pm
There are no actions to perform.  

Bikerman 
YaBB Newbie
*
Offline
Posts: 43
Cheshire - UK


None
Re: Problem with email on 2.5
OK...all permissions set to suggested default values (as per the Codex advice).
Still not able to export the membergroups (or I should say that what is downloaded is not related to the actual group memberships).
Should I rerun the maintenance routines now, with the permissions changed?
 
WWW  
IP Logged  
 Reply #9 - Aug 12th, 2010 at 3:36am
There are no actions to perform.  
Captain John 
Ex Member


None
Re: Problem with email on 2.5
yes ......


Edited:
The ONLY email I recieved was Test email
This is sent to you as a member from the backend
« Last Edit: Aug 12th, 2010 at 4:34am by N/A »  
 
IP Logged  
 Reply #10 - Aug 12th, 2010 at 4:44am
There are no actions to perform.  

Bikerman 
YaBB Newbie
*
Offline
Posts: 43
Cheshire - UK


None
Re: Problem with email on 2.5
Yep - as I thought. I did send to the membergroups but it doesn't work.
I re-ran the maintenance routines but no effect.
If I export and download the groups (in the 'email the members' section) I get a couple of entries for each which shouldn't be in there and none of the ones that should.
« Last Edit: Aug 12th, 2010 at 4:49am by Bikerman »  
WWW  
IP Logged  
 Reply #11 - Aug 12th, 2010 at 8:13am
There are no actions to perform.  

Bikerman 
YaBB Newbie
*
Offline
Posts: 43
Cheshire - UK


None
Re: Problem with email on 2.5
The following may be relevant....
When I export and download the membergroups I get a csv file with the heading fields:
name ; email address
but the entries that appear actually have
email address ; group (where group is the 'number of postings' dependant ranking).

It seems that the members are being output with the fields transposed by 1 place, as well as the wrong members being actually output....odd
« Last Edit: Aug 12th, 2010 at 8:25am by Bikerman »  
WWW  
IP Logged  
 Reply #12 - Aug 12th, 2010 at 4:23pm
There are no actions to perform.  

Bikerman 
YaBB Newbie
*
Offline
Posts: 43
Cheshire - UK


None
Re: Problem with email on 2.5
If you need admin or global mod access to the forum CJ then let me know and we'll work something out.
 
WWW  
IP Logged  
 Reply #13 - Aug 12th, 2010 at 6:07pm
There are no actions to perform.  
Carsten 
Ex Member


None
Re: Problem with email on 2.5
In Admin/MailMembers.pl find
Code Select All
		(undef, $memrealname, $mememail, $memposition, $memposts, $memaddgrp, undef) = split(/\|/, $memberinf{$user}, 7); 


and replace it with
Code Select All
		($memrealname, $mememail, $memposition, $memposts, $memaddgrp) = split(/\|/, $memberinf{$user}); 

 
 
IP Logged  
 Reply #14 - Aug 12th, 2010 at 9:40pm
There are no actions to perform.  

Bikerman 
YaBB Newbie
*
Offline
Posts: 43
Cheshire - UK


None
Re: Problem with email on 2.5
Done and I think you've cracked it again. Our gratitude builds to alarming heights. Many many thanks for the quick attention to this and don't forget - if there is anything we can do for you then a bunch of scientists, IT folk, engineers and assorted others will be happy to return the favour if we can...
 
WWW  
IP Logged  
Pages: 1 2 
Topic Tools
 

Get Yet another Bulletin Board at SourceForge.net. Fast, secure and Free Open Source software downloads Support This Project BoardMod - YaBB features and templates YaBB Codex - support on installation and usage YaBB Toolbar for your browser

YaBB Facebook Group Page

Vulnerability Scanner

Valid RSS Valid XHTML Valid CSS Powered by Perl
YaBB Chat and Support Community » Powered by YaBB 3.0 Beta!
YaBB Forum Software © 2000-2011. All Rights Reserved.