Page Index Toggle Pages: 1 [2] 
Topic Tools
Hot Topic (More than 10 Replies) GreyBox images bugs (Read 9,598 times)
Carsten
Ex Member


Re: GreyBox images bugs
Reply #3 - Aug 17th, 2010 at 3:53pm
Post Tools
Guess the fix would be:

In YaBBC.pl find
Code
Select All
sub DoUBBC { 


and add after
Code
Select All
	$image_type = $_[0]; 


then find and remove
Code
Select All
	my $image_type = $_[0]; 

  
Back to top
 
IP Logged
 
Carsten
Ex Member


Re: GreyBox images bugs
Reply #2 - Aug 17th, 2010 at 3:22pm
Post Tools
The problem is caused by this code - i don't have the faintest idea why the 'extra' sub routine was added in 2.5 - so i've asked in the proper place?? My suggestion is to remove the highlighted code - but better wait for any answer from the dev. in question Wink

Code
Select All
sub DoUBBC {
  my $msg = _do_ubbc($message);
	$message = $msg;
}

sub _do_ubbc {
  my $message = join "", @_; 




Edited:
Having had a closer look at the code i see it has to do with the 'noparse' tag - still causes a bug though
« Last Edit: Aug 17th, 2010 at 3:40pm by »  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: GreyBox images bugs
Reply #1 - Aug 17th, 2010 at 2:09pm
Post Tools
confirmed ........
  
Back to top
 
IP Logged
 
Fduch
Junior Member
**
Offline



Posts: 57
Location: .
GreyBox images bugs
Aug 17th, 2010 at 7:55am
Post Tools


For example, see the source code of this message:

<img src="http://www.yabbforum.com/img/header2_left.png" name="signat_img_resize_1" alt="..." title="..." border="0" style="display: inline; " width="400" height="152">

but must be:

<img src="http://www.yabbforum.com/img/header2_left.png" name="post_img_resize_1" alt="..." title="..." border="0" style="display: inline; " width="400" height="152">
« Last Edit: Aug 17th, 2010 at 7:55am by Fduch »  
Back to top
WWW  
IP Logged
 
Page Index Toggle Pages: 1 [2] 
Topic Tools
 
  « Board Index ‹ Board  ^Top