Page Index Toggle Pages: [1] 2 
Topic Tools
Hot Topic (More than 10 Replies) ACK - unsupported compression issue (Read 5,930 times)
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online



Posts: 2,363
Location: Earth

YaBB 2.6.1
ACK - unsupported compression issue
Sep 11th, 2010 at 12:36am
Post Tools
This has been coming and going ever since I upgraded from 2.4 to 2.5 yesterday -

Quote:
Content Encoding Error

The page you are trying to view cannot be shown because it uses an invalid or unsupported form of compression.

    *   Please contact the website owners to inform them of this problem.

      
      


I don't think this is an actual YaBB issue, but I'd like to confirm that no one else has had this issue before I yell at my host.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Jet Li
Legacy Dev Team
Development Team
****
Offline



Posts: 6,588
Location: Hong Kong
Re: ACK - unsupported compression issue
Reply #1 - Sep 11th, 2010 at 8:09am
Post Tools
change this in Variables/Settings.pl

Code
Select All
$gzcomp = 2;                                      # GZip compression: 0 = No Compression, 1 = External gzip, 2 =
                                                  #  Zlib::Compress 



Set it to 0 and you can access to your forum again. Smiley
  

PM me for YaBB Installation Service
Back to top
WWWGTalkFacebook  
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online



Posts: 2,363
Location: Earth

YaBB 2.6.1
Re: ACK - unsupported compression issue
Reply #2 - Sep 11th, 2010 at 4:45pm
Post Tools
From installed modules:

Compress::Bzip2 - is not loaded,
Compress::Zlib   Installed
Archive::Tar         Installed
Archive::Zip      Installed

I did set it to 0 - so far so good. (The odd thing is I have another board on the same hosting service and I'm had absolutely no problems with that one.)
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online



Posts: 2,363
Location: Earth

YaBB 2.6.1
Re: ACK - unsupported compression issue
Reply #3 - Sep 11th, 2010 at 11:09pm
Post Tools
Okay, now I'm not getting the unsupported compression error message, but at the bottom of every page is:

Quote:
OK

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, cgiadmin@yourhostingaccount.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


Now, everything above this is correct and nothing is showing in either the cgi-bin error logs OR the server logs. And sometimes - not always, the page tries to load twice.
Quote:
<img src=
HTTP/1.1 200 OK
Date: Sat, 11 Sep 2010 23:02:50 GMT
Content-Type: text/html; charset=ISO-8859-1
Connection: close
Server: Apache
Cache-Control: no-cache, must-revalidate
Pragma: no-cache
Content-Length: 37725



The problem of the error warning is also showing up in the Admin main page.

(The site in question is http://www.bigapricot.org/cgi-bin/yabb2/YaBB.pl)
« Last Edit: Sep 11th, 2010 at 11:10pm by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online



Posts: 2,363
Location: Earth

YaBB 2.6.1
Re: ACK - unsupported compression issue
Reply #4 - Sep 11th, 2010 at 11:30pm
Post Tools
Okay - venting here must have magic because everything seems okay for the time being - no doubt my freaking expletive deleted hosting service tech heads decided to play with something.

We need a steam coming out of ears Smilie.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online



Posts: 2,363
Location: Earth

YaBB 2.6.1
Re: ACK - unsupported compression issue
Reply #5 - Sep 12th, 2010 at 2:38am
Post Tools
Well, it seems the tech heads are still playing and breaking things - it's them, not YaBB.  Angry
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Captain John
Ex Member


Re: ACK - unsupported compression issue
Reply #6 - Sep 12th, 2010 at 1:34pm
Post Tools
Jet Li wrote on Sep 11th, 2010 at 8:09am:
change this in Variables/Settings.pl

Code
Select All
$gzcomp = 2;                                      # GZip compression: 0 = No Compression, 1 = External gzip, 2 =
                                                  #  Zlib::Compress 



Set it to 0 and you can access to your forum again. Smiley


   Compression is used within the YaBB Forum for Backup and output.  Setting either to a format not supported will cause errors and possibly the inability to access the forum.  See attached images of where these settings are.
  Note: on the Admin screen, the CheckModule displays the installation or non installation of modules.
  

cbackup.jpg ( 51 KB | 89 Downloads )
cbackup.jpg
compress.jpg ( 41 KB | 78 Downloads )
compress.jpg
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online



Posts: 2,363
Location: Earth

YaBB 2.6.1
Re: ACK - unsupported compression issue
Reply #7 - Sep 12th, 2010 at 4:47pm
Post Tools
The forum started throwing bizarre time-out and other error issues after I set everything to no compression.  I am now certain this is NOT an issue with YaBB but with the hosting service as my other forum on a different server is acting just fine after the upgrade.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Captain John
Ex Member


Re: ACK - unsupported compression issue
Reply #8 - Sep 12th, 2010 at 5:54pm
Post Tools
Dandello wrote on Sep 12th, 2010 at 4:47pm:
after I set everything to no compression.


   You "can" try Gzip for compression, it IS an option.
  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online



Posts: 2,363
Location: Earth

YaBB 2.6.1
Re: ACK - unsupported compression issue
Reply #9 - Sep 13th, 2010 at 2:32am
Post Tools
This is getting weirder by the minute. I had been using my Win7 laptop - the errors were showing on it. But when I got home to check things on my other machines - Mac, Ubuntu and XP, no errors. But it does show on the two Win7 machines I have access to.

So by process of elimination, the problem appears to be a bizarre OS problem. When I find a solution, I will let you know. Shocked
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online



Posts: 2,363
Location: Earth

YaBB 2.6.1
Re: ACK - unsupported compression issue
Reply #10 - Sep 13th, 2010 at 3:49pm
Post Tools
Okay - here's what seems to be happening - Instead of throwing time-outs because the pages are loading slowly, Win7 (and only Win7 so far) tries to automatically reload the page. (This happens with MSIE7, Firefox AND the 64-bit version of Firefox so I'm really sure it's not a browser issue.) If the download crawls to a halt at the very start, I get the 'unsupported compression'; otherwise the page starts to load and then just stops and the little loading indicator doesn't move.

If I hit refresh, the page may or may not load properly.

I know this isn't a resolved issue, but maybe I've eased the mind of some other poor soul with the same problem.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Captain John
Ex Member


Re: ACK - unsupported compression issue
Reply #11 - Sep 13th, 2010 at 9:30pm
Post Tools
"Sounds" like a web host server .... or at least a bottle neck in transmission.  What Host are you on and what is the url to your forum ?  (hopefully NOT GoDaddy)
« Last Edit: Sep 13th, 2010 at 9:31pm by »  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online



Posts: 2,363
Location: Earth

YaBB 2.6.1
Re: ACK - unsupported compression issue
Reply #12 - Sep 13th, 2010 at 9:47pm
Post Tools
I thought I'd given the URL: http://www.bigapricot.org/cgi-bin/yabb2/YaBB.pl
the hosting service is Powweb.

I've been back and forth with their techs and they can't reproduce the problem (of COURSE THEY CAN'T. THEY don't have a speed bottleneck).
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,897
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: ACK - unsupported compression issue
Reply #13 - Sep 14th, 2010 at 12:00am
Post Tools
Other than I can't resolve your server at the moment (not good) - If your host is also your ISP, this could point to a DNS problem.

BUT - from out of the blue comes these suggestions:

First - make sure you only have one adapter enabled.

Next - Disable IPv6 on the Win 7 machine/laptop for the active adapter.

It is causing many stange probs with webservers (this is based on my 'other project' - where I hold forth on Apache)  These problems seem to be in part due to MS rewriting their DNS responder.

Just use the Network Adapter fix for now - it disables IPv6 on 'standard connections' for that adapter - on a laptop you likely have 2 adapters - 1 wired and 1 wifi, disable IPv6 on the active adapter. Test.

If you use both connections and this works, disable it in both.  There are truly very few things around today that only work with IPv6, so you are not likely to break anything else in your test.

http://windows7themes.net/disable-ipv6-windows-7.html

http://support.microsoft.com/kb/929852

Its a shot-in-the-dark, but that's what I am known for, LOL.

Good Luck

Smiley

Edited:
Couple more things -

Is the wifi on a different router than the other stations?  Got jumbo frames enabled?

Lastly - run/use traceroute on the Win 7 laptop.
http://kb.iu.edu/data/aihy.html


now that was bizarre - one minute I couldn't resolve or cionnect to your server (or your Forum) - by the time I got to recycle/re-enter teh URL it was working.  Shocked

OK, it just did it again

sorry for the rambling post - but I have the thought of host problem.  As not being able to connect has about zero to do with Yabb.
« Last Edit: Sep 14th, 2010 at 12:31am by JonB »  

wierd_resolve.png ( 43 KB | 78 Downloads )
wierd_resolve.png

I find your lack of faith disturbing.
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online



Posts: 2,363
Location: Earth

YaBB 2.6.1
Re: ACK - unsupported compression issue
Reply #14 - Sep 14th, 2010 at 12:32am
Post Tools
Ah, at least it's not just me. I will try your Win7 suggestions though.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Page Index Toggle Pages: [1] 2 
Topic Tools
 
  « Board Index ‹ Board  ^Top