Page Index Toggle Pages: 1
Topic Tools
Hot Topic (More than 10 Replies) 403 FORBIDDEN (Read 5,937 times)
UKSte
YaBB Newcomer
*
Offline



Posts: 2

None
403 FORBIDDEN
Sep 13th, 2010 at 2:39pm
Post Tools
Hi everyone!
Just updated a 2.1 ot 2.5AE
Lost quite a few messages for some reason.

However, when I try an edited the Template (Admin Centre>Forum Layout>Template) I get the following message-
*****

Forbidden
You don't have permission to access /yabb/AdminIndex.pl on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/1.3.41 Server at www.peterleechessclub.co.uk Port 80
*******
Anyone any ideas why - I am one of the Admins and I am a little baffled, any help would be much appreciated - thanks!
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: 403 FORBIDDEN
Reply #1 - Sep 14th, 2010 at 7:21pm
Post Tools
Permission is controlled by CHMODs, ALL folders and *.pl files should be 755 (or higher).  "Sometimes" the Host will control access thru ...  See YaBB Codex http://www.yabbforum.com/codex/YaBB.pl?num=1190686968
  
Back to top
 
IP Logged
 
UKSte
YaBB Newcomer
*
Offline



Posts: 2

None
Re: 403 FORBIDDEN
Reply #2 - Sep 14th, 2010 at 10:56pm
Post Tools
Quote:
Permission is controlled by CHMODs, ALL folders and *.pl files should be 755 (or higher).  "Sometimes" the Host will control access thru ...  See YaBB Codex http://www.yabbforum.com/codex/YaBB.pl?num=1190686968

Hi Capt John, thanks for the reply.
I did read the codex but thought that it was relevant to 2.1 forums, and as I had upgraded to 2.5AE would not work (I know), anyway I shall have a go at this 2morrow and report back either way.
Cheers
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: 403 FORBIDDEN
Reply #3 - Sep 15th, 2010 at 2:48am
Post Tools
The first post was (relevant to 2.1) ... read the rest.
  
Back to top
 
IP Logged
 
j razz
YaBB Newcomer
*
Offline



Posts: 31
Re: 403 FORBIDDEN
Reply #4 - Mar 24th, 2011 at 2:45pm
Post Tools
I am getting this same error with the AdminIndex.pl file as well.  However, I am able to modify certain settings inside of the admin center but not others.  For instance, I cannot edit Advanced Settings but I can edit Forum Settings.  Also I cannot edit anything under "Forum Layout" options.

Why can I edit some portions of the Admin Center but not others?

------------
Here are my details:
-This was a clean install of 2.5 on a new cpanel server without the option of a YABB cpanel install.

-We have 2.4 on our old cpanel server and are migrating over to the new server.

-AdminIndex.pl has a 755 permission set (I also tried 777) and changed a few other settings based off the link I provided below (755 to 777 mainly).

-I have one mod (email notifications send out the text in the board post) but I don't know what I need to do to move that over.

-I do not have access to the server as it is hosted by westhost.com (I have to submit tickets to them and have done so and even pointed them to the link higher up in this thread).

-I have migrated over the users, boards, messages, etc and they all have come through, however, the profile fields and member groups did not transfer over (is this an issue stemming from the AdminIndex.pl issue?).

-I found it difficult to know what to do (what instructions to follow) as I am moving to a new server (clean install) and then upgrading from 2.4 to 2.5 from one server to another.  I did not find any one set of instructions to cover this.  I found the quickstart guide (which I mostly used but got confused when it was talking about upgrading), and this: http://www.yabbforum.com/codex/YaBB.pl?num=1190671650
-----------------

Any help would be greatly appreciated.  Also, I was unsure if I should post this here (seeing how it is similar in nature and may be more of a benefit to be in the same thread, or if I should start a new thread as I don't want to hijack a thread either).  Any guidance on this would be helpful as well.  Thanks.

j razz
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: 403 FORBIDDEN
Reply #5 - Mar 24th, 2011 at 10:58pm
Post Tools
In the Quick-Guide it states:
Quote:
cgi-bin/yabb2/Variables/* all files EXCEPT the following files:
Menu0.def, Menu1.def, Menu2.def
*.helporder (all files with this extension. Note: Your version may not contain these files.)
advsettings.txt
secsettings.txt
Settings.pl

Now copy the following files to a separate folder and rename them as it is shown here:
advsettings.txt => upgrade_advsettings.txt
secsettings.txt => upgrade_secsettings.txt
Settings.pl => upgrade_Settings.pl
then move the renamed files into cgi-bin/yabb2/Variables/ of your new forum.


In the update Readme file it states:
Quote:
     1)  Set your Forum in Maintenance mode.
     6)  Go back to the open window with the "Forum Settings" page in it and click
         at the "Save" Button at the bottom of the page!

     7)  Go to the "Maintenance Controls" section and run them all from top down.

     8)  Go to "AdminCenter" and review:
         - your settings in "Forum Settings"
         - your settings in "Advanced Settings", especially the changed setting:
           "Number of days after a Post is made that it will no longer show as 'new' in either the Board view or Message view."
           which was the
           "Number of days after that Posts read by the User are marked as New Posts again."
           setting before.
         - your settings in "Search Engines"
  
Back to top
 
IP Logged
 
j razz
YaBB Newcomer
*
Offline



Posts: 31
Re: 403 FORBIDDEN
Reply #6 - Mar 24th, 2011 at 11:05pm
Post Tools
I don't guess I understand what you are telling me in your response.  When I was doing this, I did not have the two files (advsettings.txt and secsettings.txt) however I did have the helporder file.

Could this be the issue?  Is that what you are pointing me to?
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: 403 FORBIDDEN
Reply #7 - Mar 24th, 2011 at 11:33pm
Post Tools
Quote:
cgi-bin/yabb2/Variables/* all files EXCEPT the following files:


Did you Copy ?
  
Back to top
 
IP Logged
 
j razz
YaBB Newcomer
*
Offline



Posts: 31
Re: 403 FORBIDDEN
Reply #8 - Mar 25th, 2011 at 1:16am
Post Tools
I did copy the Settings file (the only file I had of the three) the others I did not.  I was guilty of not reading close enough!  Anyways, I did copy that file over per the instructions and deleted just the Settings.pl file.  I did not notice any difference.  Where should I look to see where that file affected anything?

Thanks again for your help.
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: 403 FORBIDDEN
Reply #9 - Mar 25th, 2011 at 3:45pm
Post Tools
The statement states: ALL files ... except ...
  This should have included a lot of files from the ./Variables folder.  Without these you will have to go into the Admin Center and manually Set all your preferences, possibly losing any Blocked domains and IPs from your old forum.  But will rewrite the Settings.pl file.
  Your extended profile settings also would be lost.
Included with the Installation zip file and the Included Upgrade-Readme files we attempt to (if these are followed) to prevent loss of previous settings from older versions of YaBB.
  
Back to top
 
IP Logged
 
j razz
YaBB Newcomer
*
Offline



Posts: 31
Re: 403 FORBIDDEN
Reply #10 - Mar 25th, 2011 at 5:57pm
Post Tools
I still have the files (original files) as I still have that forum up and running in maintenance mode on my old server.  We are migrating to a new server platform. 

So, I then followed the instructions and renamed the settings.pl file with the new name and then removed the settings.pl file (that I copied over by not reading the directions clearly) and uploaded the newly named settings file.  I did not note anything changing.   

Also, why don't I have the other two files (what would cause me to not have them).  I read another post where another guy did not have them either.
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: 403 FORBIDDEN
Reply #11 - Mar 25th, 2011 at 9:19pm
Post Tools
j razz wrote on Mar 25th, 2011 at 5:57pm:
Also, why don't I have the other two files (what would cause me to not have them)

 Depends on the version you upgrade from

You still don't have the Membergroups ?

   You have the New forum in Maintenance Mode, you copied the variables files, you ran the Maintenance Functions ?
« Last Edit: Mar 25th, 2011 at 9:22pm by »  
Back to top
 
IP Logged
 
j razz
YaBB Newcomer
*
Offline



Posts: 31
Re: 403 FORBIDDEN
Reply #12 - Mar 25th, 2011 at 10:56pm
Post Tools
Correct.  Perhaps I missed something yet again?  However, in the interim, I just recreated those sections.  I will ask the members to fill the extra categories back out.  I also recreated the groups and those able to be chosen by the members.

Thanks for the help... I am sure it is user error.
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: 403 FORBIDDEN
Reply #13 - Mar 26th, 2011 at 3:25pm
Post Tools
Welcome .....
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Topic Tools