Page Index Toggle Pages: [1] 2 
Topic Tools
Hot Topic (More than 10 Replies) Download info (Read 4,254 times)
fpsbrian
Full Member
***
Offline



Posts: 108
Location: New Jersey
Download info
Oct 2nd, 2010 at 3:10pm
Post Tools
I'm trying to add some text by the attachment in my posts shown here. but can't seem to find the area I'm looking for?



instead of it saying:

omgot_blue_side_panel.vpk (58 KB | 54  )

I want it to say

omgot_blue_side_panel.vpk ( File Size: 58 KB | Downloads: 54  )
« Last Edit: Oct 2nd, 2010 at 3:10pm by fpsbrian »  

Back to top
IP Logged
 
ThM
Past Team Members
Offline



Posts: 444
Location: Germany

None
Re: Download info
Reply #1 - Oct 2nd, 2010 at 4:22pm
Post Tools
In Display.pl add the highlighted......

Code (Perl)
Select All
						$attachment .= qq~<div class="small"><a href="$scripturl?action=downloadfile;file=$_"><img src="$imagesdir/$attach_gif{$ext}" border="0" align="bottom" alt="" /> $_</a> (Filesize: ~ . int($filesize / 1024) . qq~ KB | Downloads: <acronym title='$attach_count{$_} $fatxt{'41a'}' class="small">$attach_count{$_}</acronym> )</div>~; 



Wink

And notice it's hardcoded. Better you make two new language strings.
« Last Edit: Oct 2nd, 2010 at 5:11pm by ThM »  

Gruß ThM
Back to top
 
IP Logged
 
fpsbrian
Full Member
***
Offline



Posts: 108
Location: New Jersey
Re: Download info
Reply #2 - Oct 2nd, 2010 at 5:14pm
Post Tools
Thank you so much!
  

Back to top
IP Logged
 
ThM
Past Team Members
Offline



Posts: 444
Location: Germany

None
Re: Download info
Reply #3 - Oct 2nd, 2010 at 5:23pm
Post Tools
You are welcome  Smiley
  

Gruß ThM
Back to top
 
IP Logged
 
fpsbrian
Full Member
***
Offline



Posts: 108
Location: New Jersey
Re: Download info
Reply #4 - Oct 12th, 2010 at 4:11pm
Post Tools
I think I messed something up... after doing some changes I can not change the
"Number of file attachments allowed in Posts" found in admin center > Advanced Settings > Attachments ?


Not sure if this helps but, when I hit "save" it go to-
omgot.com/forums/cgi-bin/yabb2/AdminIndex.pl?action=newsettings2;
page=advanced

but doesnt make it and I find myself at my homepage?



Download list looks great now!
« Last Edit: Oct 12th, 2010 at 4:31pm by fpsbrian »  

Back to top
IP Logged
 
Captain John
Ex Member


Re: Download info
Reply #5 - Oct 12th, 2010 at 6:08pm
Post Tools
The saved settings should resave Settings.pl (check CHMOD), Was Display.pl the only file you last edited ?  If so simply replace Display.pl with a backup or correct your edits.
  
Back to top
 
IP Logged
 
fpsbrian
Full Member
***
Offline



Posts: 108
Location: New Jersey
Re: Download info
Reply #6 - Oct 12th, 2010 at 11:41pm
Post Tools
I've tried using my backup from before changes and checked all chmod settings...

Still won't let me change that setting, even the option for showing images in attachments...                   


I dont see the lines for attachments in variables>settings.pl  either?
« Last Edit: Oct 12th, 2010 at 11:45pm by fpsbrian »  

Back to top
IP Logged
 
Captain John
Ex Member


Re: Download info
Reply #7 - Oct 13th, 2010 at 2:35pm
Post Tools
oops ... your using Y2.3.1 ... should be an attachments.txt and advsettings.txt file with settings.
« Last Edit: Oct 13th, 2010 at 2:42pm by »  
Back to top
 
IP Logged
 
fpsbrian
Full Member
***
Offline



Posts: 108
Location: New Jersey
Re: Download info
Reply #8 - Oct 13th, 2010 at 3:09pm
Post Tools
I see it now, I have it set for 666
  

Back to top
IP Logged
 
Captain John
Ex Member


Re: Download info
Reply #9 - Oct 13th, 2010 at 3:54pm
Post Tools
are the new settings saved ?
  
Back to top
 
IP Logged
 
fpsbrian
Full Member
***
Offline



Posts: 108
Location: New Jersey
Re: Download info
Reply #10 - Oct 13th, 2010 at 6:56pm
Post Tools
I had to do it manually because for some reason it wont let me do it in admin center?

I think I'm getting 404ed because it tries to go to AdminIndex.pl?action=newsettings2;page=advanced when I hit the save button, then I get directed to the main page.


newsettings.pl has a line

Code
Select All
  <form action="$adminurl?action=newsettings2;page=$page" onsubmit="undisableAll(this);" method="post"> 


« Last Edit: Oct 13th, 2010 at 7:03pm by fpsbrian »  

Back to top
IP Logged
 
fpsbrian
Full Member
***
Offline



Posts: 108
Location: New Jersey
Re: Download info
Reply #11 - Nov 2nd, 2010 at 1:32pm
Post Tools
ok, I still don't get why I can edit this field... when ever I hit "save" it like 404 errors me?

Even in users profile I found out?
  

Back to top
IP Logged
 
Captain John
Ex Member


Re: Download info
Reply #12 - Nov 2nd, 2010 at 2:54pm
Post Tools
mmmm well a 404 error is simply a server response for it not being able to find a file or directory (folder).  So it can't find the file requested at or in the directory specified.
  "Possibly" a path setting is incorrect or a file missing.  Turn on Debug in Admin Center to help you troubleshoot.  And/Or add
Code (Perl)
Select All
use CGI::Carp qw(fatalsToBrowser);  


to AdminIndex.pl, just below the shebang (path to Perl) line.
  
Back to top
 
IP Logged
 
fpsbrian
Full Member
***
Offline



Posts: 108
Location: New Jersey
Re: Download info
Reply #13 - Nov 2nd, 2010 at 4:30pm
Post Tools
Still not sure what I'm doing... I don't see anything wrong?
  

Back to top
IP Logged
 
fpsbrian
Full Member
***
Offline



Posts: 108
Location: New Jersey
Re: Download info
Reply #14 - Nov 2nd, 2010 at 7:22pm
Post Tools
I have another forum (yabb 2.4) not modded really... and it does the same thing!

the URLs are

Main Forum:
www.omgot.com/forums

Testing Forum:
www.omgot.com/testing

Do you think that has something to do with it?
  

Back to top
IP Logged
 
Page Index Toggle Pages: [1] 2 
Topic Tools
 
  « Board Index ‹ Board  ^Top