Page Index Toggle Pages: [1] 2 
Topic Tools
Hot Topic (More than 10 Replies) stupid 404 error (Read 7,048 times)
Tatzlwurm
YaBB Newcomer
*
Offline



Posts: 22
stupid 404 error
Nov 20th, 2010 at 6:58am
Post Tools
I have Perl installed. i have Yabb installed, permissions setup and IIS5 running on a winxp system. I try to go to http://localhost and i dont get anything. I cant access the forums on my other computers on the LAN ive tried my 192. address and nothing.

I have it installed in the standard directories with
C:\Inetpub\wwwroot\insidiouslegion\cgi-bin\yabb2\YaBB.pl
C:\perl\bin\perl.exe
Ive been working on this for a few hours now and just cant seem to figure out what im doing wrong. Im thinking this must be a simple issue that i just cant figure out, like a home directory issue or something, but i cant find the issue.
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: stupid 404 error
Reply #1 - Nov 20th, 2010 at 2:55pm
Post Tools
  
Back to top
 
IP Logged
 
Tatzlwurm
YaBB Newcomer
*
Offline



Posts: 22
Re: stupid 404 error
Reply #2 - Nov 20th, 2010 at 4:15pm
Post Tools
Yeah ive done that, it explains alot of permissions but doesnt tell me anything about my problem...ive read like a dozen forums and i cant find the issue. admittingly im not the most experienced at this however I have set one up before but Yabb2 is entirely different than Yabb1x
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: stupid 404 error
Reply #3 - Nov 20th, 2010 at 6:51pm
Post Tools
PM JonB .. he is are resident windows server guru
  
Back to top
 
IP Logged
 
Tatzlwurm
YaBB Newcomer
*
Offline



Posts: 22
Re: stupid 404 error
Reply #4 - Nov 21st, 2010 at 6:06am
Post Tools
ok Ive gone through the settings again and i still cant find the issue. i cant access my forums AT ALL. ive done the setup.pl file. and have my home directory set to
C:\Inetpub\wwwroot

thus if i typed
http://locahost/insdiouslegion/cgi-bin/yabb2/YaBB.pl

i should get my forum...correct?
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: stupid 404 error
Reply #5 - Nov 21st, 2010 at 11:08pm
Post Tools
Believe you should use the ip ...
  
Back to top
 
IP Logged
 
Tatzlwurm
YaBB Newcomer
*
Offline



Posts: 22
Re: stupid 404 error
Reply #6 - Nov 22nd, 2010 at 7:51pm
Post Tools
Ive tried that also, but nothing works.
  
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,913
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: stupid 404 error
Reply #7 - Nov 22nd, 2010 at 10:05pm
Post Tools
Well, I'm sure what is wrong.

1st - are you 100% sure its IIS5, not 6??  Maybe its the MS Personal Web Server?


read this page about IIS permissions -

http://www.newnetenterprises.com/merchants/web_tutorials/iis6_yabb.htm


where did you put the yabbfiles???

Is IIS enabled for auto-start in Windows Service Manager???  Did you start the website in the IIS MMC?

IF you aren't really familiar with IIS, I may have another 'quick solution for' XP

Look on my Excruciatingly Correct Guide -

http://bravo.newnetenterprises.com/wordpress/

Good Luck
Wink


  

I find your lack of faith disturbing.
Back to top
IP Logged
 
Tatzlwurm
YaBB Newcomer
*
Offline



Posts: 22
Re: stupid 404 error
Reply #8 - Nov 22nd, 2010 at 11:39pm
Post Tools
I am 100% sure its IIS5 5.1 to be exact.

Permissions were setup according to another post you did i read.

Yabb files are located in:
C:\Inetpub\wwwroot\insidiouslegion\public_html\

and ill read what you just posted Cheesy
  
Back to top
 
IP Logged
 
Tatzlwurm
YaBB Newcomer
*
Offline



Posts: 22
Re: stupid 404 error
Reply #9 - Nov 23rd, 2010 at 2:27am
Post Tools
OK i did the xamp install instead. and everthing went smooth except when i did http://localhost all i got was a page that said

"it worked"

and when i try the

http://localhost/insidiouslegion/cgi-bin/yabb2/Setup.pl

I still get a 404 error. I did have xamp previously installed on this system which is vista home deleted the install and reinstalled it.

My sql and apache services are both green
  
Back to top
 
IP Logged
 
Tatzlwurm
YaBB Newcomer
*
Offline



Posts: 22
Re: stupid 404 error
Reply #10 - Nov 23rd, 2010 at 2:30am
Post Tools
Ooops thats not my path

http://localhost/cgi-bin/yabb2/Setup.pl
is the path i removed the insidiouslegion folder and just did a direct copy the the htdocs folder.
  
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,913
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: stupid 404 error
Reply #11 - Nov 23rd, 2010 at 3:00am
Post Tools
On XAMMP - if its a default install to C:\xampp -

The yabb2 folder (and all its stuff) goes in c:\xampp\cgi-bin

and the yabbfiles folder (and that stuff) goes in c:\xampp\htdocs.

You should't have gotten 'it works' when you go to http://localhost - you should have been redirected to the 'XAMMP' page.

BTW - You don't need to start MySQL to make YaBB work.

All you need is Apache and Perl.

The reason I asked about making sure on IIS 5 is that it (IIS 5) has a peculiar problem with YaBB and needs the YaBB code to be patched with the 'NPH' fix.  But lets not worry about that now.

I have my fingers crossed for you - there are no permissions or anything like that to be set.

Good luck
Cool
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
Tatzlwurm
YaBB Newcomer
*
Offline



Posts: 22
Re: stupid 404 error
Reply #12 - Nov 23rd, 2010 at 3:23am
Post Tools
The "it works" issue is resolved i had two versions of apache running.

I moved the files in the directories you indicated.
C:\xampp\htdocs\public_html\yabbfiles
C:\xampp\cgi-bin\cgi-bin\yabb2

but now im getting an Error 500 when i try to go to
http://localhost/cgi-bin/cgi-bin/yabb2/Setup.pl

Error 500
localhost
11/22/2010 8:21:10 PM
Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1
  
Back to top
 
IP Logged
 
Tatzlwurm
YaBB Newcomer
*
Offline



Posts: 22
Re: stupid 404 error
Reply #13 - Nov 23rd, 2010 at 3:26am
Post Tools
  
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,913
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: stupid 404 error
Reply #14 - Nov 23rd, 2010 at 3:44am
Post Tools
Umm ahhh -- lets see

1st, when you go to http://localhost - what do you get???  

If you aren't directed to the XAMPP page - all yellow, white and orange - your XAMPP install was not right.


IF it is OK - then - Run the perlinfo()  page option on the XAMPP page. It it works then Perl is working.


Did you chose (for some reason) to activate 'mod_perl' during the XAMPP setup screen???  If so, we need to fix that - its easy - just tell me


IF you got the XAMPP Page and mod_perl is not activated then -

lets just clean up a bit - delete whatever YaBB folders you may have copied in - just send 'em to the recycle bin.

BTW - there is no need for a xammp\cgi-bin\cgi-bin

-- Extract YaBB somewhere else -

-- copy the files from inside the cgi-bin download - yabb2 and below to the \xampp\cgi-bin folder

you should now have c:\xampp\cgi-bin\yabb2 and a group of files and folders under that.


-- now, copy the files from inside the public_html download - from yabbfiles and below
to htdocs.

you should now have c:\xampp\htdocs\yabbfiles and a group of files and folders under that.


-- type in http://localhost/cgi-bin/yabb2/Setup.pl

when you get to the set paths part, YaBB should auto-detect everything by itself

Edited:
Just thought of this - did you fix all the shebang lines?
Note: - I have two sets of YaBB files because I run BOTH 2.4 and 2.5 - you should just have yabb2 - under cgi-bin and yabbfiles under htdocs. 



Below is what it looks like on a running server - the one those guides are on, BTW -

Wink

« Last Edit: Nov 23rd, 2010 at 4:00am by JonB »  

xampp_yabb.png ( 39 KB | 136 Downloads )
xampp_yabb.png

I find your lack of faith disturbing.
Back to top
IP Logged
 
Page Index Toggle Pages: [1] 2 
Topic Tools
 
  « Board Index ‹ Board  ^Top