Page Index Toggle Pages: 1 [2] 
Topic Tools
Hot Topic (More than 10 Replies) Boards missing, what did I mess up? (Read 4,867 times)
Captain John
Ex Member


Re: Boards missing, what did I mess up?
Reply #9 - Nov 20th, 2010 at 7:19pm
Post Tools
Run the Maintenance functions (Members) then check, if not fixed
attach your Settings.pl (change pl to txt before trying to attach)
« Last Edit: Nov 20th, 2010 at 7:27pm by »  
Back to top
 
IP Logged
 
ereicros
YaBB Newcomer
*
Offline



Posts: 35
Re: Boards missing, what did I mess up?
Reply #8 - Nov 20th, 2010 at 7:11pm
Post Tools
I'm seeing the membergroup info in the settings.pl, that's what's confusing me it's all in there just not on the membergroups section of the admin area.  I'm not sure what to do now as it won;t even let me recreate the membergroups because it says they already exist, even though they are not listed.

########## MemberGroups ##########

# Static Member Groups
$Group{'Global Moderator'} = 'Official Postpoker Overlord|5|stargmod.gif|blue|0|0|0|0|0|0|0';
$Group{'Moderator'} = 'Official Postpoker|5|starmod.gif|green|0|0|0|0|0|0|0';
$Group{'Administrator'} = 'In Here We Are God|5|staradmin.gif|red|0|0|0|0|0|0|0';

# Post independent Member Groups
$NoPost{'8'} = 'Skar's Icy Totem|0|starblue.gif||1|0|0|0|0|0|0';
$NoPost{'11'} = 'Feral Lemming|3|starsilver.gif||0|0|0|0|0|0|0';
$NoPost{'10'} = 'Baby Lemming|1|starblue.gif||0|0|0|0|0|0|0';
$NoPost{'9'} = 'Bossy Lemming|5|starmod.gif||0|0|0|0|0|0|0';
$NoPost{'12'} = 'True Lemming|5|stargold.gif||0|0|0|0|0|0|0';

# Post dependent Member Groups
$Post{'-1'} = 'Visitor|0|staradmin.gif||0|0|0|0|0|0|0';

That's what's in my settings.pl file.  The mod and visitor groups are all fine and working as they should be, jsut the ones in the middle are missing, even though members still have the ranks.
« Last Edit: Nov 20th, 2010 at 7:15pm by ereicros »  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Boards missing, what did I mess up?
Reply #7 - Nov 20th, 2010 at 7:08pm
Post Tools
mmmmm don't think recopying will allow to transfer that info to the new Settings.pl  (where the membergroup info is now).  Setup should have copied the info to Settings.pl
Edited:
Edit Settings.pl and verify membergroup info is correct)
« Last Edit: Nov 20th, 2010 at 7:10pm by »  
Back to top
 
IP Logged
 
ereicros
YaBB Newcomer
*
Offline



Posts: 35
Re: Boards missing, what did I mess up?
Reply #6 - Nov 20th, 2010 at 7:02pm
Post Tools
Yes I did move the files according to that guide including the membergroups.txt one although it's not in the new folder now...

Should I copy just that one over again and rebuild everything?
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Boards missing, what did I mess up?
Reply #5 - Nov 20th, 2010 at 6:57pm
Post Tools
Did you move the files from your old ./Variables folder as noted, renaming as described ?
Quote:
cgi-bin/yabb2/Variables/* all files EXCEPT the following files:

    * Menu0.def, Menu1.def, Menu2.def
    * *.helporder (all files with this extension. Note: Your version may not contain these files.)
    * advsettings.txt
    * secsettings.txt
    * Settings.pl


Now copy the following files to a separate folder and rename them as it is shown here:

    * advsettings.txt => upgrade_advsettings.txt
    * secsettings.txt => upgrade_secsettings.txt
    * Settings.pl => upgrade_Settings.pl

This would have included a membergroups.txt file from Y2.2
  
Back to top
 
IP Logged
 
ereicros
YaBB Newcomer
*
Offline



Posts: 35
Re: Boards missing, what did I mess up?
Reply #4 - Nov 20th, 2010 at 5:38pm
Post Tools
Ok, redid everything and have all my boards and posts where they should be, I do have one issue though.

I have post independent member groups on my old forum and on my new forum they are not showing up under the admin member groups section.  The members have their 'rank' in the member list and the member groups are listed in the settings.pl but they just don't show up as member groups in that section on the admin area, or as options to select in catagory/boards, any ideas?

If I just recreated the member groups with the same names and settings would the people already marked as that rank automatically be picked up by the new group I created?  Nm I just tried that and it tells me I can't have 2 ranks with the same name, even though it doesn't show me as having any on the admin section, arrgh.
« Last Edit: Nov 20th, 2010 at 6:32pm by ereicros »  
Back to top
 
IP Logged
 
ereicros
YaBB Newcomer
*
Offline



Posts: 35
Re: Boards missing, what did I mess up?
Reply #3 - Nov 20th, 2010 at 3:20pm
Post Tools
Thanks, I figured I'd messed it up beyond repair so currently redoing it all and hopefully won't miss anything this time although the lack of sleep may factor in ^^
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Boards missing, what did I mess up?
Reply #2 - Nov 20th, 2010 at 3:00pm
Post Tools
Would be a good idea to start over .... Settings.pl should never be deleted.  You initially missed a few files either in the ./Boards or ./Messages folders when you updated.
  After installing the new version and getting it running, follow the directions in the Quick-Guide to update.
  
Back to top
 
IP Logged
 
ereicros
YaBB Newcomer
*
Offline



Posts: 35
Re: Boards missing, what did I mess up?
Reply #1 - Nov 20th, 2010 at 9:38am
Post Tools
Ok now I really messed it up, I managed to delete the settings.pl file in the variables folder so now I just get 500 errors whenever I try to do anything, do I need to redo the whole thing?
  
Back to top
 
IP Logged
 
ereicros
YaBB Newcomer
*
Offline



Posts: 35
Boards missing, what did I mess up?
Nov 20th, 2010 at 8:43am
Post Tools
I'm upgrading from Yabb 2.2 to 2.5AE and I 'thought' I followed the instructions but obviously I messed something up.  

Now I see my new forum and all the posts are there, but all in the Recycle Bin and none of my original catagories or boards exist.  Also I don't see the member groups in the admin section although members are still in those groups in the memberlist.

What have/haven't I done?  Please help I've been working through the night on this and I want to go to beddd.

Old forum: http://www.sorciere.co.uk/cgi-bin/yabb2/YaBB.pl
New forum: http://www.sorciere.co.uk/cgi-bin/lol/YaBB.pl
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1 [2] 
Topic Tools
 
  « Board Index ‹ Board  ^Top