YaBB Community and Support Forum
YaBB Home About YaBB Download YaBB YaBB Support Customize Your Forum Development Contribute to the Project
  Welcome, Guest. Please Login or Register


 
Page Index Toggle Pages: 1
Topic Tools
 
Notifications dont' work since upgrade from 2.2.3 (Read 1,238 times)
 Nov 28th, 2010 at 5:02am
There are no actions to perform.  

Allison_A 
YaBB Newbie
*
Offline
Posts: 49
Portland, OR


None
Notifications dont' work since upgrade from 2.2.3
Hello all,

About a month ago I upgraded from 2.2.3 to 2.5AE by installing a new version and moving all the files over.  I have worked out most of the issues, but the user notifications for new posts to a thread, and for PM's, do not seem to work.

Under Forum Settings, Members, "Allow users to enable email notifications for boards/threads listed in 'My Notifications' when a new message is posted?" is set to yes and has been since the upgrade.  In User CP, Post and Board Notifications and Notify me of new Notifications by eMail? is set to Yes.

I checked permissions on the .Members folder and it appears to be correct, 755 at the tolder, 666 for the files.  I did notice new files were being created as 644 which seemed odd, but added a umask(000); statement to YaBB.pl which hopefully will fix that.  If that's the issue, then maybe it will go away eventually, but a test PM I sent afterwards did not generate an email.

Email notification for new accounts, and then the password email, as well as password reset work fine, but I haven't been able to get a single notification to go out since the upgrade.  Sendmail settings didn't change during the upgrade, but somehow the notification piece stopped working at that time.

Any help would be appreciated.

 
 
IP Logged  
 Reply #1 - Nov 28th, 2010 at 11:07am
There are no actions to perform.  

Jet Li 
Legacy Dev Team
Development Team
****
Offline
Posts: 6,588
Hong Kong


None
Re: Notifications dont' work since upgrade from 2.2.3
Hi
you didn't follow the Upgrade Instruction in Quick Guide.

  • Then go to "Admin Center" => "Maintenance Controls" and run the "Rebuild Notifications Files" first!
    Now run the other Maintenance Controls starting with "Rebuild Message Index" going through "Rebuild Members History."
  • Go to ALL tabs in the "Forum Settings" and "Advanced Settings" sections and verify all your settings. There are many new settings in version 2.5 AE, so take your time here. Click the Save button at the bottom of each page even if you do not change any settings on the page.
  • Go to "Maintenance Settings" and turn "Maintenance Mode?" off. Return to your forum. Refresh the page or clear the browser chache and start enjoying your brand new YaBB 2.5 AE Forum!
    Note:
    If you did allow users to get Email notification on new "Notifications" or new "PM" before you updated, you will have to set these settings again as new in your "Profile" => "Options" and "PM Preferences". If no other users logged in before you ran the "Rebuild Notifications Files" maintenance function, you (the Admin) will be the only one who has to reset these as new settings.
 
...
PM me for YaBB Installation Service
WWW Jet Li 100000788351637  
IP Logged  
 Reply #2 - Nov 28th, 2010 at 11:05pm
There are no actions to perform.  

Allison_A 
YaBB Newbie
*
Offline
Posts: 49
Portland, OR


None
Re: Notifications dont' work since upgrade from 2.2.3
I thought I followed the instructions to the letter.  I was very careful during the upgrade.

I did a rebuild of everything I could just a few days ago, but when I have some downtime I will try it again in that order.

But as of now, nobody has been able to get any notifications since the upgrade, and that includes the admin account.
 
 
IP Logged  
 Reply #3 - Nov 29th, 2010 at 12:23am
There are no actions to perform.  
Captain John 
Ex Member


None
Re: Notifications dont' work since upgrade from 2.2.3
The other option is to notify all your members (including the admin account) to reset any notification options enabled or desired to be received in each members profile.  Board or thread notifications also must be redone.

See YaBB Codex http://www.yabbforum.com/codex/YaBB.pl?num=1265743599
« Last Edit: Nov 29th, 2010 at 12:43am by N/A »  
 
IP Logged  
Page Index Toggle Pages: 1
Topic Tools
 

Get Yet another Bulletin Board at SourceForge.net. Fast, secure and Free Open Source software downloads Support This Project BoardMod - YaBB features and templates YaBB Codex - support on installation and usage YaBB Toolbar for your browser

YaBB Facebook Group Page

Vulnerability Scanner

Valid RSS Valid XHTML Valid CSS Powered by Perl
YaBB Chat and Support Community » Powered by YaBB 3.0 Beta!
YaBB Forum Software © 2000-2011. All Rights Reserved.