Page Index Toggle Pages: 1
Topic Tools
Normal Topic From Windows to Linux - lower/upper case (Read 1,422 times)
binary
YaBB Newcomer
*
Offline



Posts: 25
From Windows to Linux - lower/upper case
Jan 12th, 2011 at 11:50pm
Post Tools
Hi guys,

I've just migrated a 2.5 forum from a Windows to Linux server.
I'm now having a very specific issue regarding "ex members".

For reference, please have a look at a cut-out from a random thread:
Quote:
THREAD NAME | Hadrian [21VB]|hadrian@mail.dk|1243800067|Hadrian_21VB|xx|0|85.80.162.60|CONTENT OF THE POST
THREAD NAME | Hadrian [21VB]|hadrian@mail.dk|1277790057|hadrian_21vb|xx|0|193.89.221.64|CONTENT OF THE POST


As you can see, the same user uses "Hadrian_21VB" in the first post and "hadrian_21vb" (lowercase) in the second post.

On the old (Windows) server, this is of course not an issue.
But after migrating to the Linux server - all the instances of lowercase hadrian_21vb now looks like a ex member.
If i change the file to match the "uppercase username" the user shows up correctly.
This is true for thousands of posts and hundreds of members - so it won't be possible to manually change..

How do i go about solving this?  Shocked
« Last Edit: Jan 12th, 2011 at 11:55pm by binary »  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: From Windows to Linux - lower/upper case
Reply #1 - Jan 13th, 2011 at 7:31pm
Post Tools
We have never had this error reported ....  but something similiar has been fixed in our beta version ... so try downloading and replacing these files ...


cgi-bin/yabb2/Admin/Admin.pl
cgi-bin/yabb2/Languages/English/Register.lng
cgi-bin/yabb2/Sources/Load.pl
cgi-bin/yabb2/Sources/Profile.pl
cgi-bin/yabb2/Sources/Register.pl
cgi-bin/yabb2/Sources/UserSelect.pl
cgi-bin/yabb2/Admin/Maintenance.pl
public_html/yabbfiles/ajax.js

from CVS
  
Back to top
 
IP Logged
 
binary
YaBB Newcomer
*
Offline



Posts: 25
Re: From Windows to Linux - lower/upper case
Reply #2 - Jan 13th, 2011 at 10:20pm
Post Tools
Thanks John, although that didn't go too well, now I'm getting a 500 Internal Error  Huh

Edit:
Should i try just installing the whole beta edition ?

Edit #2:
Tried that - still doesn't work  Sad
« Last Edit: Jan 13th, 2011 at 10:51pm by binary »  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Topic Tools
 
  « Board Index ‹ Board  ^Top