Page Index Toggle Pages: 1
There are no actions to perform.
Normal Topic Mail Groups function does not work (Read 1,071 times)
Hayden Rorke
YaBB Newcomer
*
Offline



Posts: 9
Mail Groups function does not work
Jan 13th, 2011 at 6:38pm
There are no actions to perform.
Hi,

I wonder if anyone could help me please...

I currently got YaBB 2.5 AE installed running on Linux server and everything is working great as it should apart from mailing the members function.

In the admin centre > 'Email Your Members'
comes up with the 'Mail Groups'
Selecting this should send the email to members belonging to that group but it does not.

However, on the same panel, if I click 'Mail Members' on the right top corner first and then, select the the 'Mail Groups' which is now located at the left bottom corner, it will tick the members belonging to that group and mail does get sent.

Because of this, if a member belongs to 2 or more groups, it can only send email the primary group that members belongs to and not to the others. áThis has started to cause a bit of a problem.

Is this a bug of some sort or am I doing something wrong during set up? áAny ideas or suggestions would be greatly appreciated.

Thank you very much in advance.
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Mail Groups function does not work
Reply #1 - Jan 13th, 2011 at 6:49pm
There are no actions to perform.
Hayden Rorke wrote on Jan 13th, 2011 at 6:38pm:
Because of this, if a member belongs to 2 or more groups, it can only send email the primary group that members belongs to and not to the others.  This has started to cause a bit of a problem.

Is this a bug of some sort or am I doing something wrong during set up?  Any ideas or suggestions would be greatly appreciated.


  If this was done any other way than just the primary (position) membergroup members would receive an email for every and all membergroups they are assigned to.  Duplicating the same email times every membergroup assigned to.  Not a good thing.
   "started to cause a problem" Why ?  Isn't (just one) email to an individual member enough ?
  
Back to top
 
IP Logged
 
Hayden Rorke
YaBB Newcomer
*
Offline



Posts: 9
Re: Mail Groups function does not work
Reply #2 - Jan 13th, 2011 at 6:58pm
There are no actions to perform.
Hi,

Thank you for your quick reply.

The board is used for a student society.  Initially the members will join and get allocated a post independent position (Group).  Due to the international nature of the students' backgrounds, we need to create secondary position within the primary position.

So, in other words, when sending out notifications, Primary position people will receive and email of an event, then within that Primary position, the committee members or group leaders who are allocated a secondary position will need to receive communications within.

For ordinary forum use, just one position per member may be enough but for our use, we need more than 2 or 3 in some cases.

Thank you for reading all this.
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Mail Groups function does not work
Reply #3 - Jan 13th, 2011 at 7:25pm
There are no actions to perform.
2 separate and not the same email ?

So áan email is sent to the Primary group .. All receive ... correct ?
a second email can't be sent to just the secondary group ?

A bug fix was incorporated in our next Beta version for group mailings ... try this  http://www.yabbforum.com/community/YaBB.pl?num=1281485059/13#13
« Last Edit: Jan 13th, 2011 at 7:37pm by »  
Back to top
 
IP Logged
 
Hayden Rorke
YaBB Newcomer
*
Offline



Posts: 9
Re: Mail Groups function does not work
Reply #4 - Jan 13th, 2011 at 9:04pm
There are no actions to perform.
Hi,

Thank you once again for your quick reply.

And most of all, thank you very much for the link to the bug fix!! áThis bug fix has now cured it completely!!

For others having the same problem, I'll just clarify my points for future references.

1. The board is used for student society holding roughly around 100 people.

2. Each members are allocated to positions (groups) which are 'post independent'. áMost are given one position (primary) however, some are given another position (secondary). áThis works really well as who can view and post on certain boards can be controlled as well as emailing relevant information. áIn our case, this distinguish "ordinary members", "committee members", "event organisers" etc. á

3. The symptom
When 'Email Your Members' is chosen from the Admin menu, it gets the list of groups first. áWhen this is selected to a particular group, this does not work at all. áIt does not matter whether it is primary or secondary position. áIt just won't send anything.

It sends out email, only when 'Mail Members' were clicked first which takes you to the next screen and 'Groups' chosen on that page.

4. Solution
The bug fix code above has sorted this problem.


I would like to thank you once again for your time and kindness in helping us out. áThe students are trying to organise the forthcoming international cultural exchange event which required more position to be added for ease of communication and this will help us a lot.

YaBB is the best!! áThank you very much!! Smiley
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Mail Groups function does not work
Reply #5 - Jan 13th, 2011 at 10:55pm
There are no actions to perform.
Welcome .....
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
There are no actions to perform.