Page Index Toggle Pages: [1] 2 
Topic Tools
Hot Topic (More than 10 Replies) Email problems (Read 3,899 times)
BBM
YaBB Newcomer
*
Offline



Posts: 28

None
Email problems
Feb 3rd, 2011 at 10:09am
Post Tools
Hi,
I just installed 2.5 from 2.1 but have one issue that is the forum e-mails.. it mails the new members with validating info and password but it refuses to e-mail member groups or any members individually in the admin panel.
thanks
  
Back to top
 
IP Logged
 
Derek Barnstorm
Support Team
YaBB Next Team
Development Team
Beta Testers
****
Offline



Posts: 1,269
Location: United Kingdom

None
Re: Email problems
Reply #1 - Feb 3rd, 2011 at 3:12pm
Post Tools
  
Back to top
 
IP Logged
 
BBM
YaBB Newcomer
*
Offline



Posts: 28

None
Re: Email problems
Reply #2 - Feb 3rd, 2011 at 4:10pm
Post Tools
Hi Derek,
Thanks for the reply,it has that in the script already  Smiley but still doesnt work
  
Back to top
 
IP Logged
 
Derek Barnstorm
Support Team
YaBB Next Team
Development Team
Beta Testers
****
Offline



Posts: 1,269
Location: United Kingdom

None
Re: Email problems
Reply #3 - Feb 3rd, 2011 at 4:57pm
Post Tools
The line that's already there needs to be changed though. Did you actually replace the line with the fix in the link I gave you?
  
Back to top
 
IP Logged
 
BBM
YaBB Newcomer
*
Offline



Posts: 28

None
Re: Email problems
Reply #4 - Feb 3rd, 2011 at 5:55pm
Post Tools
No because the line was the same as the one you linked.. do you want me to replace it anyway?
  
Back to top
 
IP Logged
 
BBM
YaBB Newcomer
*
Offline



Posts: 28

None
Re: Email problems
Reply #5 - Feb 3rd, 2011 at 6:02pm
Post Tools
BBM wrote on Feb 3rd, 2011 at 5:59pm:
this is the line  i have

($memrealname, $mememail, $memposition, $memposts, $memaddgrp) = split(/|/, $memberinf{$user});


this is your link

($memrealname, $mememail, $memposition, $memposts, $memaddgrp) = split(/\|/, $memberinf{$user});
  
Back to top
 
IP Logged
 
Derek Barnstorm
Support Team
YaBB Next Team
Development Team
Beta Testers
****
Offline



Posts: 1,269
Location: United Kingdom

None
Re: Email problems
Reply #6 - Feb 3rd, 2011 at 6:40pm
Post Tools
Yeah, that line is already in the code for something else, but you should still have this line:

Code (Perl)
Select All
        (undef, $memrealname, $mememail, $memposition, $memposts, $memaddgrp, undef) = split(/\|/, $memberinf{$user}, 7); 


Change that line to the same as the line in the above post too.
« Last Edit: Feb 3rd, 2011 at 6:53pm by Derek Barnstorm »  
Back to top
 
IP Logged
 
BBM
YaBB Newcomer
*
Offline



Posts: 28

None
Re: Email problems
Reply #7 - Feb 3rd, 2011 at 9:25pm
Post Tools
Both lines are the same
  
Back to top
 
IP Logged
 
BBM
YaBB Newcomer
*
Offline



Posts: 28

None
Re: Email problems
Reply #8 - Feb 3rd, 2011 at 9:30pm
Post Tools
here is the script i changed to a text document to upload
  

MailMembers.txt ( 23 KB | 170 Downloads )
Back to top
 
IP Logged
 
BBM
YaBB Newcomer
*
Offline



Posts: 28

None
Re: Email problems
Reply #9 - Feb 3rd, 2011 at 9:43pm
Post Tools
Just saw that the script i uploaded is from the 2.1 forum i have uploaded and changed the 2.5 one but there is no change
  
Back to top
 
IP Logged
 
Derek Barnstorm
Support Team
YaBB Next Team
Development Team
Beta Testers
****
Offline



Posts: 1,269
Location: United Kingdom

None
Re: Email problems
Reply #10 - Feb 3rd, 2011 at 9:43pm
Post Tools
That's the wrong MailMembers.pl - it's from 2.1.

You need the 2.5 file. Try this one attached...

Edited:
Ah, you posted at the same time as me - just seen your above post. Cheesy

« Last Edit: Feb 3rd, 2011 at 9:46pm by Derek Barnstorm »  

MailMembers_pl.txt ( 23 KB | 111 Downloads )
Back to top
 
IP Logged
 
Derek Barnstorm
Support Team
YaBB Next Team
Development Team
Beta Testers
****
Offline



Posts: 1,269
Location: United Kingdom

None
Re: Email problems
Reply #11 - Feb 3rd, 2011 at 9:45pm
Post Tools
BBM wrote on Feb 3rd, 2011 at 9:43pm:
Just saw that the script i uploaded is from the 2.1 forum i have uploaded and changed the 2.5 one but there is no change

So it's still not working, even with the fix?
  
Back to top
 
IP Logged
 
BBM
YaBB Newcomer
*
Offline



Posts: 28

None
Re: Email problems
Reply #12 - Feb 3rd, 2011 at 10:33pm
Post Tools
no i remember trying the old file but its the same it just sends validation and new password thats it
  
Back to top
 
IP Logged
 
Derek Barnstorm
Support Team
YaBB Next Team
Development Team
Beta Testers
****
Offline



Posts: 1,269
Location: United Kingdom

None
Re: Email problems
Reply #13 - Feb 3rd, 2011 at 11:20pm
Post Tools
I'm just wondering, how come you had a 2.1 file anyway? Are you sure that everything else is up to date too?

  
Back to top
 
IP Logged
 
BBM
YaBB Newcomer
*
Offline



Posts: 28

None
Re: Email problems
Reply #14 - Feb 3rd, 2011 at 11:36pm
Post Tools
When i saw the e-mail was working the way i described i took the old pl file from my old forum which is 2.1 but forgot to take it out and replace it with the current one
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: [1] 2 
Topic Tools