Page Index Toggle Pages: 1
Topic Tools
Normal Topic E-mail delivery (Read 2,004 times)
TonyL
Full Member
***
Offline



Posts: 103
Location: Ontario, Canada

None
E-mail delivery
Feb 12th, 2011 at 1:44pm
Post Tools
I am having a problem with e-mail being sent from our servers host. E-mail is being blocked as spam because we are on a shared server. We paid for a dedicated IP thinking this would solve our problem, however the problem still exist. Below is a copy of an e-mail that I received from our host JustHost.

Quote:
Email's FROM field is "xxxxxxx@fsx03.justhost.com" which means it was sent through some sort of PHP mail-form.
When such type of sending is used, all emails are originated from "CPANEL_USER"@"SERVERNAME".
I.e. they will always be sent from server's hostname and therefore from server's default IP address.
This behaviour cannot be changed but you can bypass it by modifying your PHP mailing script to pass through SMTP authentication.
In other words you should modify your mailer script, so that your emails would be sent from "SOMETHING"@"titaniumrvowners.com" rather than "xxxxxxx@fsx03.justhost.com".
Only in this case your emails will be sent from your dedicated IP.
--
--
Kind regards,
Alex Montana
Just Host
www.justhost.com


Any suggestions on how I can fix this.
Thanks,
Tony
  
Back to top
 
IP Logged
 
raymor
YaBB Newcomer
*
Offline



Posts: 11
Re: E-mail delivery
Reply #1 - Feb 12th, 2011 at 2:02pm
Post Tools
I really doubt that changing the from address is going to change
the IP.  You'd probably do well to carefully read some of the
bounce messages to really see what the problem is.  For example,
it's likely that the problem is that the server has no reverse
DNS set, or it's set wrong.  Some of the bounce messages
will tell you what the problem is.

That said, here are a few thousand tips on how to use SMTP auth
from Perl, though I don't think that's going to keep your emails
from being blocked downstream:
http://www.google.com/search?hl=en&client=mozilla&q=perl+smtp+auth&aq=f&aqi=g3g-...
  
Back to top
 
IP Logged
 
TonyL
Full Member
***
Offline



Posts: 103
Location: Ontario, Canada

None
Re: E-mail delivery
Reply #2 - Feb 12th, 2011 at 2:12pm
Post Tools
Thank you for the quick response. I do not have bounced e-mail, they just go into cyberspace and never delivered or returned. Below is a support e-mail received from Microsoft. I will check ths suggestions in your link.
Quote:
Hello,



My name is Paul and I work with the Windows Live Hotmail Sender Support Team.



I have identified that the messages from your IP 184.154.94.10 are being filtered based on the recommendations of the SmartScreen Filter Technology. Based off of the information you provided and our mail policy, we regret to inform you that we are unable to offer any kind of mitigation at this time.



You can find our Mail policies located here.



We encourage you to download the Hotmail Enhanced Deliverability white paper. While this in effect helps you with delivering to Hotmail, Microsoft makes no guarantees on deliverability to Hotmail/Live/MSN customers.



Sincerely,



Paul
Windows Live Hotmail Sender Support


  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: E-mail delivery
Reply #3 - Feb 13th, 2011 at 4:05am
Post Tools
TonyL wrote on Feb 12th, 2011 at 1:44pm:
Quote:
Email's FROM field is "xxxxxxx@fsx03.justhost.com" which means it was sent through some sort of PHP mail-form.
When such type of sending is used, all emails are originated from "CPANEL_USER"@"SERVERNAME".
I.e. they will always be sent from server's hostname and therefore from server's default IP address.
This behaviour cannot be changed but you can bypass it by modifying your PHP mailing script to pass through SMTP authentication.
In other words you should modify your mailer script, so that your emails would be sent from "SOMETHING"@"titaniumrvowners.com" rather than "xxxxxxx@fsx03.justhost.com".
Only in this case your emails will be sent from your dedicated IP.
--
--
Kind regards,
Alex Montana
Just Host
www.justhost.com


  and with the response from MSN, the solution looks like changing the Admin email addy.
  The mailbox address you should be using (In Admin Center - Advanced Settings - Email Tab - Webmaster Email Address)  webmaster@titaniumrvowners.com  and NOT the email in the Admin's profile or fsx03.justhost.com
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: E-mail delivery
Reply #4 - Feb 13th, 2011 at 9:22pm
Post Tools
Changes made ..... Please verify
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Topic Tools