Page Index Toggle Pages: 1
There are no actions to perform.
Normal Topic Attachment won't view (Read 2,973 times)
Tim5071
YaBB Newcomer
*
Offline



Posts: 2

YaBB 2.6.0
Attachment won't view
Feb 13th, 2011 at 3:14am
There are no actions to perform.
The attachment path is set to .../yabb/attachments, but after you add an attachment and go back into the forum and click on the attached file, it tries to go to ...yabb/YaBB.pl?action=downloadfile;file=photo_1_.JPG.  Maybe this isn't the problem.  However, I can't seem to find anything else that might be causing this problem.  I have tried everything I can think of, which is obviously not enough.  (resize pictures, change attachment settings, etc...).  Nothing seems to work.  Please help.
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Attachment won't view
Reply #1 - Feb 13th, 2011 at 3:22am
There are no actions to perform.
Tim5071 wrote on Feb 13th, 2011 at 3:14am:
The attachment path is set to .../yabb/attachments,

  You must use Absolute not Relative DIR Paths and "url's".  If the path you supplied is correct Attachments should start with a Capitol "A"

  
Back to top
 
IP Logged
 
Tim5071
YaBB Newcomer
*
Offline



Posts: 2

YaBB 2.6.0
Re: Attachment won't view
Reply #2 - Feb 13th, 2011 at 12:15pm
There are no actions to perform.
Yes, they do start with an "A" rather than an "a".
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Attachment won't view
Reply #3 - Feb 13th, 2011 at 5:43pm
There are no actions to perform.
Quote:
You must use Absolute not Relative DIR Paths

  
Back to top
 
IP Logged
 
Elfen
Full Member
***
Offline



Posts: 452
Re: Attachment won't view
Reply #4 - Feb 14th, 2011 at 8:10pm
There are no actions to perform.
Tim5071 wrote on Feb 13th, 2011 at 3:14am:
The attachment path is set to .../yabb/attachments, but after you add an attachment and go back into the forum and click on the attached file, it tries to go to ...yabb/YaBB.pl?action=downloadfile;file=photo_1_.JPG. áMaybe this isn't the problem. áHowever, I can't seem to find anything else that might be causing this problem. áI have tried everything I can think of, which is obviously not enough. á(resize pictures, change attachment settings, etc...). áNothing seems to work. áPlease help.

Like Captain John says, you must use Absoute Paths and not relative paths.
.../yabb/attachments - is a realtive Directory Path

Its cPanel, right? So you are looking for the Absolute Path, which should be (depending on you cPanel account)
/public_html/yabb/attachments - (or something simillar.)
« Last Edit: Feb 14th, 2011 at 8:12pm by Elfen »  
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 4,204
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Attachment won't view
Reply #5 - Dec 12th, 2011 at 1:51pm
There are no actions to perform.
Off-Topic replies have been moved to this Topic.
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
Page Index Toggle Pages: 1
There are no actions to perform.