Page Index Toggle Pages: 1 [2] 3 
Topic Tools
Very Hot Topic (More than 25 Replies) unable to open post (Read 6,315 times)
Puttboy
YaBB Newcomer
*
Offline



Posts: 29

YaBB 2.6.0
Re: unable to open post
Reply #15 - Feb 19th, 2011 at 7:13am
Post Tools
This is a user account, into which I was logged yesterday (on another machine) before I rebuilt the members list, which is the action which seems to have deleted all the member accounts, and into which I am still logged.

I have changed the .vars file to accept me as administrator. Clicking on the Home tab, I am still logged in with the greeting Good Morning Andy, etc, but at the bottom of the page, under forum statistics, there are 0 members and 0 guests listed as Users Online.

I have seven tabs across the top of the forum: Home, Help, Search, Members, Update Session (which I've never seen before,) User CP and Logout.

I opened Update Session in a new tab, and it says:

Your session has expired, as you entered the forum from a different IP address (which is then listed)
To check your credentials answer the following question you entered in your profile
You did not select a Session Question in your profile so the only way to check your credentials is your password

Then it asks for my password as validation. This strikes me as a trap I do not want to walk into.

Notably, I don't have an Admin tab at the top of the page. I'm fairly certain that if I input a password into the session I am currently logged into, I will be shut out completely.

I will wait for your suggestions before I proceed any further.

Ciao,

Andy
  
Back to top
IP Logged
 
Puttboy
YaBB Newcomer
*
Offline



Posts: 29

YaBB 2.6.0
Re: unable to open post
Reply #16 - Feb 19th, 2011 at 7:17am
Post Tools
Should I try inputting a question into sesquest',"" and an answer into sesanswer',""?

Or is that no more likely to work than the steps we took yesterday to change the admin user password?
  
Back to top
IP Logged
 
Captain John
Ex Member


Re: unable to open post
Reply #17 - Feb 19th, 2011 at 6:30pm
Post Tools
Puttboy wrote on Feb 19th, 2011 at 7:13am:
Notably, I don't have an Admin tab at the top of the page.

  The Admin Center tab is replaced with the Update Sessions tab.  It is NOT a tap, you must of turned on Sessions Security.
  Click on the tab, enter your password, go to Admin Center - Security Settings and Uncheck Activate Session ID's?
This protects the Administrative Functions based on a three part Session Key based on IP address
  
Back to top
 
IP Logged
 
Puttboy
YaBB Newcomer
*
Offline



Posts: 29

YaBB 2.6.0
Re: unable to open post
Reply #18 - Feb 19th, 2011 at 11:04pm
Post Tools
Hi Captain John,

I have done as you suggested. When I change the Activate Session ID setting and try to save, I get an error code:
Masterkey is invalid !
This should be a text string between 8 and 24 characters long !

I don't know what that means or what I should do about it (the password for that account has eight characters.)
  
Back to top
IP Logged
 
Derek Barnstorm
Support Team
YaBB Next Team
Development Team
Beta Testers
****
Offline



Posts: 1,269
Location: United Kingdom

None
Re: unable to open post
Reply #19 - Feb 19th, 2011 at 11:55pm
Post Tools
What value have you got for 'Set a masterkey for encryption' under the 'Validation Image' tab in Security Settings? It should look something like this:

eP4ebUYfkoCFCrCJe8aA9pYu
  
Back to top
 
IP Logged
 
Puttboy
YaBB Newcomer
*
Offline



Posts: 29

YaBB 2.6.0
Re: unable to open post
Reply #20 - Feb 20th, 2011 at 1:40am
Post Tools
Derek, I now have no access whatsoever to our YaBB forum.

I clicked on the Admin tab and got kicked out. I received a message:

Warning!

Only registered Members are allowed to access this forum.
Please login below or click -here- to register an account with Proactive Physio YaBB forum.

Of course, I can't log in because I don't have any members.

I should have created another member when I had access to the Admin page this morning.

I guess all is now lost.
  
Back to top
IP Logged
 
Puttboy
YaBB Newcomer
*
Offline



Posts: 29

YaBB 2.6.0
Re: unable to open post
Reply #21 - Feb 20th, 2011 at 1:46am
Post Tools
Unless I can edit something directly through the File Manager on cPanel.

Can someone help me do that?
  
Back to top
IP Logged
 
Derek Barnstorm
Support Team
YaBB Next Team
Development Team
Beta Testers
****
Offline



Posts: 1,269
Location: United Kingdom

None
Re: unable to open post
Reply #22 - Feb 20th, 2011 at 5:19am
Post Tools
So you hadn't changed anything since you last logged in as an Admin? And you can't log back in with those details - Are you getting a Username / Password mismatch again?
  
Back to top
 
IP Logged
 
Puttboy
YaBB Newcomer
*
Offline



Posts: 29

YaBB 2.6.0
Re: unable to open post
Reply #23 - Feb 20th, 2011 at 8:37am
Post Tools
On screen, I was still logged in. I had tried to change the settings Captain John advised me to change, with the results I recorded in my reply to his suggestions.

I hadn't touched anything for several hours after that, and when I clicked the Admin button, I was taken to the request for a password.

As previously mentioned, the member list was bare, and I didn't think to register a new member at that time, so now I get Username / Password mismatch when I try to login.

I have access to all of the YaBB files on the server, but with the failed attempts to change login details to allow another login, I don't know how much use that is.

Is there any way I can alter the files to repopulate the member list, or create a new member I can login through?
  
Back to top
IP Logged
 
Puttboy
YaBB Newcomer
*
Offline



Posts: 29

YaBB 2.6.0
Re: unable to open post
Reply #24 - Feb 20th, 2011 at 9:25am
Post Tools
Good news!

I have found that one of the tablet PCs at work was carelessly left on and someone's login was operational!

Hallelujah.

I have attempted to change the Uncheck Activate Session ID's setting. I still get the message:

Error: Masterkey is invalid !
This should be a text string between 8 and 24 characters long !

Derek, you asked for the value for 'Set a masterkey for encryption' under the 'Validation Image' tab in Security Settings. It is

ox7c6pQpKu9Zj86cADDF4hgcn_hGsX3p

Is that still relevant?

I have added a new member, who shows up in the member list and can login, so I should at least be able to try anything you suggest next time!
  
Back to top
IP Logged
 
Derek Barnstorm
Support Team
YaBB Next Team
Development Team
Beta Testers
****
Offline



Posts: 1,269
Location: United Kingdom

None
Re: unable to open post
Reply #25 - Feb 20th, 2011 at 5:11pm
Post Tools
Puttboy wrote on Feb 20th, 2011 at 9:25am:
I have attempted to change the Uncheck Activate Session ID's setting. I still get the message:

Error: Masterkey is invalid !
This should be a text string between 8 and 24 characters long !

Derek, you asked for the value for 'Set a masterkey for encryption' under the 'Validation Image' tab in Security Settings. It is

ox7c6pQpKu9Zj86cADDF4hgcn_hGsX3p

Is that still relevant?

I don't really understand how you have that entered in the input field, because it has a max length of 24 characters and you have more than 24 characters there. But, it's not relevant to the problems you are having, no.

Puttboy wrote on Feb 20th, 2011 at 9:25am:
I have added a new member, who shows up in the member list and can login, so I should at least be able to try anything you suggest next time!

Have you got a back up of your forum? If you haven't, then I can only really suggest that you get logged in as an Admin and try the rebuild functions again...

  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: unable to open post
Reply #26 - Feb 20th, 2011 at 5:36pm
Post Tools
Puttboy wrote on Feb 20th, 2011 at 9:25am:
ox7c6pQpKu9Zj86cADDF4hgcn_hGsX3p

  When entering a Master Key is states: A random text string

"_" is NOT text, letters/numbers only
  
Back to top
 
IP Logged
 
Puttboy
YaBB Newcomer
*
Offline



Posts: 29

YaBB 2.6.0
Re: unable to open post
Reply #27 - Feb 20th, 2011 at 10:31pm
Post Tools
Captain John,

I don't understand what you mean by this post. What I think you mean is that I inputted this random string into the Master Key field. I didn't put anything into that field, that's what was there when I followed Derek's suggestion to investigate it.

Should I change that field? Derek says it's not relevant to my problem.

I don't have a back-up of my forum, I had no idea I needed one and nor do I know how to create one. All the data for the forum appears to be intact on the webpage, so I can create a back-up of that, but I don't know what good that will do me given that it doesn't seem to work.

I will back it up anyway and then try the rebuild functions again.

Please let me know what else I can try if there's anything else to try.

Undecided

Quote:
Puttboy wrote on Feb 20th, 2011 at 9:25am:
ox7c6pQpKu9Zj86cADDF4hgcn_hGsX3p

 When entering a Master Key is states: A random text string

"_" is NOT text, letters/numbers only

  
Back to top
IP Logged
 
Puttboy
YaBB Newcomer
*
Offline



Posts: 29

YaBB 2.6.0
Re: unable to open post
Reply #28 - Feb 20th, 2011 at 10:46pm
Post Tools
Thank you very much for all your help.

Rebuilding the member list appears to have done the job, I can login all members again.

One last question (for the time being): How do I turn off the ISP address being shown next to members' names at the bottom where it lists members online?

Thanks again,

Andy

  
Back to top
IP Logged
 
Derek Barnstorm
Support Team
YaBB Next Team
Development Team
Beta Testers
****
Offline



Posts: 1,269
Location: United Kingdom

None
Re: unable to open post
Reply #29 - Feb 20th, 2011 at 10:56pm
Post Tools
Puttboy wrote on Feb 20th, 2011 at 10:46pm:
Thank you very much for all your help.

Rebuilding the member list appears to have done the job, I can login all members again.

Great! I'm glad you got it working.

Puttboy wrote on Feb 20th, 2011 at 10:46pm:
One last question (for the time being): How do I turn off the ISP address being shown next to members' names at the bottom where it lists members online?

In Admin Center => Security Settings, uncheck:

Show IP in Board Index Online List for all online Members/Guests to Administrators?

And...
     
Show IP in Board Index Online List for all online Members/Guests to Global Moderators?


« Last Edit: Feb 20th, 2011 at 11:02pm by Derek Barnstorm »  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1 [2] 3 
Topic Tools