Page Index Toggle Pages: [1] 2 
Topic Tools
 10 Moving Yabb to a new server causes errors (Read 6,433 times)
Captain John
Ex Member


Re: Moving Yabb to a new server causes errors
Reply #21 - May 4th, 2011 at 3:41pm
Post Tools
Welcome ....

jem wrote on May 3rd, 2011 at 3:35pm:
I suppose there must be bits of code missing...?

  Using a program like WinMerge, do a Compare of the default template for your YaBB version and the template you're using to find missing lines of code.
  
Back to top
 
IP Logged
 
jem
Full Member
***
Offline



Posts: 177
Re: Moving Yabb to a new server causes errors
Reply #20 - May 3rd, 2011 at 3:35pm
Post Tools
Excellent! I've tried your suggestion and it worked. Even though about 60 messages are still missing, at least the rest are ok. Thank you so much!

There's another thing, the login button on top of the front page and the registration button at the bottom are not working. I suppose there must be bits of code missing...?

Thank you again


  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Moving Yabb to a new server causes errors
Reply #19 - Apr 25th, 2011 at 5:48pm
Post Tools
Quote:
The only way to recover these files that don't show, is to FTP the site and download "or" do a Host Panel Backup of the folders on your old site

  
Back to top
 
IP Logged
 
jem
Full Member
***
Offline



Posts: 177
Re: Moving Yabb to a new server causes errors
Reply #18 - Apr 25th, 2011 at 8:35am
Post Tools
Well, now there's a strange thing...i haven't deleted the forum's files off the old server, so i've checked the number of files in the messages and members folders with three different ftp clients and it shows 1998 files in both folders. This is the same number of files that i can see in the folders uploaded in the new host. Obviously, there should be a more files in both folders
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Moving Yabb to a new server causes errors
Reply #17 - Apr 25th, 2011 at 3:55am
Post Tools
jem wrote on Apr 24th, 2011 at 8:21pm:
This means that i won't be able to use the board in this hosting?

  This is your "New" host ?  Yep, if they don't allow more than 1024 ?  You have way more than that.
  How many files did or do you actually have in the old forum's Messages folder ?  Were you able to download "all" of them from your old host ?
  
Back to top
 
IP Logged
 
jem
Full Member
***
Offline



Posts: 177
Re: Moving Yabb to a new server causes errors
Reply #16 - Apr 24th, 2011 at 8:21pm
Post Tools
Well, that makes total sense. I've contacted my hosting to ask them about a possible file limit and this has been their reply:

Quote:
Your shared hosting account's directories can hold up to 1,024 files. This limit prevents customers' file structures from taxing the server's resources and negatively affect its load time.

If you have more than 1,024 files in a directory, you might receive an "Out of Disk Space" when trying to add or create more files in that directory. This doesn't mean that your entire hosting account has exceeded its disk space, only that directory has.

You can avoid this issue by splitting directories with many files into sub-directories, and by pruning any 'cache' or 'thumbnail' directories your site uses manually or with a cron job. We will warn customers exceeding this limit and may relocate files to maintain server performance.


This means that i won't be able to use the board in this hosting? Is there a way i might be able to work around this issue?

Thank you so much, you've been a great help
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Moving Yabb to a new server causes errors
Reply #15 - Apr 24th, 2011 at 5:08am
Post Tools
 Okay CHMOD Boards, Messages and Members files to 666, Checked Paths, Ok.  Checked files -
jem wrote on Apr 22nd, 2011 at 4:39pm:
Unable to open ./Messages/1189967843.txt (09/16/2007 - 2:37 PM)


Clicking on MUY IMPORTANTE, ESTE FORO ES SOLO DE LECTURA PORQUE HEMOS CAMBIADO DE SITIO Board returns:
Quote:
Unable to open ./Messages/1189981634.txt (09/16/2007 - 6:27 PM)

   The "Last" or most recent post in the Messages folder is 1157154119 (09/01/2006 - 7:41 PM)
    FTPing your site, you have 1999 files,  You are missing a "lot" of Message files.   Some Hosts limit how many files you can view within a folder (usually 2,000), even though there are more there.  The only way to recover these files that don't show, is to FTP the site and download "or" do a Host Panel Backup of the folders on your site and then download/unpack and reupload to the New site.
« Last Edit: Apr 24th, 2011 at 5:16am by »  
Back to top
 
IP Logged
 
jem
Full Member
***
Offline



Posts: 177
Re: Moving Yabb to a new server causes errors
Reply #14 - Apr 23rd, 2011 at 10:10pm
Post Tools
Done, thank you!!
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Moving Yabb to a new server causes errors
Reply #13 - Apr 23rd, 2011 at 8:26pm
Post Tools
PM me the ftp access url and password, also the admin password for the forum.
  
Back to top
 
IP Logged
 
jem
Full Member
***
Offline



Posts: 177
Re: Moving Yabb to a new server causes errors
Reply #12 - Apr 23rd, 2011 at 4:05pm
Post Tools
Quote:
Since you have a modified Template you are using ... try using the default (unaltered) template just to test with.
  Your CHMODs are correct and the file user/group correct ?
  You have any valuable Perl MODs missing ?

Sorry about all the questions and checks, but very hard to troubleshoot not knowing everything you have done or changed and with no access.

Quote:
Since you have a modified Template you are using ... try using the default (unaltered) template just to test with.
  Your CHMODs are correct and the file user/group correct ?
  You have any valuable Perl MODs missing ?

Sorry about all the questions and checks, but very hard to troubleshoot not knowing everything you have done or changed and with no access.


I'm using the default template now with the same results. I've checked chmods and users permissions tons of times...they seem to be ok.
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Moving Yabb to a new server causes errors
Reply #11 - Apr 23rd, 2011 at 3:17pm
Post Tools
Since you have a modified Template you are using ... try using the default (unaltered) template just to test with.
   Your CHMODs are correct and the file user/group correct ?
   You have any valuable Perl MODs missing ?

Sorry about all the questions and checks, but very hard to troubleshoot not knowing everything you have done or changed and with no access.
  
Back to top
 
IP Logged
 
jem
Full Member
***
Offline



Posts: 177
Re: Moving Yabb to a new server causes errors
Reply #10 - Apr 23rd, 2011 at 10:50am
Post Tools
Quote:
I assume you updated your Path Settings after you setup the DNS ?
 I see you didn't update your Templates from your old forum to Y2.5.  Use a file compare program like WinMerge to add elements needed for Y2.5.
 Note - You have keywords duplicated in the html header.  I see 3 different style sheets specified.

jem wrote on Apr 22nd, 2011 at 4:39pm:
I'm guessing it's a problem with the boards folder

 You did transfer the files from the old yabb/Boards folder this new server ?


Yes, i updated the paths. The thing is that i thought maybe some files got corrupted in the transfer process, so i've transfered them again (messages, boards, members) from one host to another, but this time i didn't move the whole folders but a few files every time, so there wasn't a chance they got damaged in the way. This didn't work either.

I'm getting desperate now, i don't know what else to try  Undecided
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Moving Yabb to a new server causes errors
Reply #9 - Apr 22nd, 2011 at 9:01pm
Post Tools
I assume you updated your Path Settings after you setup the DNS ?
  I see you didn't update your Templates from your old forum to Y2.5.  Use a file compare program like WinMerge to add elements needed for Y2.5.
  Note - You have keywords duplicated in the html header.  I see 3 different style sheets specified.

jem wrote on Apr 22nd, 2011 at 4:39pm:
I'm guessing it's a problem with the boards folder

  You did transfer the files from the old yabb/Boards folder this new server ?
  
Back to top
 
IP Logged
 
jem
Full Member
***
Offline



Posts: 177
Re: Moving Yabb to a new server causes errors
Reply #8 - Apr 22nd, 2011 at 4:39pm
Post Tools
So the DNS is ok now and i'm still having the same problem. I'm guessing it's a problem with the boards folder, since the missing messages appear when i rewrite this folder (although i still can't access the messages).

This is the link to the board:

http://sinfomusic.es/cgi-bin/yabb/YaBB.pl

Error when trying to access some messages:

The information you are trying to access is not available to you. ./Messages/1189981634.txt

Error when trying to get in some threads:

Unable to open ./Messages/1189967843.txt
Verbose: No such file or directory

Thanks!
  
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,768
Location: Land of the Blazing Sun!

YaBB 2.6.0
Re: Moving Yabb to a new server causes errors
Reply #7 - Apr 20th, 2011 at 1:11pm
Post Tools
Good Luck!

Cool <== Kool Geek
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
Page Index Toggle Pages: [1] 2 
Topic Tools
 
  « Board Index ‹ Board  ^Top