YaBB Community and Support Forum
YaBB Home About YaBB Download YaBB YaBB Support Customize Your Forum Development Contribute to the Project
  Welcome, Guest. Please Login or Register


 
Pages: 1 2 
Topic Tools
 
Moving Yabb to a new server causes errors (Read 6,114 times)
 Apr 15th, 2011 at 9:31am
There are no actions to perform.  

jem 
Full Member
***
Offline
Posts: 177


None
Moving Yabb to a new server causes errors
Hi, i've just moved Yabb (2.5 to 2.5) to a new server  (linux) following the instructions i found here:

http://www.yabbforum.com/codex/YaBB.pl?num=1190674425

Everything works ok except when i recounted the messages list half of the posts dissapeared. The same happened to the users list.

I uploaded again the users folder: the lost users appeared again, though i didn't recount this time, since it makes them dissapear again. I uploaded the messages folder. Seeing as uploading the messages folder caused no effect whatsoever, i realised that uploading the boards folder the missing messages appeared again. The problem this time is that whenever i try to open one of those it says:

"The information you are trying to access is not available to you /home/etc/*.txt"

And if i recount the messages list they dissapear again.

Chmod is 777 just in case.

Help please. Thanks!
 
 
IP Logged  
 Reply #1 - Apr 15th, 2011 at 3:58pm
There are no actions to perform.  
Captain John 
Ex Member


None
Re: Moving Yabb to a new server causes errors
mmmm Are you sure the Path Settings are correct for the new server ?  Using an Absolute path for DIRs and a complete URL where required ?
  Uploading the forum, using the correct transfer mode ?  ALL files and folders under yabb2 folder as AscII.
  Did you do a New Install then upload the old forum data files or upload the entire old forum ?
   Did you correct the Start/Date the forum was installed to the old date ?
  3 files in the yabb2/Members folder contain the members info, list and count & newest.
  Codex - http://www.yabbforum.com/codex/YaBB.pl?num=1224094402
« Last Edit: Apr 15th, 2011 at 4:00pm by N/A »  
 
IP Logged  
 Reply #2 - Apr 18th, 2011 at 1:01pm
There are no actions to perform.  

jem 
Full Member
***
Offline
Posts: 177


None
Re: Moving Yabb to a new server causes errors
Hello, thank you for your reply. I've been struggling with this for some time now and i'm beginning to feel desperate.

Path settings are ok: there's about 50000 messages in my forum, and half of them can be read ok.

I've been very careful to upload everything under yabb2 in Ascii. Actually i've done it a few times already with different ftp clients, just in case.

I've made a fresh install but the setup file didn't work properly (once i set up the paths all i could see was strange symbols), so i uploaded the data from my old forum, folloing the instructions.  

The start date of the forum is correct.

Those 3 files in the members folder you mention are there.

I've no idea what to try next  Undecided
 
 
IP Logged  
 Reply #3 - Apr 18th, 2011 at 5:13pm
There are no actions to perform.  
Captain John 
Ex Member


None
Re: Moving Yabb to a new server causes errors
jem wrote on Apr 18th, 2011 at 1:01pm:
a fresh install but the setup file didn't work properly (once i set up the paths all i could see was strange symbols), so i uploaded the data from my old forum, folloing the instructions.

  mmm Setup didn't work, so you uploaded your data files anyway ??

Would like to see your Paths and Settings pl files.  Attach to your reply.
 
 
IP Logged  
 Reply #4 - Apr 18th, 2011 at 10:16pm
There are no actions to perform.  

jem 
Full Member
***
Offline
Posts: 177


None
Re: Moving Yabb to a new server causes errors
Ok, here they go. Thank you







                                                                                               removed attachment
« Last Edit: Apr 19th, 2011 at 4:44pm by N/A »  
 
IP Logged  
 Reply #5 - Apr 19th, 2011 at 4:58pm
There are no actions to perform.  
Captain John 
Ex Member


None
Re: Moving Yabb to a new server causes errors
mmmmm looks all right ... nothing stands out as being incorrect.
 Really like your template.  Noticed you seem to have quite a few members and as you stated over 51 thousand posts ... but the last post is March 27,2010 ???
 and you do not have your DNS setup as of yet ?  You realize that once that is done, your Path settings will then be incorrect ?  Notice that when you access your site as of now, you get the popup window stating this is a "Preview", that might be the reason for your problems (a guess, since I am not a server guru).
 
 
IP Logged  
 Reply #6 - Apr 20th, 2011 at 8:25am
There are no actions to perform.  

jem 
Full Member
***
Offline
Posts: 177


None
Re: Moving Yabb to a new server causes errors
The board's been closed for some time now because of lack of space in my old host but i want to re-open it now for members to be allowed to post again.

Right now i've got the site up in the new hosting as a preview version to be able to test it and make sure it works ok before propagating the dns. If you say that this might be the cause of the error, i'm going to change the dns settings (and the paths, of course) to check the site live and see if it works that way.

I'll keep you posted. Thanks!
 
 
IP Logged  
 Reply #7 - Apr 20th, 2011 at 1:11pm
There are no actions to perform.  

JonB 
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 3,614
Land of the Blazing Sun!


None
Re: Moving Yabb to a new server causes errors
Good Luck!

Cool <== Kool Geek
 
I find your lack of faith disturbing.
 
IP Logged  
 Reply #8 - Apr 22nd, 2011 at 4:39pm
There are no actions to perform.  

jem 
Full Member
***
Offline
Posts: 177


None
Re: Moving Yabb to a new server causes errors
So the DNS is ok now and i'm still having the same problem. I'm guessing it's a problem with the boards folder, since the missing messages appear when i rewrite this folder (although i still can't access the messages).

This is the link to the board:

http://sinfomusic.es/cgi-bin/yabb/YaBB.pl

Error when trying to access some messages:

The information you are trying to access is not available to you. ./Messages/1189981634.txt

Error when trying to get in some threads:

Unable to open ./Messages/1189967843.txt
Verbose: No such file or directory

Thanks!
 
 
IP Logged  
 Reply #9 - Apr 22nd, 2011 at 9:01pm
There are no actions to perform.  
Captain John 
Ex Member


None
Re: Moving Yabb to a new server causes errors
I assume you updated your Path Settings after you setup the DNS ?
 I see you didn't update your Templates from your old forum to Y2.5.  Use a file compare program like WinMerge to add elements needed for Y2.5.
 Note - You have keywords duplicated in the html header.  I see 3 different style sheets specified.

jem wrote on Apr 22nd, 2011 at 4:39pm:
I'm guessing it's a problem with the boards folder

 You did transfer the files from the old yabb/Boards folder this new server ?
 
 
IP Logged  
 Reply #10 - Apr 23rd, 2011 at 10:50am
There are no actions to perform.  

jem 
Full Member
***
Offline
Posts: 177


None
Re: Moving Yabb to a new server causes errors
Quote:
I assume you updated your Path Settings after you setup the DNS ?
 I see you didn't update your Templates from your old forum to Y2.5.  Use a file compare program like WinMerge to add elements needed for Y2.5.
 Note - You have keywords duplicated in the html header.  I see 3 different style sheets specified.

jem wrote on Apr 22nd, 2011 at 4:39pm:
I'm guessing it's a problem with the boards folder

 You did transfer the files from the old yabb/Boards folder this new server ?


Yes, i updated the paths. The thing is that i thought maybe some files got corrupted in the transfer process, so i've transfered them again (messages, boards, members) from one host to another, but this time i didn't move the whole folders but a few files every time, so there wasn't a chance they got damaged in the way. This didn't work either.

I'm getting desperate now, i don't know what else to try  Undecided
 
 
IP Logged  
 Reply #11 - Apr 23rd, 2011 at 3:17pm
There are no actions to perform.  
Captain John 
Ex Member


None
Re: Moving Yabb to a new server causes errors
Since you have a modified Template you are using ... try using the default (unaltered) template just to test with.
  Your CHMODs are correct and the file user/group correct ?
  You have any valuable Perl MODs missing ?

Sorry about all the questions and checks, but very hard to troubleshoot not knowing everything you have done or changed and with no access.
 
 
IP Logged  
 Reply #12 - Apr 23rd, 2011 at 4:05pm
There are no actions to perform.  

jem 
Full Member
***
Offline
Posts: 177


None
Re: Moving Yabb to a new server causes errors
Quote:
Since you have a modified Template you are using ... try using the default (unaltered) template just to test with.
  Your CHMODs are correct and the file user/group correct ?
  You have any valuable Perl MODs missing ?

Sorry about all the questions and checks, but very hard to troubleshoot not knowing everything you have done or changed and with no access.

Quote:
Since you have a modified Template you are using ... try using the default (unaltered) template just to test with.
  Your CHMODs are correct and the file user/group correct ?
  You have any valuable Perl MODs missing ?

Sorry about all the questions and checks, but very hard to troubleshoot not knowing everything you have done or changed and with no access.


I'm using the default template now with the same results. I've checked chmods and users permissions tons of times...they seem to be ok.
 
 
IP Logged  
 Reply #13 - Apr 23rd, 2011 at 8:26pm
There are no actions to perform.  
Captain John 
Ex Member


None
Re: Moving Yabb to a new server causes errors
PM me the ftp access url and password, also the admin password for the forum.
 
 
IP Logged  
 Reply #14 - Apr 23rd, 2011 at 10:10pm
There are no actions to perform.  

jem 
Full Member
***
Offline
Posts: 177


None
Re: Moving Yabb to a new server causes errors
Done, thank you!!
 
 
IP Logged  
Pages: 1 2 
Topic Tools
 

Get Yet another Bulletin Board at SourceForge.net. Fast, secure and Free Open Source software downloads Support This Project BoardMod - YaBB features and templates YaBB Codex - support on installation and usage YaBB Toolbar for your browser

YaBB Facebook Group Page

Vulnerability Scanner

Valid RSS Valid XHTML Valid CSS Powered by Perl
YaBB Chat and Support Community » Powered by YaBB 3.0 Beta!
YaBB Forum Software © 2000-2011. All Rights Reserved.