Page Index Toggle Pages: 1 [2] 
Topic Tools
Hot Topic (More than 10 Replies) Moving Yabb to a new server causes errors (Read 6,808 times)
Captain John
Ex Member


Re: Moving Yabb to a new server causes errors
Reply #15 - Apr 24th, 2011 at 5:08am
Post Tools
 Okay CHMOD Boards, Messages and Members files to 666, Checked Paths, Ok.  Checked files -
jem wrote on Apr 22nd, 2011 at 4:39pm:
Unable to open ./Messages/1189967843.txt (09/16/2007 - 2:37 PM)


Clicking on MUY IMPORTANTE, ESTE FORO ES SOLO DE LECTURA PORQUE HEMOS CAMBIADO DE SITIO Board returns:
Quote:
Unable to open ./Messages/1189981634.txt (09/16/2007 - 6:27 PM)

   The "Last" or most recent post in the Messages folder is 1157154119 (09/01/2006 - 7:41 PM)
    FTPing your site, you have 1999 files,  You are missing a "lot" of Message files.   Some Hosts limit how many files you can view within a folder (usually 2,000), even though there are more there.  The only way to recover these files that don't show, is to FTP the site and download "or" do a Host Panel Backup of the folders on your site and then download/unpack and reupload to the New site.
« Last Edit: Apr 24th, 2011 at 5:16am by »  
Back to top
 
IP Logged
 
jem
Full Member
***
Offline



Posts: 177
Re: Moving Yabb to a new server causes errors
Reply #16 - Apr 24th, 2011 at 8:21pm
Post Tools
Well, that makes total sense. I've contacted my hosting to ask them about a possible file limit and this has been their reply:

Quote:
Your shared hosting account's directories can hold up to 1,024 files. This limit prevents customers' file structures from taxing the server's resources and negatively affect its load time.

If you have more than 1,024 files in a directory, you might receive an "Out of Disk Space" when trying to add or create more files in that directory. This doesn't mean that your entire hosting account has exceeded its disk space, only that directory has.

You can avoid this issue by splitting directories with many files into sub-directories, and by pruning any 'cache' or 'thumbnail' directories your site uses manually or with a cron job. We will warn customers exceeding this limit and may relocate files to maintain server performance.


This means that i won't be able to use the board in this hosting? Is there a way i might be able to work around this issue?

Thank you so much, you've been a great help
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Moving Yabb to a new server causes errors
Reply #17 - Apr 25th, 2011 at 3:55am
Post Tools
jem wrote on Apr 24th, 2011 at 8:21pm:
This means that i won't be able to use the board in this hosting?

  This is your "New" host ?  Yep, if they don't allow more than 1024 ?  You have way more than that.
  How many files did or do you actually have in the old forum's Messages folder ?  Were you able to download "all" of them from your old host ?
  
Back to top
 
IP Logged
 
jem
Full Member
***
Offline



Posts: 177
Re: Moving Yabb to a new server causes errors
Reply #18 - Apr 25th, 2011 at 8:35am
Post Tools
Well, now there's a strange thing...i haven't deleted the forum's files off the old server, so i've checked the number of files in the messages and members folders with three different ftp clients and it shows 1998 files in both folders. This is the same number of files that i can see in the folders uploaded in the new host. Obviously, there should be a more files in both folders
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Moving Yabb to a new server causes errors
Reply #19 - Apr 25th, 2011 at 5:48pm
Post Tools
Quote:
The only way to recover these files that don't show, is to FTP the site and download "or" do a Host Panel Backup of the folders on your old site

  
Back to top
 
IP Logged
 
jem
Full Member
***
Offline



Posts: 177
Re: Moving Yabb to a new server causes errors
Reply #20 - May 3rd, 2011 at 3:35pm
Post Tools
Excellent! I've tried your suggestion and it worked. Even though about 60 messages are still missing, at least the rest are ok. Thank you so much!

There's another thing, the login button on top of the front page and the registration button at the bottom are not working. I suppose there must be bits of code missing...?

Thank you again


  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Moving Yabb to a new server causes errors
Reply #21 - May 4th, 2011 at 3:41pm
Post Tools
Welcome ....

jem wrote on May 3rd, 2011 at 3:35pm:
I suppose there must be bits of code missing...?

  Using a program like WinMerge, do a Compare of the default template for your YaBB version and the template you're using to find missing lines of code.
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1 [2] 
Topic Tools