YaBB Community and Support Forum
YaBB Home About YaBB Download YaBB YaBB Support Customize Your Forum Development Contribute to the Project
  Welcome, Guest. Please Login or Register


 
Pages: 1 2 
Topic Tools
 
Upgrade from yabb 1.4 all the way to current? (Read 7,823 times)
 Apr 26th, 2011 at 11:12pm
There are no actions to perform.  

virtualassistants 
YaBB Newbie
*
Offline
Posts: 12


None
Upgrade from yabb 1.4 all the way to current?
Can I upgrade my old yabb 1.4 to the current version without it messing anything up?

We are way behind but it has been fine until yesterday when the template file got hacked by a trojan virus. I was able to fix this but must upgrade for better protection.

I was surprised as the yabb file is in a protected directory too.

So can I just download the newest version and upload, without losing info?

thanks for the help in advance, I appreciate it very much.
 
 
IP Logged  
 Reply #1 - Apr 26th, 2011 at 11:28pm
There are no actions to perform.  

JonB 
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 3,625
Land of the Blazing Sun!


None
Re: Upgrade from yabb 1.4 all the way to current?
This Topic was moved here from Programming and other Technical Help by JonB.
 
I find your lack of faith disturbing.
jonbservergeek  
IP Logged  
 Reply #2 - Apr 26th, 2011 at 11:45pm
There are no actions to perform.  

JonB 
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 3,625
Land of the Blazing Sun!


None
Re: Upgrade from yabb 1.4 all the way to current?
Hello

Quote:
So can I just download the newest version and upload, without losing info?



Well, other than the word 'just' the answer is probably:

Yes - you can download the new version, backup your data (also a download effectively) to a local drive, install the new version (and make sure it works), then upload your old data, and YaBB will convert it (your old data) to the new format.  "Then" it will 'just' work  Wink

Its quite do-able,

Read up about installing YaBB:
http://www.yabbforum.com/codex/YaBB.pl?catselect=general

About conversions

http://www.yabbforum.com/codex/YaBB.pl?num=1190674872

You also might want to look through this Upgrading YaBB board.
(its new in the last year or so) That's why I moved your post... Roll Eyes


A few things -

A - I'm glad you were able to patch things.

B - make sure your server has the minimum Perl version for the current YaBB

C - was your old Forum 'modded' or have changes to the Templates? If so, these will need to be 'figured out' in advance.

Really Good News - the new YaBB (besides the many new features) is very secure, and has a built in server backup.

read through the Codex stuff and DL the current version, then look thru the Quick Start Guide that comes with it.

Ask all the questions you want
Good Luck
Wink
 
I find your lack of faith disturbing.
jonbservergeek  
IP Logged  
 Reply #3 - Apr 27th, 2011 at 12:25am
There are no actions to perform.  

virtualassistants 
YaBB Newbie
*
Offline
Posts: 12


None
Re: Upgrade from yabb 1.4 all the way to current?
Thank you so much! I really appreciate it. I was afraid of upgrading that many levels thinking of all the changes.

When you say save data, I would think that would be the Board folder and the Member folder?
 
 
IP Logged  
 Reply #4 - Apr 27th, 2011 at 12:53am
There are no actions to perform.  

JonB 
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 3,625
Land of the Blazing Sun!


None
Re: Upgrade from yabb 1.4 all the way to current?
"When you say save data, I would think that would be the Board folder and the Member folder? "

You should read the Codex articles about now, LOL  Wink

Quote:
Once you have entered Maintenance Mode, you must log into your server and make a copy of the following directories:

Required

  * Boards
  * Messages
  * Members
  * Variables

  * Attachments (to be uploaded directly to yabbfiles/Attachment in New Forum) using binary mode transfer.


To be honest, YaBB 1.4, is very old, so I have never worked on a 1.4 board - so you should check to see if those folders are present.  (the answer is probably yes - and I'm quite sure they are all needed.

I'm also not long enough in the tooth to know how and when file-uploading (attachments for posts) got welded on.  I'm pretty sure it was a mod first.

Cool
 
I find your lack of faith disturbing.
jonbservergeek  
IP Logged  
 Reply #5 - Apr 27th, 2011 at 12:56am
There are no actions to perform.  

virtualassistants 
YaBB Newbie
*
Offline
Posts: 12


None
Re: Upgrade from yabb 1.4 all the way to current?
I am reading now, thanks for all your help. One more thing, for now, when I go to download the newest, do I download the

yabb 2.5 AE zip
or
yabb 2.5 AE upgrade?

Thanks again for all your help.
 
 
IP Logged  
 Reply #6 - Apr 27th, 2011 at 4:49am
There are no actions to perform.  

JonB 
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 3,625
Land of the Blazing Sun!


None
Re: Upgrade from yabb 1.4 all the way to current?
Hi

You should download the full version, not the upgrade. The upgrade is only for those with very recent versions of YaBB.

The most important thing will be to have a good data backup. I don't know what kind of a hosting package this forum is on. BUT - if there's a good amount of data, there may be a problem downloading full folders.  Many Control Panels have limits on the number of files you can view or download in one pass. For this reason, I suggest you do the data DL with an FTP client, being careful on the transfer type.  Check the Codex articles - but for BACKUP/DOWNLOAD purposes, I'm pretty sure I can generally say that the folders mentioned that are under 'yabb' should be in Text/ASCII mode, and the Attachments folder GENERALLY should be done in Binary mode.  I say this last because you could have text file attachments.

UPLOADING - you will need to be meticulous on the FTP mode and setting permissions


Good Luck
Smiley
 
I find your lack of faith disturbing.
jonbservergeek  
IP Logged  
 Reply #7 - Apr 27th, 2011 at 10:53pm
There are no actions to perform.  

virtualassistants 
YaBB Newbie
*
Offline
Posts: 12


None
Re: Upgrade from yabb 1.4 all the way to current?
Thanks for the help. I already permissioned everything last night but must of missed something. Am doing it all over again right now. Permissions that is. So keeping my fingers crossed too.

Thanks again for your help I really appreciate you.
 
 
IP Logged  
 Reply #8 - Apr 28th, 2011 at 7:06pm
There are no actions to perform.  

virtualassistants 
YaBB Newbie
*
Offline
Posts: 12


None
Re: Upgrade from yabb 1.4 all the way to current?
What if I get an error 500 after I set all permissions on the folders. Do I still have permissions wrong. My Yabb directory is also in a password protected area. Although it was before too.

So I have installed before but a long time ago. I am pretty sure I set the permissions correctly. Any thoughts?
 
 
IP Logged  
 Reply #9 - Apr 28th, 2011 at 7:09pm
There are no actions to perform.  

virtualassistants 
YaBB Newbie
*
Offline
Posts: 12


None
Re: Upgrade from yabb 1.4 all the way to current?
I am going to try setting them one more time.

Is there anyone here that I can pay to do this? If I cannot get this to work?
 
 
IP Logged  
 Reply #10 - Apr 28th, 2011 at 7:41pm
There are no actions to perform.  
Captain John 
Ex Member


None
Re: Upgrade from yabb 1.4 all the way to current?
Usually an ISE 500 is not caused by CHMODs (permissions), usually it is caused by corrupt files.  ALL the files under the yabb2 folder MUST be transferred using an AscII transfer mode.  If not, they'll corrupt on transfer.
 It is true that to get a YaBB installation correct, you must assure 3 things:
1.) The Shebang (Path to Perl) must be correct in 4 files (Setup.pl, YaBB.pl, AdminIndex.pl and ModuleCheck.pl)
2) Uploading files using the correct transfer mode
3.) The correct CHMOD per file (Very Important that all the folders and *.pl files are set to at least 755)
 
 
IP Logged  
 Reply #11 - Apr 28th, 2011 at 11:58pm
There are no actions to perform.  

virtualassistants 
YaBB Newbie
*
Offline
Posts: 12


None
Re: Upgrade from yabb 1.4 all the way to current?
On the transfer files page it said the directory should look like so but there are some files outside the folder in yabbfiles

such as ajax.js, AJS.js, etc.

Do I load those also to the server?

I appreciate all your help.
 
 
IP Logged  
 Reply #12 - Apr 29th, 2011 at 12:19am
There are no actions to perform.  
Captain John 
Ex Member


None
Re: Upgrade from yabb 1.4 all the way to current?
virtualassistants wrote on Apr 28th, 2011 at 11:58pm:
some files outside the folder

virtualassistants wrote on Apr 28th, 2011 at 11:58pm:
such as ajax.js, AJS.js, etc.

 They're not "outside" the folder, they are within the yabbfiles folder.

and of course they must be uploaded.
 
 
IP Logged  
 Reply #13 - Apr 29th, 2011 at 12:23am
There are no actions to perform.  
Captain John 
Ex Member


None
Re: Upgrade from yabb 1.4 all the way to current?
Once you have installed and run Setup.pl and everything is working ... Be sure you reset the start date/time of the New forum to the Start Date/Time of the Old forum before you run Setup.pl again to Covert your old data files.
 
 
IP Logged  
 Reply #14 - Apr 29th, 2011 at 12:28am
There are no actions to perform.  

virtualassistants 
YaBB Newbie
*
Offline
Posts: 12


None
Re: Upgrade from yabb 1.4 all the way to current?
Thanks for all your help, you're the best. Am working on it now. Hope third time is the charm.
 
 
IP Logged  
Pages: 1 2 
Topic Tools
 

Get Yet another Bulletin Board at SourceForge.net. Fast, secure and Free Open Source software downloads Support This Project BoardMod - YaBB features and templates YaBB Codex - support on installation and usage YaBB Toolbar for your browser

YaBB Facebook Group Page

Vulnerability Scanner

Valid RSS Valid XHTML Valid CSS Powered by Perl
YaBB Chat and Support Community » Powered by YaBB 3.0 Beta!
YaBB Forum Software © 2000-2011. All Rights Reserved.