Page Index Toggle Pages: [1] 2 
Topic Tools
Very Hot Topic (More than 25 Replies) Modify Button (Read 7,289 times)
Elrick.
YaBB Moderators
Beta Testers
***
Offline



Posts: 163
Location: Edge of the Abyss

YaBB 2.6.1
Modify Button
May 11th, 2011 at 8:38pm
Post Tools
Hi,

On one of the boards on my forum (set up exactly the same as the others) the Modify and delete buttons does not appear on Members posts. In any of the other boards it is available to members.
Any help or indication would be greatly appreciated. Many thanks

Elrick
« Last Edit: May 11th, 2011 at 8:54pm by Elrick. »  

<div class=
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Modify Button
Reply #1 - May 12th, 2011 at 9:19pm
Post Tools
You don't state what version of YaBB you're using ........
 In Y2.5 these are under Post Tools
Under either it depends on the Admin Center Settings on how long a user has (timed setting) to Modify or Delete.
« Last Edit: May 12th, 2011 at 9:20pm by »  
Back to top
 
IP Logged
 
Elrick.
YaBB Moderators
Beta Testers
***
Offline



Posts: 163
Location: Edge of the Abyss

YaBB 2.6.1
Re: Modify Button
Reply #2 - May 12th, 2011 at 9:48pm
Post Tools
Hi Captain John,

Thank you for your reply. My version of YaBB is quoted on top right hand corner of my posts: YaBB 2.5.

Time limit for modify is set to 2 days for all members. As stated on my post they have available the buttons to modify or delete when they post on any of the other boards of the forum, but whenever they post on that specific board I was referring to, the buttons for modify or delete are not available on their posts on that board from the moment they post.

This is very puzling that only on that board they are not able to modify their posts. Not an issue of time limit as the buttons does not appear at all from the time they post. That board was already existent together with the other 8 boards when upgraded to 2.5 and they were able to delete or modify prior to upgrade. that board itself is set up exactly as the others. I fail to see a logical reason why they cannot modify when posting.

Any suggestions on what can I look at to find the reasons?

Many thanks for your assistance.

P.S.  additional information:

Hi Captain John,

To illustrate the issue here are two posts made by the same member within a minute of each other on two different boards of the forum. On board No.3 there is no modify or delete buttons, where on board No.4 they are available on the post. It is for some obscure reason that posts on board No.3 members cannot modify their posts due to the absence of the buttons.

I will be very grateful for any insights you might shed on this puzzle.  Many thanks for your help and assistance.




« Last Edit: May 13th, 2011 at 10:27am by Elrick. »  

<div class=
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Modify Button
Reply #3 - May 13th, 2011 at 2:46pm
Post Tools
I have never seen this happen ..... on the same forum, on different boards.  There is No control setting to enable/disable these buttons for individual boards.
  Question: Do you have "Topic Starter" highlighted/selected to Reply to Posts, on both boards ?  Same membergroups highlighted/selected to Start "and" Reply permissions ?
  
Back to top
 
IP Logged
 
Elrick.
YaBB Moderators
Beta Testers
***
Offline



Posts: 163
Location: Edge of the Abyss

YaBB 2.6.1
Re: Modify Button
Reply #4 - May 13th, 2011 at 4:03pm
Post Tools
Hi Captain John,

Thank you so much for looking into this, and yes that was my first thought that perhaps the boards permissions were somehow different but I have checked them all and they are set up identically. No difference. This is what it is bugging me that as you say there is no setting/control to enable/disable those buttons and yet members cannot modify on board No.3.

Here is a screenshot of board No.3 settings and the other boards FYI.

Board No.3


Board N.4, 5, 6, 7, 8

Now, if you do come up with a solution I will certainly owe you a tinny like the one I gave to Derek!!.  – Any other areas or files I could look at?.

Many thanks for your time and effort.
  

<div class=
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Modify Button
Reply #5 - May 14th, 2011 at 12:58am
Post Tools
According to your screen captures .. you allow every membergroup (including Guests) to Start/Reply/View all posts.  But the forum (The Lifeboat Forum) actually does not.  So are these actually from the Forum ?
« Last Edit: May 14th, 2011 at 1:02am by »  
Back to top
 
IP Logged
 
Elrick.
YaBB Moderators
Beta Testers
***
Offline



Posts: 163
Location: Edge of the Abyss

YaBB 2.6.1
Re: Modify Button
Reply #6 - May 14th, 2011 at 11:48am
Post Tools
Hi Captain John,

Thank you for staying with this issue.

1. Quote: “So are these actually from the Forum ?”Yes, of course. Took a screen capture of Board No.3 (the troublesome one) and the other boards. The settings are all the same in all boards.

2. Quote: “you allow every membergroup (including Guests) to Start/Reply/View all posts.”Yes, the permissions for membergroups are not highlighted (I am not sure whether highlighting them allow membergroups to perform the function described on top of the windows  or prevent them from Start/Reply/View all posts. Also Guests/Activate cannot post until Admin sets the posts count at least to 2. Once membership is approved.

3. If I highlight the membergroups to View (including Activate) then guests cannot see or read posts on the boards. Weird!!!

4. All  registered members can modify their posts in all boards except Board No.3. Why??.
If a member start a new topic on Board No.3 then the Modify and Delete buttons are available to them but if they Reply to a post by other members then the buttons are not available to Modify or Delete on that board but available on the others. A Mystery!!!.

What else can we explore?
Thank you for your efforts with this issue!

  

<div class=
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Modify Button
Reply #7 - May 14th, 2011 at 3:18pm
Post Tools
Elrick. wrote on May 14th, 2011 at 11:48am:
2. Quote:
“you allow every membergroup (including Guests) to Start/Reply/View all posts.”
Yes, the permissions for membergroups are not highlighted (I am not sure whether highlighting them allow membergroups to perform the function described on top of the windows  or prevent them from Start/Reply/View all posts. Also Guests/Activate cannot post until Admin sets the posts count at least to 2. Once membership is approved.

3. If I highlight the membergroups to View (including Activate) then guests cannot see or read posts on the boards. Weird!!!


 Not actually weird if you think about it.  There is No Guest membergroup.  So highlighting a membergroup(s) restricts permissions to that or those membergroups.  When None (or not any) membergoup is selected, then Guests are allowed, because No access is restricted to any membergoup .


Attach a screen snapshot of the Membergroups Setup screen for Post Dependent ....
« Last Edit: May 14th, 2011 at 3:22pm by »  
Back to top
 
IP Logged
 
Elrick.
YaBB Moderators
Beta Testers
***
Offline



Posts: 163
Location: Edge of the Abyss

YaBB 2.6.1
Re: Modify Button
Reply #8 - May 14th, 2011 at 5:15pm
Post Tools
Hi Captain John,

Herewith a screenshot of current setup for Post-Dependent Member Groups



I am at a loss as to why members can start a topic on Board No.3 and being able to modify and delete as the buttons are available, BUT not when they reply to another member's posts on that board!!.  Still a mystery!!

  

<div class=
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Modify Button
Reply #9 - May 15th, 2011 at 4:22pm
Post Tools
mmmm I see no setup reason why this happening ... I have 2 Y2.5 forums setup and don't have the problem, never had a user (before you) report this either ...
  Can't be CHMODs, Permissions or any other normal reason that I am aware of.  So unable to give you a place to start to look..
   Though I have not given up on your problem ... will keep trying to even think of a reason for it.
  
Back to top
 
IP Logged
 
Elrick.
YaBB Moderators
Beta Testers
***
Offline



Posts: 163
Location: Edge of the Abyss

YaBB 2.6.1
Re: Modify Button
Reply #10 - May 16th, 2011 at 12:19pm
Post Tools
Hi Captain John,

Very many thanks for your persistance and perseverance with this issue. There has been a number of glitches since upgrade to 2.5 from 2.1 but not overly troublesome!. It might be some scripts went astray during upgrade.

One of them is posts views count. It went up the creeck!
Another is Stored PMs on users profile. They show not highlighted (not in Bold font) and the number of stored PMs but they are not accessible. See example of screenshot below: Storage 38.



I am sure there is a reason for these glitches but the rubb is to find out why and whether they could be remedied. Embarrassed

Thanks ever so much for all the continuous support of this forum. I would be lost without it!. Cry
« Last Edit: May 16th, 2011 at 12:31pm by Elrick. »  

<div class=
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Modify Button
Reply #11 - May 16th, 2011 at 3:59pm
Post Tools
This thread might help: http://www.yabbforum.com/community/YaBB.pl?num=1271912786

  Seems maybe not all the yabb2/Variables files were transferred and possibly renamed from the old version to the update.  What was your Old version of YaBB before upgrading ?
« Last Edit: May 16th, 2011 at 4:12pm by »  
Back to top
 
IP Logged
 
Elrick.
YaBB Moderators
Beta Testers
***
Offline



Posts: 163
Location: Edge of the Abyss

YaBB 2.6.1
Re: Modify Button
Reply #12 - Jun 15th, 2011 at 1:21pm
Post Tools
The saga continues....

It seems all files were properly transferred when upgraded from 2.1. Now the problem has extended to two additional boards where members cannot mofidy/delete their posts due to the absence of the buttons on their posts.

I run out of ideas about this issue or explanations for the possible causes..... Cry -  but I am certain there must be some somewhere  Undecided.

It only happens when replying to a post but not when starting a new topic. Now there are three boards with this problem.

I will be eternally grateful for any suggestions.... Kiss
  

<div class=
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Modify Button
Reply #13 - Jun 15th, 2011 at 5:04pm
Post Tools
There was a minor template code fix after Y2.5 was released to fix tags, try this .....
http://www.yabbforum.com/community/YaBB.pl?num=1278599869/6#6
  
Back to top
 
IP Logged
 
Elrick.
YaBB Moderators
Beta Testers
***
Offline



Posts: 163
Location: Edge of the Abyss

YaBB 2.6.1
Re: Modify Button
Reply #14 - Jun 16th, 2011 at 2:40pm
Post Tools
Hi Captain John,

Very many thanks for staying with this issue and your continued support. I value that.
I appreciate the link you provided. It is instructive but seems an unrelated issue.

Have run several tests and found that it appears it is not board-related. It happens in any board now
when replying and there is an ex-member post on a thread/topic. Then the Modify/Delete buttons are
not available, but, interestingly,  if the thread/topic goes onto a new page and in that page there
is no ex-member post, then the Modify/Delete buttons are available again!!.  Weird and bizarre!!!

Below is a couple of screen-shots to elucidate the foregoing. Post No.134 is a reply to a thread/topic where
there is an ex-member post on that page and the buttons are not available. Post No.135 reply to the same thread/topic but on a new page and the buttons appear available again. ---- Mysterium Tremendum --- !!!!!!

Now, the $64K Question:  What can induce this event? (never happened before on 2.1 even when the same events of ex-member post appeared on a thread). Any ideas?, suggestions? Possible causes?






« Last Edit: Jun 16th, 2011 at 2:42pm by Elrick. »  

<div class=
Back to top
 
IP Logged
 
Page Index Toggle Pages: [1] 2 
Topic Tools
 
  « Board Index ‹ Board  ^Top