YaBB Community and Support Forum
YaBB Home About YaBB Download YaBB YaBB Support Customize Your Forum Development Contribute to the Project
  Welcome, Guest. Please Login or Register


 
Page Index Toggle Pages: 1
Topic Tools
 
Cpanel upgrade - everything lost. Please help! (Read 4,361 times)
 Jul 27th, 2011 at 7:25pm
There are no actions to perform.  

Sim - WOLF 
YaBB Newbie
*
Offline
Posts: 11


None
Cpanel upgrade - everything lost. Please help!
I was running my beloved forum without any issues at all - YaBB.0 v2.1  http://wolf-rs.co.uk/yabb/

For weeks I continually received prompt emails from Cpanel to upgrade to v2.3.1 so I clicked just 1 button to see what it was all about and it did an auto run so the decision was taken out of my hands for me.  

An error message then appeared and now I get an Internal Server Error 500 - "The server encountered an internal error or misconfiguration and was unable to complete your request.  Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request".

The error log says:  [Sun Jul 24 21:34:46 2011] [error] [client 82.153.191.169] Bareword found where operator expected at Paths.pl line 57, near "<p class="redtext">Could"
[Sun Jul 24 21:34:46 2011] [error] [client 82.153.191.169] \t(Missing operator before Could?)
[Sun Jul 24 21:34:46 2011] [error] [client 82.153.191.169] Bareword found where operator expected at Paths.pl line 57, near "/public_html/yabb"
[Sun Jul 24 21:34:46 2011] [error] [client 82.153.191.169] \t(Missing operator before yabb?)
[Sun Jul 24 21:34:46 2011] [error] [client 82.153.191.169] Bareword found where operator expected at Paths.pl line 58, near "<p class="redtext">Could not open /home"
[Sun Jul 24 21:34:46 2011] [error] [client 82.153.191.169] (Might be a runaway multi-line // string starting on line 57)
[Sun Jul 24 21:34:46 2011] [error] [client 82.153.191.169] \t(Missing operator before home?)
[Sun Jul 24 21:34:46 2011] [error] [client 82.153.191.169] Bareword found where operator expected at Paths.pl line 59, near "<p class="redtext">Could not open /home"
[Sun Jul 24 21:34:46 2011] [error] [client 82.153.191.169] (Might be a runaway multi-line // string starting on line 58)
[Sun Jul 24 21:34:46 2011] [error] [client 82.153.191.169] \t(Missing operator before home?)
[Sun Jul 24 21:34:46 2011] [error] [client 82.153.191.169] Bareword found where operator expected at Paths.pl line 60, near "<p class="redtext">Could not open /home"
[Sun Jul 24 21:34:46 2011] [error] [client 82.153.191.169] (Might be a runaway multi-line // string starting on line 59)
[Sun Jul 24 21:34:46 2011] [error] [client 82.153.191.169] \t(Missing operator before home?)
[Sun Jul 24 21:34:46 2011] [error] [client 82.153.191.169] Search pattern not terminated at Paths.pl line 60.
[Sun Jul 24 21:34:46 2011] [error] [client 82.153.191.169] Compilation failed in require at YaBB.pl line 47.
[Sun Jul 24 21:34:46 2011] [error] [client 82.153.191.169] BEGIN failed--compilation aborted at YaBB.pl line 61.
[Sun Jul 24 21:34:46 2011] [error] [client 82.153.191.169] Premature end of script headers: YaBB.pl

I'm at such a loss how to fix it.  My host (Betterwebspace) have been great and tried to assist but they now recommend a fresh install and I'd lose everything.  Albeit it looks like I've lost it all now anyway.

Can anyone please please help me?  I'm not very technical minded but I will do my best to try any recommendations  Smiley
 
 
IP Logged  
 Reply #1 - Jul 27th, 2011 at 9:58pm
There are no actions to perform.  
Captain John 
Ex Member


None
Re: Cpanel upgrade - everything lost. Please help!
First Don't panic and do anything foolish ........
1.) Have you done a backup of your forum or website anytime recently ?
2.) FTP or use cPanel to "view" your folder (directory) and check if the folders and files are still there, the Most important are the /Boards, /Members, /Messages and possibly the /Variables and /Attachments folders.
 If these folders above still contain the files .. your forum is recoverable.

Note: YaBB does not support, promote or actually has nothing to do with this cPanel Addon.  It is developed by a third party for cPanel to sell and/or include with the cPanel installation.
 
 
IP Logged  
 Reply #2 - Jul 28th, 2011 at 8:30pm
There are no actions to perform.  

Sim - WOLF 
YaBB Newbie
*
Offline
Posts: 11


None
Re: Cpanel upgrade - everything lost. Please help!
Hi, thank you for replying!

Yes I did a backup of my forum only a few days prior and all the files look as though they are still there!

There are a couple of new folders also now:      yabb.cpaddons_upgrade.backup
yabbfiles2.4
 
If there is a glimmer of hope here I'm very happy!!
 
 
IP Logged  
 Reply #3 - Jul 28th, 2011 at 11:12pm
There are no actions to perform.  
Captain John 
Ex Member


None
Re: Cpanel upgrade - everything lost. Please help!
Read this on the YaBB Codex http://www.yabbforum.com/codex/YaBB.pl?num=1190671650

Now since you still have the ./Boards, ./Members and ./Messages folders (and also have fairly new backup) Your site is recoverable ...
 If you have ANY problems Holler !
Do NOT overwrite any file in those folders, nor in the ./Variables folder from an Installation zip.  Since your Quick install failed, you might consider upgrading YaBB to Y2.5.  Only need to do a manual install.
« Last Edit: Jul 28th, 2011 at 11:15pm by N/A »  
 
IP Logged  
 Reply #4 - Jul 29th, 2011 at 8:23pm
There are no actions to perform.  

Sim - WOLF 
YaBB Newbie
*
Offline
Posts: 11


None
Re: Cpanel upgrade - everything lost. Please help!
I have printed the Codex document off and amended permissions as recommended but I'm struggling with what to do next (binary mode etc?).

« Last Edit: Jul 29th, 2011 at 9:05pm by Sim - WOLF »  
 
IP Logged  
 Reply #5 - Jul 29th, 2011 at 9:05pm
There are no actions to perform.  

Sim - WOLF 
YaBB Newbie
*
Offline
Posts: 11


None
Re: Cpanel upgrade - everything lost. Please help!
Also, it looks as though I have 4 forums sitting on my directory, 3 of which include my original and the recent upgrades - should I delete any of these off?  I have amended the permissions as suggested against just the yabb folder only.

The yabbOLD folder was from a previous upgrade but it seemed that my normal YaBB could not work without it.  All so confusing!

Directory folders:
  • yabb
    yabb.cpaddons_upgrade.backup
    yabbfiles2.4
    yabbOLD
« Last Edit: Jul 29th, 2011 at 9:06pm by Sim - WOLF »  
 
IP Logged  
 Reply #6 - Jul 31st, 2011 at 8:19pm
There are no actions to perform.  
Captain John 
Ex Member


None
Re: Cpanel upgrade - everything lost. Please help!
If your not hurting for disk space .. I would NOT delete any folder until you have the New forum running and correct.
 If the Forum you were using, required the other folder .. then you Path Settings were (are) incorrect.
Sim - WOLF wrote on Jul 29th, 2011 at 8:23pm:
but I'm struggling with what to do next (binary mode etc?).

  If your manually installing the forum (as suggested) and your using an FTP to upload files .. do NOT use the Auto transfer mode, the file extentions in YaBB might not be understood and the incorrect transfer mode will corrupt file. It is strongly suggested ALL files under the yabb2 folder be transferred (uploaded) in AscII transfer mode.
« Last Edit: Jul 31st, 2011 at 8:22pm by N/A »  
 
IP Logged  
 Reply #7 - Jul 31st, 2011 at 8:48pm
There are no actions to perform.  

Sim - WOLF 
YaBB Newbie
*
Offline
Posts: 11


None
Re: Cpanel upgrade - everything lost. Please help!
Thank you so much for all your support and advice Captain John.  

Another forum member kindly did the previous upgrade for me which linked to old files so I guess to upgrade again everything will be pointing in all sorts of places!

After much deliberation and attempts, I just can't resolve this myself (just far too technical for me) so am sadly going to uninstall and delete everything.   Sad
 
 
IP Logged  
 Reply #8 - Aug 1st, 2011 at 12:16am
There are no actions to perform.  

Tony Barnett 
YaBB Newbie
*
Offline
Posts: 20
Mansfield, Victoria, Australia


YaBB 2.5
Re: Cpanel upgrade - everything lost. Please help!
Quote:
Now since you still have the ./Boards, ./Members and ./Messages folders (and also have fairly new backup) Your site is recoverable ...

As Captain John suggests it would be a good idea NOT to delete anything until we/you get a clean installation up and running!

From there it is a relatively simple process to recover your old data.

You could do a new install in a new location (e.g. /forums) and just ignore your old installations until you need the backup.

This way shouldn't be nearly as confusing.

Let us know if you need further assistance with the new setup or recovering your backup?
 
...
WWW AdventurePro-Australia-New-Zealand/30522938281  
IP Logged  
 Reply #9 - Aug 9th, 2011 at 9:34pm
There are no actions to perform.  

Sim - WOLF 
YaBB Newbie
*
Offline
Posts: 11


None
Re: Cpanel upgrade - everything lost. Please help!
I would like to say the biggest thanks ever to Tony Barnett for his amazing work on recovering my group's forum.

Everything was fully restored and issues from a previous upgrade were also fixed.  

The after-support provided has been excellent too and I now have a much better understanding of the more technical aspects of Yabb.  

Tony, you are a true asset to the Yabb community!!
 
 
IP Logged  
Page Index Toggle Pages: 1
Topic Tools
 

Get Yet another Bulletin Board at SourceForge.net. Fast, secure and Free Open Source software downloads Support This Project BoardMod - YaBB features and templates YaBB Codex - support on installation and usage YaBB Toolbar for your browser

YaBB Facebook Group Page

Vulnerability Scanner

Valid RSS Valid XHTML Valid CSS Powered by Perl
YaBB Chat and Support Community » Powered by YaBB 3.0 Beta!
YaBB Forum Software © 2000-2011. All Rights Reserved.