Page Index Toggle Pages: 1
Topic Tools
Hot Topic (More than 10 Replies) Problems upgrading to 2.5 (Read 1,713 times)
simviator
Junior Member
**
Offline



Posts: 91
Problems upgrading to 2.5
Aug 30th, 2011 at 12:55pm
Post Tools
I have tried to follow detailed instructions to upgrade from 2.4 to 2.5.

All files uploaded in yabb_2_5_upgrade_all.
All cgi-bin files uploaded in ascii (filezilla)
Chmod according to Yabb Quick Start Guide - all folders/sub folders and files checked


All seemed to be going great - in maintenance mode -- checked back and the new 2.5 forum looked good - all looked OK with 'yabb 2.5' listed at the foot.

So I looked around the boards to make sure all was looking good then unchecked 'maintenance mode' - then I got Internal Server Error 500.

I have gone through the Support Codex and gone through all files again to check chmods, etc.

Unticked  use CGI::Carp qw(fatalsToBrowser); # used only for tests
And this is the message:

Software error:

Nested quantifiers before HERE mark in regex m/^217.159.200.** << HERE */ at ./Sources/Security.pl line 145.



Running freebsd with perl 5.6.1


Any help would be appreciated.

  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Problems upgrading to 2.5
Reply #1 - Aug 30th, 2011 at 2:30pm
Post Tools
Did you transfer ALL your filessimviator wrote on Aug 30th, 2011 at 12:55pm:
So I looked around the boards to make sure all was looking good then unchecked 'maintenance mode' - then I got Internal Server Error 500.


   Was this before or after you transferred your old forum files to the new forum ? 


Sounds like you have an error in ban_log.txt in the yabb2/Variables folder .. Had you transferred the files from your old forum to the ./Variables folder of your new installation ?
  
Back to top
 
IP Logged
 
simviator
Junior Member
**
Offline



Posts: 91
Re: Problems upgrading to 2.5
Reply #2 - Aug 30th, 2011 at 2:36pm
Post Tools
HI,

I didn't transfer any files from the old forum - as stated in the Readme Update for 2.5:

[color=#ff0000]INSTALLATION NOTES FOR UPDATES FROM YABB 2.4 TO 2.5
*********************************************************

     1)  Set your Forum in Maintenance mode.

     2)  Make a Backup of your forum. For example with YaBBs "Backup" feature.
         Backup at least the folders:
         Boards, Members, Messages and Variables

     3)  Upload all files from the "YaBB_2_5_upgrade_all" folder.

     4)  CHMOD the uploaded files like the other files were set. If you don't remember,
         look into the Quick-Guide in the full version download package.
[/color]


So I uploaded the updated files into the same yabb2 directory in my cgi-bin (over writing the old files).

All the other files were left untouched.
The problem only began when I unchecked 'maintenance mode'.
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Problems upgrading to 2.5
Reply #3 - Aug 30th, 2011 at 3:01pm
Post Tools
So ... since the ./Variables folder in the Y2.5 (Upgrade_All) installation folder is empty, you did not overwrite any files in that old forum's folder, correct ?

  
Back to top
 
IP Logged
 
simviator
Junior Member
**
Offline



Posts: 91
Re: Problems upgrading to 2.5
Reply #4 - Aug 30th, 2011 at 3:20pm
Post Tools
In that folder I have:

bots.hosts
Menu0.def
Menu2.def

These files were uploaded but I don't think they overwrote anything (but can't remember exactly about that)
  
Back to top
 
IP Logged
 
simviator
Junior Member
**
Offline



Posts: 91
Re: Problems upgrading to 2.5
Reply #5 - Aug 30th, 2011 at 3:28pm
Post Tools
I should add that I have also tried the 'alternative' chmod settings with no change.

thanks
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Problems upgrading to 2.5
Reply #6 - Aug 31st, 2011 at 3:19am
Post Tools
simviator wrote on Aug 30th, 2011 at 3:20pm:
In that folder I have:

bots.hosts
Menu0.def
Menu2.def



That's all ?  Where are your prior files from your old forum ?
  
Back to top
 
IP Logged
 
simviator
Junior Member
**
Offline



Posts: 91
Re: Problems upgrading to 2.5
Reply #7 - Aug 31st, 2011 at 7:02am
Post Tools
Quote:
Y2.5 (Upgrade_All) installation folder is empty,


I don't mean in my existing Variables folder -- The 2.5 Upgrade All Variables folder is not empty as you suggest -- It contains the files I mention above ..

Meanwhile I have 25,000 people waiting to get their forum back up.

I think I'm going to have to contract someone from scriptlance.
  
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Problems upgrading to 2.5
Reply #8 - Aug 31st, 2011 at 2:22pm
Post Tools
simviator wrote on Aug 31st, 2011 at 7:02am:
The 2.5 Upgrade All Variables folder is not empty as you suggest --

The YaBB_2_5_"Upgrade All" ./Variables folder in the Y2.5 Installation zip is empty ....
The YaBB_2_5_ Upgrade from Y_2_3_x has those 3 files in ...


simviator wrote on Aug 31st, 2011 at 7:02am:
Meanwhile I have 25,000 people waiting to get their forum back up.

I think I'm going to have to contract someone from scriptlance.


Do what you need to do ...
« Last Edit: Aug 31st, 2011 at 2:23pm by »  
Back to top
 
IP Logged
 
simviator
Junior Member
**
Offline



Posts: 91
Re: Problems upgrading to 2.5
Reply #9 - Aug 31st, 2011 at 3:56pm
Post Tools
Take a look:

Upgrade all / variables folder is not empty ...

Proof attached.

  

yabbvariables.jpg ( 35 KB | 69 Downloads )
yabbvariables.jpg
Back to top
 
IP Logged
 
Captain John
Ex Member


Re: Problems upgrading to 2.5
Reply #10 - Sep 1st, 2011 at 3:39pm
Post Tools
Quote:
Sounds like you have an error in ban_log.txt in the yabb2/Variables folder ..

  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Topic Tools
 
  « Board Index ‹ Board  ^Top