Page Index Toggle Pages: 1
Topic Tools
Hot Topic (More than 10 Replies) Problem with installing YaBB (Read 3,095 times)
Lefri
YaBB Newcomer
*
Offline



Posts: 8

None
Problem with installing YaBB
Sep 21st, 2011 at 8:54am
Post Tools
recently, I have been told by my boss to set up a forum for a project and I have been reading a lot of information saying Yabb is an amazing self host forum system on the internet. So, I recently have a try on it, and now in the testing phases. I am using the latest version, 2.5, and I probably followed all the installation guide which is included in the package. (I am sorry that I am not person who is good at computer and know about the Perl language)

However, I still found some problems.
1) sometimes when i login, it says
"Unable to open ./Members/username.vars
: Permission denied"
while i can login in the other computers with the exactly the same login user name. it is really weird.

2) sometimes, I even cannot register a new account, and it just gone to the search engine pages like Googles.

could anyone please kindly help me out with these?
I am kind of in the middle of rush!! Cry

Cheers
  
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 4,039
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Problem with installing YaBB
Reply #1 - Sep 21st, 2011 at 10:38am
Post Tools
Quote:
1) sometimes when i login, it says
"Unable to open ./Members/username.vars
: Permission denied"


WHERE do you get this message?? we don't know what 'the other computers' would be referring to.

Quote:
2) sometimes, I even cannot register a new account, and it just gone to the search engine pages like Googles


WHEN and WHERE - are you unable to register new users???  when you are using the Admin Center??? (it sounds like you might have a browser hijacker)

Good Luck
Smiley

  

I find your lack of faith disturbing.
Back to top
IP Logged
 
Lefri
YaBB Newcomer
*
Offline



Posts: 8

None
Re: Problem with installing YaBB
Reply #2 - Sep 22nd, 2011 at 2:10am
Post Tools
I am Sorry!! maybe i have not made myself clear enough with my poor English!!

Let me explain more.

in fact, I installed YaBB and done the SETUP part by using computer A. and I can login as an admin and also can register a new account for myself.

while I am using computer B, it cannot register a new account or login as admin and pop-up the msg "UNable to open ./Members/username(or admin).vars: Permission denied"

after a while, I tried to use Computer C to login as admin and register new account. and it works. however, come back to Computer A, it cannot login anymore, and this time even dont have the background and all the gif. have been dead linked.

it is really weird!!

one interesting finding today, if i didn't logout in computer A (just close the browser), then i login with computer B with the same username successfully, when come back to computer A, it cannot login anymore. Shocked

i really donno what to do with this situation.

and what do you mean by broswer hijacker??

please kindly help me out!! Thank you so much with your sincerely reply!! and any support from whom reading this post is welcome as well. APPRECIATED!!  Cry
« Last Edit: Sep 22nd, 2011 at 2:27am by Lefri »  
Back to top
 
IP Logged
 
Lefri
YaBB Newcomer
*
Offline



Posts: 8

None
Re: Problem with installing YaBB
Reply #3 - Sep 22nd, 2011 at 2:23am
Post Tools
I have captured the screen as a reference.

Help me please..... Cry

Thank you!!!
  

screen_cap.JPG ( 96 KB | 93 Downloads )
screen_cap.JPG
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 4,039
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Problem with installing YaBB
Reply #4 - Sep 22nd, 2011 at 4:04am
Post Tools
OK, I understand better what is wrong now (although I do not know yet what is causing the problem)

I think we can forget this "and what do you mean by broswer hijacker??" - not the issue.

Perhaps you better explain what kind of a server and network you have and how its connected.

If i heard the symptoms and did not know what program it was, I would say you have a concurrent users problem. i.e "for some reason only 'x' people can be logged on due some unknown factor" (what i really do is I am a network engineer)

Good Luck
Cool
« Last Edit: Sep 22nd, 2011 at 4:06am by JonB »  

I find your lack of faith disturbing.
Back to top
IP Logged
 
Lefri
YaBB Newcomer
*
Offline



Posts: 8

None
Re: Problem with installing YaBB
Reply #5 - Sep 22nd, 2011 at 9:16am
Post Tools
Thank a lot for your reply~! you r really kind~!! Smiley

as i know, it is a UNIX system which is host by my company, i have been allocated some space of the server to put in the software.

here is my latest situation, i have tried to set all the files from the permission which should be in 755 to 777.
by that, my computer A and B, my co-worker's and my iphone did can login and register a new account. but not the other computers!

it is really weird! I am so exhausted!!!  Cry SOS!!
  
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 4,039
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Problem with installing YaBB
Reply #6 - Sep 22nd, 2011 at 9:54am
Post Tools
I don't think it has to do with file permissions - they don't change once you set them, and they affect all client's the same.

How did you configure the address of the server?  with a domain name???  If you used a domain name, are you also using your own DNS servers?

Huh

  

I find your lack of faith disturbing.
Back to top
IP Logged
 
Lefri
YaBB Newcomer
*
Offline



Posts: 8

None
Re: Problem with installing YaBB
Reply #7 - Sep 23rd, 2011 at 2:04am
Post Tools
JonB wrote on Sep 22nd, 2011 at 9:54am:
I don't think it has to do with file permissions - they don't change once you set them, and they affect all client's the same.

How did you configure the address of the server?  with a domain name???  If you used a domain name, are you also using your own DNS servers?

Huh



I am sorry~ I am not really familiar with these technical terms, I don't know whether this is called DNS system or not~ but please allow me to explain it in this way.

my company ABC has three servers with different system,
and she has granted me a section in the server with UNIX system. She gave me the address is
http://home.ABC.com/~username/

is that a domain name system??
will that be the problem that, in fact, the company is not allow us to give permission to others to write/read/execute? (but that cannot explain why some computer can login or create a new account, weird!!!)

please forgive my innocence  in the I.T. field. Cry
  
Back to top
 
IP Logged
 
Lefri
YaBB Newcomer
*
Offline



Posts: 8

None
Re: Problem with installing YaBB
Reply #8 - Sep 23rd, 2011 at 9:06am
Post Tools
false alarm Cry

now i have installed v2.4

i thought it will be fine when i can login and create account on 5 computers, however, to the 6th computer, it failed to do so again~!!! Undecided

OMG!!

  
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 4,039
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Problem with installing YaBB
Reply #9 - Sep 23rd, 2011 at 2:47pm
Post Tools

what actually happens on the 6th computer???? (you can't IS NOT a description of an error, it is a statement of a fact)

As for this -

Quote:


Under the assumption the 'username' on the Unix system was 'Lefri'

then the URL for YaBB should be something like:

http://home.ABC.com/Lefri/cgi-bin/yabb2/YaBB.pl
(and should be exactly like that, no matter where anyone logs in from).


The permissions in the folders need to be as stated in the Codex and Installation Quick Guide.

The best thing would be to paste the contents of the Paths.pl file in a Private Message to me, and I will see if they should work or not.


Quote:
will that be the problem that, in fact, the company is not allow us to give permission to others to write/read/execute? (but that cannot explain why some computer can login or create a new account, weird!!!)

the Permissions ONLY need to be 'global' in the folders YaBB is in - so the rest of the ~username folder can follow any company policies


Good Luck
Cool
You should talk to your company's IT department/ system administrators.
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
Lefri
YaBB Newcomer
*
Offline



Posts: 8

None
Re: Problem with installing YaBB
Reply #10 - Sep 26th, 2011 at 2:29am
Post Tools
I am so sorry I didn’t make it clear for the 6th computer, actually, I mean it happened to be have the same problem, which is cannot login as an admin and also creating a new account.

Exactly!! The link I am using is like
http://home.ABC.com/~Lefri/cgi-bin/yabb2/YaBB.pl

and the permission I have set exactly what the installation guide said and checked a thousand times, so, I think it is fine with the permission (and also, since I can login and create new account in some computers, that means the permission is fine here.)

Last but not least, I have spoken with my company’s IT department, she has checked out the server for me. And said it is fine, shouldn’t be the problem with my current situation. But she cannot figure out what’s going on indeed. Sigh….. Undecided

I have sent you the pm. Plx kindly check, thank you very much!! It has been a week, and you still keep on helping me out. Really appreciated!! Smiley
  
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 4,039
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Problem with installing YaBB
Reply #11 - Sep 28th, 2011 at 1:15am
Post Tools
The problem is likely that the ~Lefri (or whatever) cannot always be resolved based on the state of their Unix logins.

'~' is 'unixese' for a relative path that normally begins in /home of the Unix filesystem. It is effectively installing YaBB as if it were a local Unix application AND using a relative path.  YaBB does not support relative paths. Ask your IT administrators for an absolute URL for the folder YaBB is installed in.

That URL 'may' have to be added to the 'hosts' on those machines as well. "They" should know if that is needed or not.

Good Luck
Cool


  

I find your lack of faith disturbing.
Back to top
IP Logged
 
Lefri
YaBB Newcomer
*
Offline



Posts: 8

None
Re: Problem with installing YaBB
Reply #12 - Sep 28th, 2011 at 7:23am
Post Tools
Thank you so much, JonB.

I have told the IT department about what you said above. and they said there is nothing they can do as "~username" is the default path for the computer. they cannot change it.

So....sad to say, i can't use YaBB this time. but finally, still good to get to know what happened. really appreciate for what you have done for me in the past whole week!!! really appreciate.

in the future, if i had chance to create another forum, i will first think of YaBB and also promote it to the people around, because there r a really good supporting team.

ok~ so.... wish you and YaBB all the best.  Wink
« Last Edit: Sep 28th, 2011 at 7:39am by Lefri »  
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 4,039
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Problem with installing YaBB
Reply #13 - Sep 28th, 2011 at 2:37pm
Post Tools
Good Luck Lefri, sorry it did not work out -

Cool
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
Page Index Toggle Pages: 1
Topic Tools