YaBB Community and Support Forum
YaBB Home About YaBB Download YaBB YaBB Support Customize Your Forum Development Contribute to the Project
  Welcome, Guest. Please Login or Register


 
Pages: 1 2 3 ... 5
Topic Tools
 
Still perplexed on "spamming" issues. (Read 13,330 times)
 Oct 8th, 2011 at 4:10am
There are no actions to perform.  

Jeff Walters 
YaBB Newbie
*
Offline
Posts: 21


YaBB 2.5
Still perplexed on "spamming" issues.
I was being "spammed" with false registered members from all sorts of emails like gmail, hotmail, yahoo, and a lot more. The ones that hit the most are 163.com, 126.com, tom.com, urmail.com yeah.net and a whole lot more.
I went and added all these IP's and emails to the "banned" list but they still show up everysingle day.
So I switched the new registered to "must have admin approval". Now no one can post, not even me!
I removed that to what it was before to "open registraion" and still no on else can post.
What, where do i look and what, where do I "check or click" to allow people to post? I am really getting pissed off at this and all "simple to understand English" comments are welcome.
 
 
IP Logged  
 Reply #1 - Oct 8th, 2011 at 3:04pm
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 1,876
Earth


YaBB 2.5
Re: Still perplexed on "spamming" issues.
Well, first, banning and blocking are two different things. The email domains are 'blocked' under Security Center->Antispam Settings
For the rest - when you banned all those IPs under 'Ban Members' you banned EVERYBODY's IPs

So - unban the IPs then put the email domains you want to block in the Antispam list - just the email domains (second text box) - ie: 123.com, etc.

The current email addresses you have banned should stay banned.
« Last Edit: Oct 8th, 2011 at 3:12pm by Dandello »  
WWW  
IP Logged  
 Reply #2 - Oct 10th, 2011 at 11:12am
There are no actions to perform.  

ortegaj 
YaBB Newbie
*
Offline
Posts: 2


YaBB 2.5
Re: Still perplexed on "spamming" issues.
Is there a new  robot that beat the captcha feature of YABB 2.5 AE???


I've deleten new members from my forum (more than 3 daily) for the past 3 months.

Is there aother option like the one i use in every other site i create:   captcha [dot]  net ???

Please advice.

Thanks
 
 
IP Logged  
 Reply #3 - Oct 10th, 2011 at 10:02pm
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 1,876
Earth


YaBB 2.5
Re: Still perplexed on "spamming" issues.
If there's a new robot beating the 2.5 captcha it hasn't hit my boards.

for the rest:
  1. set the validation image to a higher number of figures and more complex figures than the default - like 8 figures with caps.
  2. block the known spam email domains under Antispam Settings -> Email Domain Filter
  3. add the Anti-spam mod (http://www.boardmod.org/yabb2/YaBB.pl?num=1315522544
  4. use 'pre-registration by email and admin approval of all registrations'
  5. under Antispam Settings - put the minimum number of posts before links and images allowed in messages and in signatures to at something a lot higher than 0.


At least this way, you won't be deleting them from your board, just from your registration log.

This method has taken me from 10 spam registration attempts a day to one a week. And new members can still get through - assuming their 'reason for registering' is not random garbage,
 
WWW  
IP Logged  
 Reply #4 - Oct 11th, 2011 at 11:43am
There are no actions to perform.  

BloodyRue 
Junior Member
**
Offline
Posts: 83


YaBB 2.5
Re: Still perplexed on "spamming" issues.
I just got this error, but the forum spammer mod has been working fine before this one:

Could not find YaBB.xml in ./ at ./Sources/Register.pl line 584
 
...    ...
WWW MVMB1  
IP Logged  
 Reply #5 - Oct 11th, 2011 at 11:49am
There are no actions to perform.  

ortegaj 
YaBB Newbie
*
Offline
Posts: 2


YaBB 2.5
Re: Still perplexed on "spamming" issues.
Thanks man...I did all but one of that list.   Lets see what happen.


The only thing i couldn't find was the "pre-registration" setting.

Can you tell me where is it?
 
 
IP Logged  
 Reply #6 - Oct 11th, 2011 at 3:09pm
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 1,876
Earth


YaBB 2.5
Re: Still perplexed on "spamming" issues.
Admin->Forum Settings->Members
It's about halfway down the page in a select box.

@BloodyRue
on my copy of Register.pl that line is calling for a function in XML::Simple (which is a Perl module).
Check and make sure the module is installed and didn't get updated into oblivion or corrupted. I think some other people have had similar issues but at an educated guess, if this is a brand new problem, then that module is a good place to start looking.
« Last Edit: Oct 11th, 2011 at 3:21pm by Dandello »  
WWW  
IP Logged  
 Reply #7 - Oct 11th, 2011 at 3:44pm
There are no actions to perform.  

Derek Barnstorm 
Support Team
YaBB Next Team
Development Team
Beta Testers
****
Offline
Posts: 1,269
United Kingdom


YaBB 2.5
Re: Still perplexed on "spamming" issues.
ortegaj wrote on Oct 10th, 2011 at 11:12am:
Is there aother option like the one i use in every other site i create:   captcha [dot]  net ???

Hi,

There's a Mod for that here:

http://www.boardmod.org/yabb2/YaBB.pl?num=1315959061
 
 
IP Logged  
 Reply #8 - Oct 11th, 2011 at 10:45pm
There are no actions to perform.  

BloodyRue 
Junior Member
**
Offline
Posts: 83


YaBB 2.5
Re: Still perplexed on "spamming" issues.
I am wondering if the spammer was trying to hack the registration process and got that error. otherwise the mod is working fine on all the rest of the spammers.

i noticed a funky email sent by my initial yabb install and went to check why something was coming from yabb and not yabb2.

in there i found someone waiting in the registration log waiting to be authorized.

i didn't set the board up for that so i am assuming they hacked their way    into that.

i removed yabb.pl from the directory and did a redirection to the new yabb2 board for calls into that directory.
 
...    ...
WWW MVMB1  
IP Logged  
 Reply #9 - Oct 12th, 2011 at 2:18am
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 1,876
Earth


YaBB 2.5
Re: Still perplexed on "spamming" issues.
It does sound odd. I know some other people have had odd problems with getting XML::Simple loaded but since yours is working a majority of the time, then that's not likely to be the same problem.
 
WWW  
IP Logged  
 Reply #10 - Oct 30th, 2011 at 12:45am
There are no actions to perform.  

lazykins 
YaBB Newbie
*
Offline
Posts: 6


YaBB 2.1
Re: Still perplexed on "spamming" issues.
I've got a problem related to this today. I've had my registrations on lock down for sometime. Something attempted to register with user name 12345. I can't delete it from my reg log! Instant delete doesn't delete it. I can't open the View Profile and decide link, I get a message about not being able to view raw data. Cleaning the log didn't work. Can I manually delete my reg log? Can I replace it with a blank?

I upped my captcha settings and tuned everything up a notch after this. Hopefully this was an actual person who is ticked off that they must wait for approval and not a spammer. There were no weird errors at that time, and no other activity on the logs.

Thanks for any suggestions you can provide.

Amy
 
 
IP Logged  
 Reply #11 - Oct 30th, 2011 at 1:26am
There are no actions to perform.  

lazykins 
YaBB Newbie
*
Offline
Posts: 6


YaBB 2.1
Re: Still perplexed on "spamming" issues.
Figured it out when i searched the forum a little further back. Del .pre file in Members dir. Clean log. Thanks YaBB people, for sharing!
 
 
IP Logged  
 Reply #12 - Nov 2nd, 2011 at 1:00pm
There are no actions to perform.  

crazydiamond23 
YaBB Newbie
*
Offline
Posts: 2


None
Re: Still perplexed on "spamming" issues.
lazykins wrote on Oct 30th, 2011 at 1:26am:
Figured it out when i searched the forum a little further back. Del .pre file in Members dir. Clean log. Thanks YaBB people, for sharing!

I am getting killed everyday by spammers. Admittedly, I need to upgrade and change the spamming rules but I am not very good with this stuff. I've noticed that lately my log is being wiped clean as well so this last reply really got my attention. Is there anyone I can contact to do an upgrade for me and change the spamming rules? Would really appreciate some help.

thanks
Tim
 
 
IP Logged  
 Reply #13 - Nov 3rd, 2011 at 9:13am
There are no actions to perform.  

Bod. 
YaBB Newbie
*
Offline
Posts: 46


None
Re: Still perplexed on "spamming" issues.
In the last few days the forum on a site I maintain has been hit with lots of "spam registrations". That is they are signing up, but due to us having to approve members, no spam is actually being posted to the forum (good).  But a bit annoying to the admin who approves/rejects registrations.

We have the captcha set to a length of 9, a mix of upper/lower case & digits. But still they come.  Could bump it up, but don't want to make it too hard for the genuine registrations.

From previous posts on this matter, the conclusion is that there are little fingers in a low cost back-land being paid a few bread crumbs to type away.  Is this still the conclusion?  Do we just wait until they tire of it?  
 
My altzeimer's is improving - I can't remember the last time I forgot something.
 
IP Logged  
 Reply #14 - Nov 3rd, 2011 at 1:46pm
There are no actions to perform.  

AmishCake 
Junior Member
**
Offline
Posts: 97
Ohio, USA


None
Re: Still perplexed on "spamming" issues.
Well, changing the registration to a 6 digit captcha slowed it down at first, but today I woke up to 50 verified and 17 other registrations waiting for approval. Geez! Does it ever end???
 
E.
WWW  
IP Logged  
Pages: 1 2 3 ... 5
Topic Tools
 

Get Yet another Bulletin Board at SourceForge.net. Fast, secure and Free Open Source software downloads Support This Project BoardMod - YaBB features and templates YaBB Codex - support on installation and usage YaBB Toolbar for your browser

YaBB Facebook Group Page

Vulnerability Scanner

Valid RSS Valid XHTML Valid CSS Powered by Perl
YaBB Chat and Support Community » Powered by YaBB 3.0 Beta!
YaBB Forum Software © 2000-2011. All Rights Reserved.