Page Index Toggle Pages: 1
Topic Tools
Normal Topic Installing yabb on ubuntu 11.10 (Read 3,530 times)
Elfen
Full Member
***
Offline



Posts: 450
Re: Installing yabb on ubuntu 11.10
Reply #9 - Jun 13th, 2012 at 8:23pm
Post Tools
Learn something new everyday, JonB.

But I'm assuming that the user in this case has Ubuntu Desktop (11.0-I think), and it trying to install YaBB on it. This is not possible since it Ubuntu Desktop does not have LAMP on it, and its Perl is very minimal at best.

At this point there are two solutions: yours like you stated with XAMPP or its variant of installing LAMP module by Module (the Ubuntu Repository in doing this is not a good one. They are trying to keep you from actually doing it! Their forum is filled with "WHY DES IT NOT WORK!") -OR- use Ubuntu Server Edition and deal with the CLI operations it only supports.

Then there is also using Ubuntu Server Edition and install Gnome or KDE on it and then work it like Ubuntu Desktop, but like the first of installing LAMP onto Ubuntu is difficult because Ubuntu itself, the same applies here. Ubuntu stated that adding a GUI to its shell server edition weakens its security severely. I disagree, though there is a weakness in security, in my mind its not as severe as they state it is.

I'm going to look into this project you are part of. Lord knows that though as stable as my SUSE 9.2 is (with the mods I put on it), its LAMP is showing its age and needs a serious upgrade that Novell makes it impossible to do.
« Last Edit: Jun 13th, 2012 at 8:31pm by Elfen »  
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,785
Location: Land of the Blazing Sun!

YaBB 2.6.0
Re: Installing yabb on ubuntu 11.10
Reply #8 - Jun 11th, 2012 at 2:18pm
Post Tools
Elfen -
I have to disagree (to an extent).

A. Nowadays you can build a LAMP stack with virtually no effort or knowledge on the Desktop variants of Linux. (I do it all the time) all you need to know is how to use your installer package (usually apt-get or yum) and the names of the packages you need.  The new repository systems have all the parts you need already compiled for 'your flavor' on Linux. I run 4 different flavors, and they all work.

B. If you don't want to go that route - Just install XAMPP/lampp for Linux.  It does all the things you need: Apache, MySQL, Perl, PHP, phpMyAdmin, ProFTPd, and Webalizer, all in one install. Its designed for DIY servers. You do need either a root PW or you need to be a member of the sudoers group.

http://www.apachefriends.org/en/xampp-linux.html

I'm a member of that project, and learned its Windows version in anticipation of a YaBB 3.0 that never materialized. So I stuck around and became a debugger, just like here - except - there I'm the Linux debugger, LOL.

From a hosting point of view, with the advent of Virtual Private Servers (VPS's) - the headless Linux server is almost a 'dead duck'.

If you want a local linux server that runs on low resources, I can recommend either LXDE or XCFE desktops - they look a lot like XP and can run on 512MB easily.

In the last few months, I have actually virtualized almost all my local servers as well.  Pretty cool, just call 'em when you want to work on a project, want to try something out? - clone it.  I've done this with both Windows and Linux, but no Hackintoshes yet.  Wink  I like the VirtualBox offering from Oracle.

Just 'my opinion'.
Smiley
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
Elfen
Full Member
***
Offline



Posts: 450
Re: Installing yabb on ubuntu 11.10
Reply #7 - Jun 9th, 2012 at 5:46pm
Post Tools
Tah Zonemaster wrote on Oct 27th, 2011 at 5:19pm:
Hey,
I'm currently running on ubuntu, but installing YaBB doesn't go as it should. Perl should be installed, but when I'm navigating to Setup.pl, firefox asks me if I want to download it. I couldn't find this on google, so any thoughts? Thanks in advance Smiley

Tah Zonemaster

Tah Zonemaster wrote on Oct 27th, 2011 at 5:19pm:
Hey,
I'm currently running on ubuntu, but installing YaBB doesn't go as it should. Perl should be installed, but when I'm navigating to Setup.pl, firefox asks me if I want to download it. I couldn't find this on google, so any thoughts? Thanks in advance Smiley

Tah Zonemaster

I'm just realizing that there might be a mistake here.

You can not install web programs to make a functional website onto Ubuntu/Kubuntu/Xubuntu/etc. They do not have the appropriate settings for a web server and are missing Apache, PHP, MySQL, and much of Perl. These Linux systems are meant to be be Single User Systems only and not Networked Accessed Devices.

To install YaBB (or any other website program), you are going to need Ubuntu Server Edition (aka USE). USE has the components to make a functioning webserver, but does not have a GUI (Graphic User Interface). It works on a CLI (Command Line interface), and everything must be done by hand on the CLI to get YaBB.pl running on USE.

There are ways to all a GUI on to USE and LAMP into regular Ubuntu/Kubuntu/Xubuntu, but these subjects are beyond the scope of this forum and there are many forums out there that discuss this.

Once you get YaBB installed into USE, its like any other webserver out there. But it has to be accessed from a different machine.
« Last Edit: Jun 9th, 2012 at 5:48pm by Elfen »  
Back to top
 
IP Logged
 
Elfen
Full Member
***
Offline



Posts: 450
Re: Installing yabb on ubuntu 11.10
Reply #6 - Jan 23rd, 2012 at 10:34pm
Post Tools
On Ubuntu, you should open a shell or terminal window and type 'perl -v ' on the command line and hit Enter/Return. If Perl is installed, it will give what version of it is on the system. if there is no Perl, it will give you an error instead.

As for the rest of the problem, sounds to me that your permissions are wonky on the CGI-BIN /YaBB files and folders. You should be able to type in on a command window "chmod 755 *" (for the folders) and "chmod 755 *.*" for the files, in there. in a worst case scenero, you will have to do the same inside the Admin and Sources folders individually but this should set the YaBB files to execute.

I've done this on Unbunto 7.0 - 9.0; I dont think its that much harder to do on 11.0.
  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,196
Location: Earth

YaBB 2.6.0
Re: Installing yabb on ubuntu 11.10
Reply #5 - Oct 30th, 2011 at 4:12am
Post Tools
We have been here before haven't we?  Huh
Maybe we should make a check-list.

1) If Perl isn't working, make sure it's installed.  Shocked
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,785
Location: Land of the Blazing Sun!

YaBB 2.6.0
Re: Installing yabb on ubuntu 11.10
Reply #4 - Oct 29th, 2011 at 3:22pm
Post Tools
I'm pretty sure I know what's wrong = (and I'm pretty sure someone didn't use either a file manager or term to go look for the Perl executable as asked - or look at the 'package' being installed)

Some Ubuntu desktop packages do not include Perl, I ran into it before  

read this thread - http://www.yabbforum.com/community/YaBB.pl?num=1316536491

It depends on the distribution 'package' you select - both Fedora and Ubuntu have (IMO) screwed up and turned out so many packages that no-one (off the teams) has any idea "what is in which".
(this goes to my 'other' volunteer job, over on XAMPP, where I have just about the same role)

I think the syntax is:
Code
Select All
 #sudo apt-get install perl
 



or use the synaptic package manager.

or install one of the 'development/server' add-ons

for more:
http://webcache.googleusercontent.com/search?q=cache:ldt9S1sj22kJ:geeksplanet.ne...

I'm not betting the house on this, but I will bet a Strongbow...  Wink

Good Luck
Cool

JonB and Dandello need to go on 'senior vitamins', the kind with 'wonderstuff for enhanced memory'.  Tongue
« Last Edit: Oct 29th, 2011 at 3:50pm by JonB »  

I find your lack of faith disturbing.
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,196
Location: Earth

YaBB 2.6.0
Re: Installing yabb on ubuntu 11.10
Reply #3 - Oct 28th, 2011 at 7:19pm
Post Tools
Tah Zonemaster wrote on Oct 28th, 2011 at 5:54pm:
Hello JonB,
Thankyou very much for your reply.
A: I didn't modify the shebang, it should be correct
B: Dunno, I guess it isn't =/ Can you tell me where I can find the perl settings config? I couldn't find it (neither on google)


If your Perl executable is installed somewhere other than the usual 'usr/bin/' then the shebang  (#!/usr/bin/perl)has to be edited to point to the right place.

Normally, users don't need to worry much about Perl configuration as that is handled automatically during install. The additional add-on modules that some Perl scripts need may have to be installed separately.

Other configuration issues will normally be handled by the server configuration. (For Apache that's 'httpd.config'.)  Look there to make sure Perl is enabled and mod_perl is disabled.


  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Tah Zonemaster
YaBB Newcomer
*
Offline



Posts: 22
Re: Installing yabb on ubuntu 11.10
Reply #2 - Oct 28th, 2011 at 5:54pm
Post Tools
Hello JonB,
Thankyou very much for your reply.
A: I didn't modify the shebang, it should be correct
B: Dunno, I guess it isn't =/ Can you tell me where I can find the perl settings config? I couldn't find it (neither on google)
« Last Edit: Oct 28th, 2011 at 5:55pm by Tah Zonemaster »  
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,785
Location: Land of the Blazing Sun!

YaBB 2.6.0
Re: Installing yabb on ubuntu 11.10
Reply #1 - Oct 27th, 2011 at 7:28pm
Post Tools
Two things

A. Do you 'know for sure where the Perl executable is', and is that what is pointed to in your shebang lines???

B. is mod_perl enabled?  If so disable it

Good Luck
Cool
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
Tah Zonemaster
YaBB Newcomer
*
Offline



Posts: 22
Installing yabb on ubuntu 11.10
Oct 27th, 2011 at 5:19pm
Post Tools
Hey,
I'm currently running on ubuntu, but installing YaBB doesn't go as it should. Perl should be installed, but when I'm navigating to Setup.pl, firefox asks me if I want to download it. I couldn't find this on google, so any thoughts? Thanks in advance Smiley

Tah Zonemaster
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Topic Tools
 
  « Board Index ‹ Board  ^Top