Page Index Toggle Pages: 1
Topic Tools
Normal Topic Two Questions: Log In and Spell Check (Read 886 times)
sziblis
YaBB Newcomer
*
Offline



Posts: 8

YaBB 2.6.0
Two Questions: Log In and Spell Check
Nov 29th, 2011 at 2:33am
Post Tools
Okay, so I am running YaBB 2.3.1 and I have two issues that I am trying to figure out.
1) On the forum home page, where it says "Welcome Guest, Please Login or Register" - the Login link does not lead anywhere. I can see in the template that the code calls out
Code (CSS)
Select All
<td align="left" valign="middle" height="40">{yabb uname}<br />{yabb im}{yabb admin_alert}</td> 

and I am wondering where I can find the {yabb im} or {yabb admin_alert} files so I can peak at the code and see if I can figure it out?
2) My spell check has stopped working, and I am looking if anyone has any ideas of why or how I can troubleshoot/fix this. When there is a misspelled word, and I click Check Spelling I get this error code: "An error was encountered on the server. Please try again later." I recently installed StopForumSpam, could this have anything to do with it?
I appreciate any insight or resources, thank you.
  
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 4,039
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Two Questions: Log In and Spell Check
Reply #1 - Nov 29th, 2011 at 2:54am
Post Tools
A. PLEASE - one question per topic -

B. - I'll tackle your second question first (and please make a separate one for the Login question) then one of us can answer that as well.

OK - first thing we need to know - are you running YaBB on a webhost's server???

Reason -

Both 'googiespell' (I know from debugging it) and 'Stop Forum Spam' (I'm pretty sure - but Derek knows best) use 'server calls' - this is where the script running on the server make an outbound 'service' request to another server.  Some hosts don't allow that at all (SourceForge is one - so we can't run the spell checker here).  Other's have security measures to ensure these tools don't cause problems on their servers (like overloading).

Did Googiespell (yes that's its real name) 'used to work'???

Did it stop the same day (or one or two after) you installed Stop Forum Spam - if so a call, a problem ticket or an e-mail to the host is probably in order. To see if you have hit a roadblock.

If you are on your own server - then we have a different matter obviously.

Good Luck
Cool
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
sziblis
YaBB Newcomer
*
Offline



Posts: 8

YaBB 2.6.0
Re: Two Questions: Log In and Spell Check
Reply #2 - Nov 29th, 2011 at 1:25pm
Post Tools
Yes, I am running YaBB on a webshost's server... I am actually helping someone out by trying to fix this, so it's not exactly /my site/.
Yes, the Spell Check used to work, and stopped working after I installed StopForumSpam.
I think she has access to the server controls though, as in she owns all the webhost stuff. If I have access to this, is there something you recommend that I do to allow both to work?
I am also considering just removing StopForumSpam if it proves to be easier. I think that SpamFruits is honestly keeping everything out as is. Thoughts on this?
Thank you~
« Last Edit: Nov 29th, 2011 at 1:26pm by sziblis »  
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 4,039
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Two Questions: Log In and Spell Check
Reply #3 - Nov 29th, 2011 at 2:39pm
Post Tools
Its virtually impossible to 'guess at' server settings particularly if its a provisioned system - i.e one with a Control Panel or a VPS with a control panel/admin tool.

I would recommend you go with your idea of un-installing Stop Forum Spam and see what happens -

Cool
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
sziblis
YaBB Newcomer
*
Offline



Posts: 8

YaBB 2.6.0
Re: Two Questions: Log In and Spell Check
Reply #4 - Nov 29th, 2011 at 2:41pm
Post Tools
Okay, I figured that might be the case.
Thank you. C:
  
Back to top
 
IP Logged
 
sziblis
YaBB Newcomer
*
Offline



Posts: 8

YaBB 2.6.0
Re: Two Questions: Log In and Spell Check
Reply #5 - Nov 29th, 2011 at 4:06pm
Post Tools
Uninstalled StopForumSpam and the Spell Checker still does not work.
  
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 4,039
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Two Questions: Log In and Spell Check
Reply #6 - Nov 29th, 2011 at 6:38pm
Post Tools
If the spellchecker is not working you need to check the server error logs.  It could be  that you can't make SSL connections for some reason.

There will probably be errors on port 443 (SSL) for a Google server -
like this -
Unable to connect to ssl://www.google.com:443

NOTE - the spell-checker is not a YaBB component - its an Open Source tool called googiespell.

http://orangoo.com/labs/GoogieSpell/

I just checked a couple of my working forums, and googiespell is working correctly at the moment (this no errors)

The Spell checker was a 'mod' first -
There are some good debugging tips. in this thread -

http://www.boardmod.org/yabb2/YaBB.pl?num=1212737074

Good Luck
Wink




yfc
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
Page Index Toggle Pages: 1
Topic Tools