Page Index Toggle Pages: 1
Topic Tools
Normal Topic server requires all perl files to be .cgi (Read 1,131 times)
Elfen
Full Member
***
Offline



Posts: 450
Re: server requires all perl files to be .cgi
Reply #2 - Feb 25th, 2012 at 4:02am
Post Tools
Draz wrote on Feb 4th, 2012 at 12:22pm:
server requires all perl files to be .cgi

which files do I need to  change please

Let me ask the famous question... What is the server, OS and Perl version are you using?

I've have worked with YaBB since 1999 or when ever it came out on Windows 98 dell Latitude Laptop 1000 (circa 2000) and Perl 5.2.x, on a Mac clone with a G3 Accelerator card on BSD (no GUI!), and on a Mac 9500 running MacTen Unix Interlay OS and all worked without needing to change file names.

The next thing is to check all .pl Yabb files have the 755 permissions set to them and finally you are going to check your Apache (or other webserver) config file to see if CGIs are processed with CGI itself or with others... I can supply details to this later.
  
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,847
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: server requires all perl files to be .cgi
Reply #1 - Feb 4th, 2012 at 2:17pm
Post Tools
As far as I know this answer is still correct:

http://www.yabbforum.com/community/YaBB.pl?num=1239741789

Quote:
Normally only YaBB.pl, AdminIndex.pl and Setup.pl


Good Luck
Cool
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
Draz
YaBB Newcomer
*
Offline



Posts: 1
server requires all perl files to be .cgi
Feb 4th, 2012 at 12:22pm
Post Tools
server requires all perl files to be .cgi

which files do I need to  change please
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Topic Tools
 
  « Board Index ‹ Board  ^Top