YaBB Community and Support Forum
YaBB Home About YaBB Download YaBB YaBB Support Customize Your Forum Development Contribute to the Project
  Welcome, Guest. Please Login or Register


 
Pages: 1 2 3 4
Topic Tools
 
adding images (Read 6,665 times)
 Mar 25th, 2012 at 2:27pm
There are no actions to perform.  

greenparkland 
YaBB Newbie
*
Offline
Posts: 34


YaBB 2.1
adding images
Hi I have followed the instruction given on a subject for adding images, but when I get to the part that says click advanced setting then file attachment tab in the section marked:Attachment directory exists and has correct permissions? is set at yes, but not with the suggested text it suggests changing it to  ......com/forum/yabbfiles/attachments, but when I change it to this the attachment directory is then set at no, I have even tried it unchanged with the permission set at yes . yet when listing something in the forum when I hit browse button it brings up files I choose one then list the subject but when I click on the link to view is bring up a web page saying URL not found, I can get pictures by uploading to phobucket and inserting the code but others will find it hard, any ideas I need this one solved please Smiley
 
 
IP Logged  
 Reply #1 - Mar 25th, 2012 at 2:41pm
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 1,862
Earth


YaBB 2.5
Re: adding images
In 2.5 the default directory for attachments is  'path-to-your-html-directory'/yabbfiles/Attachments. This path can be changed in Paths.pl.

The prewritten path in Advanced Settings comes from that setting. Advanced Settings isn't giving you a recommendation - it's telling you what you have set up on your server.

So, if you change the path, you are probably changing to a directory that doesn't exist.

The list that comes up is from a file that lists the attachments that are supposed to be there, not from reading the directory where they're supposed to be.
« Last Edit: Mar 25th, 2012 at 2:43pm by Dandello »  
WWW  
IP Logged  
 Reply #2 - Mar 25th, 2012 at 4:05pm
There are no actions to perform.  

greenparkland 
YaBB Newbie
*
Offline
Posts: 34


YaBB 2.1
Re: adding images
Hi many thanks for your reply it just took a look at my main page and it has a small message that say wev'e up graded you to yaBB 2! not sure what that is if it is the 2.5 or not it the advice the same for this edition, many thanks
 
 
IP Logged  
 Reply #3 - Mar 25th, 2012 at 4:24pm
There are no actions to perform.  

greenparkland 
YaBB Newbie
*
Offline
Posts: 34


YaBB 2.1
Re: adding images
Dandello wrote on Mar 25th, 2012 at 2:41pm:
In 2.5 the default directory for attachments is  'path-to-your-html-directory'/yabbfiles/Attachments. This path can be changed in Paths.pl.

The prewritten path in Advanced Settings comes from that setting. Advanced Settings isn't giving you a recommendation - it's telling you what you have set up on your server.

So, if you change the path, you are probably changing to a directory that doesn't exist.

The list that comes up is from a file that lists the attachments that are supposed to be there, not from reading the directory where they're supposed to be.

Just check my cPanel and it is yaBB21 but there is no Path.pl when I look in sources gives all others .pl but not paths, would it be called anything else? many thanks
 
 
IP Logged  
 Reply #4 - Mar 25th, 2012 at 7:01pm
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 1,862
Earth


YaBB 2.5
Re: adding images
Quote:
$uploaddir = "/home/cometopo/public_html/yabb/Attachments";


That's the folder where your attachments are supposed to be uploaded to according to your Paths.pl.

You should also check and see if the folder being recommended actually exists. If that folder doesn't exist, then you may need to create it. Mind that non-Windows servers are case-sensitive. 'Attachments' is different than 'attachments'. And YaBB's attachment folder is usually 'Attachments'.

If it's still a puzzle, give a shout to JonB or Derek. Both are knowledgeable about older versions of YaBB.




« Last Edit: Mar 25th, 2012 at 7:10pm by Dandello »  
WWW  
IP Logged  
 Reply #5 - Mar 25th, 2012 at 7:39pm
There are no actions to perform.  

greenparkland 
YaBB Newbie
*
Offline
Posts: 34


YaBB 2.1
Re: adding images
many thanks will give it a try, will let you know either way
 
 
IP Logged  
 Reply #6 - Mar 25th, 2012 at 7:51pm
There are no actions to perform.  

greenparkland 
YaBB Newbie
*
Offline
Posts: 34


YaBB 2.1
Re: adding images
this is the message i get when I upload a photo then click on the link it brings up another page saying
Not Found

The requested URL /yabb/install/Attachments/P1060898__450x338__001.jpg was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.2.21 (Unix) mod_ssl/2.2.21 OpenSSL/0.9.8e-fips-rhel5 DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 mod_perl/2.0.5 Perl/v5.8.8 Server at cometoportugal.com Port 80
 
 
IP Logged  
 Reply #7 - Mar 25th, 2012 at 8:12pm
There are no actions to perform.  

Bill Myers 
God Member
Beta Testers
*****
Offline
Posts: 1,482
Los Angeles


YaBB 2.4
Re: adding images
Edited:
I'm surprised that your folder for attachments isn't as follows:

/yabbfiles/Attachments

Then again, it really doesn't matter where your attachments folder is. Wherever it is, you'll see it's path in AdminCenter.

greenparkland wrote on Mar 25th, 2012 at 7:51pm:
...
Not Found

The requested URL /yabb/install/Attachments/P1060898__450x338__001.jpg was not found on this server.

The /install/ in your path gives me pause. Surely this isn't a directory on your server, is it? This should be easy enough to check through your FTP client.
« Last Edit: Mar 25th, 2012 at 8:26pm by Bill Myers »  
Morning, noon, or night, have a great one! ...
WWW BillHMyers  
IP Logged  
 Reply #8 - Mar 25th, 2012 at 8:19pm
There are no actions to perform.  

greenparkland 
YaBB Newbie
*
Offline
Posts: 34


YaBB 2.1
Re: adding images
sorry this is new to me I am in my cPanel and just clicked FTP account and it wants be to create one
 
 
IP Logged  
 Reply #9 - Mar 25th, 2012 at 8:20pm
There are no actions to perform.  

Bill Myers 
God Member
Beta Testers
*****
Offline
Posts: 1,482
Los Angeles


YaBB 2.4
Re: adding images
greenparkland wrote on Mar 25th, 2012 at 8:19pm:
sorry this is new to me I am in my cPanel and just clicked FTP account and it wants be to create one

Then I guess you should create it. Then you'll be good to go.  Wink
Bill Myers wrote on Mar 25th, 2012 at 8:24pm:
I think I just gave you bad advice. I think the better advice is to simply create an attachments folder where you want it in a public folder, and then reference that path in your path settings.

Suggested path: /yabbfiles/Attachments
« Last Edit: Mar 25th, 2012 at 8:25pm by Bill Myers »  
Morning, noon, or night, have a great one! ...
WWW BillHMyers  
IP Logged  
 Reply #10 - Mar 25th, 2012 at 8:24pm
There are no actions to perform.  

Bill Myers 
God Member
Beta Testers
*****
Offline
Posts: 1,482
Los Angeles


YaBB 2.4
Re: adding images
I think I just gave you bad advice. I think the better advice is to simply create an attachments folder where you want it in a public folder, and then reference that path in your path settings.

Suggested path: /yabbfiles/Attachments
« Last Edit: Mar 25th, 2012 at 8:25pm by Bill Myers »  
Morning, noon, or night, have a great one! ...
WWW BillHMyers  
IP Logged  
 Reply #11 - Mar 25th, 2012 at 8:28pm
There are no actions to perform.  

greenparkland 
YaBB Newbie
*
Offline
Posts: 34


YaBB 2.1
Re: adding images
when I go into my file manager in my cPanel when I go to my file in the yaBB folder it pulls up all the files and in the path.pl the following is set

$uploaddir = "/home/cometopo/public_html/yabb/Attachments";
as soon as I change it it show in the admin centre on the Attachment directory exists and has correct permissions?  as no
if I leave it as above it shows it as yes, but when I upload a photo in the forum post it brings up another page with the message I posted earlier
 
 
IP Logged  
 Reply #12 - Mar 25th, 2012 at 8:42pm
There are no actions to perform.  

depablo 
YaBB Moderators
YaBB Next Team
Beta Testers
***
Offline
Posts: 577
UK


YaBB 2.5
Re: adding images
You got a link to your forum?
 
Taking a peek behind the mask Wink
 
IP Logged  
 Reply #13 - Mar 25th, 2012 at 8:45pm
There are no actions to perform.  

Bill Myers 
God Member
Beta Testers
*****
Offline
Posts: 1,482
Los Angeles


YaBB 2.4
Re: adding images
Okay, since /home/cometopo/public_html/yabb/Attachments is a valid path, i.e., it exists, and it has correct permissions, then any photo that is in that folder should show up just fine.

As such, after you've attached a photo, go to the folder mentioned above to see if the photo is actually there. According to your error, that photo doesn't exist; at least not in that folder.

So, is the photo you attached/uploaded showing up in that folder on your server?
 
Morning, noon, or night, have a great one! ...
WWW BillHMyers  
IP Logged  
 Reply #14 - Mar 25th, 2012 at 8:49pm
There are no actions to perform.  

Bill Myers 
God Member
Beta Testers
*****
Offline
Posts: 1,482
Los Angeles


YaBB 2.4
Re: adding images
Important: You should check your file attachments page in your Admin Center.

Click Advanced Settings.

Then click File Attachments.

Look over your settings. How's everything look there?
 
Morning, noon, or night, have a great one! ...
WWW BillHMyers  
IP Logged  
Pages: 1 2 3 4
Topic Tools
 

Get Yet another Bulletin Board at SourceForge.net. Fast, secure and Free Open Source software downloads Support This Project BoardMod - YaBB features and templates YaBB Codex - support on installation and usage YaBB Toolbar for your browser

YaBB Facebook Group Page

Vulnerability Scanner

Valid RSS Valid XHTML Valid CSS Powered by Perl
YaBB Chat and Support Community » Powered by YaBB 3.0 Beta!
YaBB Forum Software © 2000-2011. All Rights Reserved.