Page Index Toggle Pages: 1
Topic Tools
Normal Topic Harvester abuse email (Read 1,088 times)
westwegoman
Ex Member
**




YaBB 2.5.2
Harvester abuse email
Apr 23rd, 2012 at 12:58pm
Post Tools
I just noticed that the email that I receive for harvester abuse detection doesnt show a month in the message.

This is what I receive:
Harvester Abuse Detected! on  23, 2012  1:53am

Abusing user ID (Real Name): Guest -> () Abuse detected from IP: 000.000.00.000 Blocked Harvester: mozilla/4.7 (compatible; offbyone; windows 2000) webster pro v3.4


Any ideas?
« Last Edit: Apr 23rd, 2012 at 12:59pm by WestwegoMan »  
Back to top
 
IP Logged
 
Derek Barnstorm
Support Team
YaBB Next Team
Development Team
Beta Testers
****
Offline



Posts: 1,269
Location: United Kingdom

None
Re: Harvester abuse email
Reply #1 - Apr 23rd, 2012 at 2:36pm
Post Tools
Hi Merv,

This seems to fix it:

In Sources/Guardian.pl find:

Code (Perl)
Select All
$abuse_time = &timeformat($date,1,0,1); 


And change to:

Code (Perl)
Select All
$abuse_time = &timeformat($date,1,1,1); 




  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,724
Location: Los Angeles

YaBB 2.4
Re: Harvester abuse email
Reply #2 - Apr 23rd, 2012 at 3:55pm
Post Tools
Thanks Derek!  Smiley

I don't recall seeing the same error in our forum that Merv saw in his, but I presume that I would get the same error as well since our Sources/Guardian.pl file contained the following:

Derek Barnstorm wrote on Apr 23rd, 2012 at 2:36pm:
Code (Perl)
Select All
$abuse_time = &timeformat($date,1,0,1); 




But thanks to you, I made the following correction as you noted:

Derek Barnstorm wrote on Apr 23rd, 2012 at 2:36pm:
Code (Perl)
Select All
$abuse_time = &timeformat($date,1,1,1); 




For me since I read about it here, this is one of those "just in case" situations, so I really appreciate your instructions.
Smiley

  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online



Posts: 2,474
Location: Earth

YaBB 2.6.1
Re: Harvester abuse email
Reply #3 - Apr 24th, 2012 at 3:15pm
Post Tools
I haven't seen that particular error either.

Code
Select All
&timeformat($date,1,0,1); 


is sent to DateTime.pl for formatting.

Code
Select All
my ( $oldformat, $dontusetoday, $use_rfc, $forum_default ) = @_;  



Within sub timeformat use_rfc and forum_default appear to be mutually exclusive. (Actually, in this case it will simply default to use_rfc as it's checked after forum_default.)

It might be a good idea to check and make sure all the different user timeformats are working properly (I have a vague recollection that one might not be quite right but I can't recall which one.)


I'm wondering if the real issue isn't in the timeformat selected for the forum.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
westwegoman
Ex Member
**




YaBB 2.5.2
Re: Harvester abuse email
Reply #4 - Apr 25th, 2012 at 12:56am
Post Tools
I made the changes in Sources/Guardian.pl and that solved the problem.

Thanks.
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,724
Location: Los Angeles

YaBB 2.4
Re: Harvester abuse email
Reply #5 - Apr 25th, 2012 at 1:38am
Post Tools
Thanks for letting us know that it worked. That's very helpful.
  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
Page Index Toggle Pages: 1
Topic Tools