Page Index Toggle Pages: [1] 2 
Topic Tools
 10 Lost Password Email Issue (Read 2,602 times)
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,768
Location: Land of the Blazing Sun!

YaBB 2.6.0
Re: Lost Password Email Issue
Reply #19 - May 3rd, 2012 at 11:32pm
Post Tools
Good Work Billy -  Smiley

I'm going to mention (although you may already know) why that fix works.  Because you are clicking a link in the e-mail, the action is NOT taking place on the home domain of YaBB, THUS there is a 'referer' domain in the request.  If its not on the referer Domain "OK" list (checked) YaBB will spit up.

Good Luck to all
Wink
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,768
Location: Land of the Blazing Sun!

YaBB 2.6.0
Re: Lost Password Email Issue
Reply #18 - May 3rd, 2012 at 11:18pm
Post Tools
Good call, and that was what was on my brain - reminder2 and login2 can trip up the password recovery.

Glad you got it resolved...

Wink
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,550
Location: Los Angeles

YaBB 2.4
Re: Lost Password Email Issue
Reply #17 - May 3rd, 2012 at 9:12pm
Post Tools
Billy Rhythm wrote on May 3rd, 2012 at 9:02pm:
It wasn't the chmoding that fixed it; that was done yesterday before I posted. I think it was that check in the referrer security.

That makes sense. I had not thought of that, so good for you for getting to it on your own.  Smiley


Billy Rhythm wrote on May 3rd, 2012 at 9:02pm:
I've checked it now with my admin account, and another test account, and it worked on both.
Excellent!  Smiley


Billy Rhythm wrote on May 3rd, 2012 at 9:02pm:
The capha mod, though, has cleaned things up SO MUCH, I think he can relax his guard a little.

Yep! Once again, that CAPTCHA hack really does its thing. It's worked great for us. In fact, while keeping my fingers crossed, I recently stopped the admin approval for registrations. Email verification is all that it takes now, which is ideal since people can register themselves without having to wait for me to approve them.

Edited:
For YaBB's future reference, I'm hoping that developers will include mods like Spamfruits to help deal with spammers, and even the mod that requires an answer or answers to questions to register a membership.

And like SMF already does it, I'm hoping that admins can enable mods directly through YaBB's own interface. That could be part of the Admin Center, which I might add is more user friendly in YaBB than it is in SMF.

« Last Edit: May 3rd, 2012 at 9:18pm by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
Billy Rhythm
YaBB Newcomer
*
Offline



Posts: 23

None
Re: Lost Password Email Issue
Reply #16 - May 3rd, 2012 at 9:02pm
Post Tools
I've checked it now with my admin account, and another test account, and it worked on both. It wasn't the chmoding that fixed it; that was done yesterday before I posted. I think it was that check in the referrer security.

I'm not sure why the board owner has that turned on. My guess is because he had been running 2.1, and was getting KILLED with spam registrations. So he locked things down tight. The capha mod, though, has cleaned things up SO MUCH, I think he can relax his guard a little.

Thanks again for all the help everyone.
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,550
Location: Los Angeles

YaBB 2.4
Re: Lost Password Email Issue
Reply #15 - May 3rd, 2012 at 8:42pm
Post Tools
Maybe you should simply uncheck the following (Security Center => Security Settings =>):

Code
Select All
Activate Referral Security Checking?
Fine tuning you can do in Security Center => Referer Security 



I don't have it checked, and our forum has worked great since 2002.  Huh  Smiley

Edited:
Edited to add another instruction.
« Last Edit: May 3rd, 2012 at 8:44pm by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,550
Location: Los Angeles

YaBB 2.4
Re: Lost Password Email Issue
Reply #14 - May 3rd, 2012 at 8:36pm
Post Tools
Edited:
I smell success!  Smiley

Billy Rhythm wrote on May 3rd, 2012 at 8:34pm:
I THINK I GOT IT!!!

In the referrer security, reminder2 was NOT checked. I checked it, and then, when I pasted the link in the received email, it worked! I got to the "reset your password now" screen. Whew. Let me keep cracking and testing.

Billy Rhythm wrote on May 3rd, 2012 at 8:17pm:
It doesn't work either way. PM being sent.

Have you tried to recreate this error yourself with a test membership or by using your admin account to reset your password?

I guess my real question is, did the CHMOD changes solve this problem?
« Last Edit: May 3rd, 2012 at 8:38pm by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
Billy Rhythm
YaBB Newcomer
*
Offline



Posts: 23

None
Re: Lost Password Email Issue
Reply #13 - May 3rd, 2012 at 8:34pm
Post Tools
I THINK I GOT IT!!!

In the referrer security, reminder2 was NOT checked. I checked it, and then, when I pasted the link in the received email, it worked! I got to the "reset your password now" screen. Whew. Let me keep cracking and testing.
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,550
Location: Los Angeles

YaBB 2.4
Re: Lost Password Email Issue
Reply #12 - May 3rd, 2012 at 8:30pm
Post Tools
Thanks for the update.  Smiley

It suddenly dawned on me that this could have been a permissions issue.

For future reference if you haven't already done this, I've found that having at least one or more regular memberships are good to have in terms of testing what other members go through while accessing, and using your forum. That way, you can possibly recreate error messages that they may get, and also be more in tune with their experiences versus simply using your forum as an admin.

On a related note as an example, I have a few items included in my menu that are quick references for me, but which are not available or visible to regular members.

For instance, I like having a direct link to the "Error Log" rather than going into the Admin Center for it. I also have an "IP Locator" link for a quick reference. Items like that.
Enjoy your forum!  Smiley

Edited:
Edited to include the actual link for the "IP Locator" service that I normally use.
« Last Edit: May 3rd, 2012 at 8:33pm by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
Billy Rhythm
YaBB Newcomer
*
Offline



Posts: 23

None
Re: Lost Password Email Issue
Reply #11 - May 3rd, 2012 at 8:17pm
Post Tools
JonB wrote on May 3rd, 2012 at 1:31pm:
@ Billy -
OK - let me ask for a clarification???

Are you saying this error occurs ONLY when Guest Access is enabled?

Does it work correctly when Guest Access is disabled???

Please past the contents of the e-mail generated into a PM and send it to me.

Thanks
Cool


It doesn't work either way. PM being sent.
  
Back to top
 
IP Logged
 
Billy Rhythm
YaBB Newcomer
*
Offline



Posts: 23

None
Re: Lost Password Email Issue
Reply #10 - May 3rd, 2012 at 8:13pm
Post Tools
Thanks for all the help.

Bill: I checked the "lost password" email template. It looked correct. For the heck of it, I hit the "save" button, but it wouldn't save. It said I didn't have permission in the English folder to save that file. So now, Languages is chmoded 777, English is 777, and that particular file is now 666 (was 644).

My server must be one of those wacky servers you reference. I have a couple random directories that are "supposed" to be 755, but only work with 777. The files in the Members directory are all at 666.
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,550
Location: Los Angeles

YaBB 2.4
Re: Lost Password Email Issue
Reply #9 - May 3rd, 2012 at 7:06pm
Post Tools
Billy Rhythm wrote on May 3rd, 2012 at 12:46pm:
Thanks. No issue with the Goldwing. In fact, I drive a 50cc Honda Metropolitan scooter! 42 mph downhill, but 110 mpg.

Very cool! Your mpg is amazing! I try sticking with the Goldwing versus taking our Jeep because even in the city the mpg is pretty darned good at about 30-36 mpg (straight highway seems to be about 48-52 mpg). Luckily, my wife enjoys the ride, too.

Edited:
I just saw that scooter a couple of days ago at the Honda dealership when I had new tires installed, and gave my bike an oil change. The funny thing is that I couldn't figure out where the gas cap was; not for the longest time. But as you know, it's straight down from the seat in front. Duh!


Billy Rhythm wrote on May 3rd, 2012 at 12:46pm:
Bill, I just re-read your post. I think I may not have been clear. It's not the "forgot password" link that's broken. It's the link that's sent in the email that gets mailed.

Thanks for the clarification.

Okay then. The immediate thing to try is to click your "Forgot password" link for yourself or a regular test account you use (preferably the latter), and follow through with it when you get your email.

So then, click the appropriate link, and see if that error is occurring, which I presume will come up. If that's the case, then the source of your problem is simple, and it can be corrected easily enough.

When I say, "easily enough," I don't mean easy for a computer illiterate like me, but for someone like JobB or Dandello who actually have the smarts to know how to fix this.

If I was the one with this problem, the first place I'd look would be in the Admin Center for the actual message that goes out, which for our site using YaBB 2.4 looks like the following:

Code
Select All
Dear {yabb displayname},

This reminder was requested by a visitor at {yabb mbname}. If you did not submit a request to reset your password, then please ignore this Email.

Otherwise, go here to reset your password: {yabb scripturl}?action=resetpass&ID={yabb remindercode}&user={yabb cryptusername}

Regards,
The {yabb mbname} team 



My thinking is that something there might be amiss. Then again, I'm just guessing here. If someone else here figures this out for you, please let us know so that others can benefit from what the answer to this problem really is.

Thanks, and good luck!

P.S.If this error doesn't occur for you personally, then I suppose it's possible that the *.vars file for the member getting the error could be corrupted in some way. But maybe it's a simple matter of reassigning its permissions.

If you check, those permissions are probaly set at 644 because that's kind of the default setting for many servers (evidently our own server does this). CHMOD 644 should work, but ...

YaBB's instructions actually tell you to set all of the membership files to 666 (the folder should be 755, although on some servers it needs to be 777).

I've had a few problematic membership files that were "fixed" when I reset them from 644 to 666. In other words, those members would get a similar error message when trying to modify their own profiles.

In any case, duh, what I finally did was to simply follow YaBB's instructions, at which point I changed permissions for all membership files from 644 to 666.

So far, so good.  Smiley
« Last Edit: May 3rd, 2012 at 7:15pm by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,768
Location: Land of the Blazing Sun!

YaBB 2.6.0
Re: Lost Password Email Issue
Reply #8 - May 3rd, 2012 at 1:31pm
Post Tools
@ Billy -
OK - let me ask for a clarification???

Are you saying this error occurs ONLY when Guest Access is enabled?

Does it work correctly when Guest Access is disabled???

Please past the contents of the e-mail generated into a PM and send it to me.

Thanks
Cool
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
Billy Rhythm
YaBB Newcomer
*
Offline



Posts: 23

None
Re: Lost Password Email Issue
Reply #7 - May 3rd, 2012 at 12:49pm
Post Tools
Bill, I just re-read your post. I think I may not have been clear. It's not the "forgot password" link that's broken. It's the link that's sent in the email that gets mailed. When you click that link it gets all keflunkered. And it does the same thing whether you click the link in the email, or if you copy and paste the link. You end up at either the "you cant get to this section" info, or you just get brought to the log-in screen again.
  
Back to top
 
IP Logged
 
Billy Rhythm
YaBB Newcomer
*
Offline



Posts: 23

None
Re: Lost Password Email Issue
Reply #6 - May 3rd, 2012 at 12:46pm
Post Tools
Thanks. No issue with the Goldwing. In fact, I drive a 50cc Honda Metropolitan scooter! 42 mph downhill, but 110 mpg.

I'm now sitting at a different machine, and I still get the "you are not allowed in the section" error. And yet you were able to get in? Hmm... I wonder if the office proxy server is causing an issue. Still, the guy who reported the problem is on a different network.
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,550
Location: Los Angeles

YaBB 2.4
Re: Lost Password Email Issue
Reply #5 - May 2nd, 2012 at 9:59pm
Post Tools
Yeah, isn't that XXcaptchaXX mod great?  Smiley

Regarding the newest error message you've gotten, I think that may be a cache issue of some kind that is probably temporary. You can probably test it with another browser.

I just tried your Forgot password? link, and I didn't get an error (at least from within your domain).

But if you click on that link from here, you'll probably see the following:

Code
Select All
System Information

This action is not allowed from an outside domain!!
Action is: reminder
Your Domain: www.eurobikemaine.org
Referer Domain: www.yabbforum.com 


In any case, I think you're good to go now.  Smiley

Edited:
By the way (per your message here), you can hide your email address like I've done with mine here if you're worried about spammers trolling for it. People can always right-click the email link to use the Copy Email Address function of the menu of one's mouse (in Firefox). Internet Explorer comes up with the Copy shortcut command.
Oh, and I hope you don't mind that I'm a Honda Goldwing rider.   Smiley
« Last Edit: May 2nd, 2012 at 10:32pm by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
Page Index Toggle Pages: [1] 2 
Topic Tools
 
  « Board Index ‹ Board  ^Top