Page Index Toggle Pages: 1 [2] 
Topic Tools
Hot Topic (More than 10 Replies) Lost Password Email Issue (Read 2,769 times)
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,684
Location: Los Angeles

YaBB 2.5
Re: Lost Password Email Issue
Reply #15 - May 3rd, 2012 at 8:42pm
Post Tools
Maybe you should simply uncheck the following (Security Center => Security Settings =>):

Code
Select All
Activate Referral Security Checking?
Fine tuning you can do in Security Center => Referer Security 



I don't have it checked, and our forum has worked great since 2002.  Huh  Smiley

Edited:
Edited to add another instruction.
« Last Edit: May 3rd, 2012 at 8:44pm by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
Billy Rhythm
YaBB Newcomer
*
Offline



Posts: 23

None
Re: Lost Password Email Issue
Reply #16 - May 3rd, 2012 at 9:02pm
Post Tools
I've checked it now with my admin account, and another test account, and it worked on both. It wasn't the chmoding that fixed it; that was done yesterday before I posted. I think it was that check in the referrer security.

I'm not sure why the board owner has that turned on. My guess is because he had been running 2.1, and was getting KILLED with spam registrations. So he locked things down tight. The capha mod, though, has cleaned things up SO MUCH, I think he can relax his guard a little.

Thanks again for all the help everyone.
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,684
Location: Los Angeles

YaBB 2.5
Re: Lost Password Email Issue
Reply #17 - May 3rd, 2012 at 9:12pm
Post Tools
Billy Rhythm wrote on May 3rd, 2012 at 9:02pm:
It wasn't the chmoding that fixed it; that was done yesterday before I posted. I think it was that check in the referrer security.

That makes sense. I had not thought of that, so good for you for getting to it on your own.  Smiley


Billy Rhythm wrote on May 3rd, 2012 at 9:02pm:
I've checked it now with my admin account, and another test account, and it worked on both.
Excellent!  Smiley


Billy Rhythm wrote on May 3rd, 2012 at 9:02pm:
The capha mod, though, has cleaned things up SO MUCH, I think he can relax his guard a little.

Yep! Once again, that CAPTCHA hack really does its thing. It's worked great for us. In fact, while keeping my fingers crossed, I recently stopped the admin approval for registrations. Email verification is all that it takes now, which is ideal since people can register themselves without having to wait for me to approve them.

Edited:
For YaBB's future reference, I'm hoping that developers will include mods like Spamfruits to help deal with spammers, and even the mod that requires an answer or answers to questions to register a membership.

And like SMF already does it, I'm hoping that admins can enable mods directly through YaBB's own interface. That could be part of the Admin Center, which I might add is more user friendly in YaBB than it is in SMF.

« Last Edit: May 3rd, 2012 at 9:18pm by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,918
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Lost Password Email Issue
Reply #18 - May 3rd, 2012 at 11:18pm
Post Tools
Good call, and that was what was on my brain - reminder2 and login2 can trip up the password recovery.

Glad you got it resolved...

Wink
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,918
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Lost Password Email Issue
Reply #19 - May 3rd, 2012 at 11:32pm
Post Tools
Good Work Billy -  Smiley

I'm going to mention (although you may already know) why that fix works.  Because you are clicking a link in the e-mail, the action is NOT taking place on the home domain of YaBB, THUS there is a 'referer' domain in the request.  If its not on the referer Domain "OK" list (checked) YaBB will spit up.

Good Luck to all
Wink
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
Page Index Toggle Pages: 1 [2] 
Topic Tools
 
  « Board Index ‹ Board  ^Top