Page Index Toggle Pages: 1
Topic Tools
Normal Topic Can't save changes in advanced settings (Read 1,546 times)
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,785
Location: Land of the Blazing Sun!

YaBB 2.6.0
Re: Can't save changes in advanced settings
Reply #8 - Jun 11th, 2012 at 3:53pm
Post Tools
@ hhhaogie2

If you would PM me the URL of your forum, and both a YaBB admin login and FTP URL user/pw login (or Control Panel login) I will look at the issue for you when I get a chance later today or this evening. (obviously no charge/free at this point.)

Good Luck
Cool
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,562
Location: Los Angeles

YaBB 2.4
Re: Can't save changes in advanced settings
Reply #7 - Jun 11th, 2012 at 3:52pm
Post Tools
Oh! I just thought of another option that's worked for me ... I don't know why.

I've sometimes gotten the same error message as you while using my regular FTP program (Ipswitch WS_FTP 12). But then I use my WinSCP program without a problem.

I use both of those programs regularly, and prefer each for different reasons.

I guess it should be noted that my access with the Ipswitch WS_FTP 12 program is done as a regular user while my use of the WinSCP program is done with root access, the latter of which I'm guessing is giving me full permission.

So maybe this isn't YaBB related (question to myself)? I've always wondered about this.
  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,562
Location: Los Angeles

YaBB 2.4
Re: Can't save changes in advanced settings
Reply #6 - Jun 11th, 2012 at 3:45pm
Post Tools
Also, you can try to temporarily CHMOD to 777 so that there's a better chance of it working. I've had to do this with other forums that weren't on our server when 755 would have otherwise worked.

If that works, CHMOD them back to 755 (I think for reasons of security although I suppose this might not matter in a cgi-bin directory).

Good luck!
  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,169
Location: Earth

YaBB 2.6.0
Re: Can't save changes in advanced settings
Reply #5 - Jun 11th, 2012 at 3:39pm
Post Tools
ARG, this blasted thing ate my message.

Re-upload to Admin virgin copies of BOTH Settings_Advanced.pl AND NewSettings.pl .

Then, if it's still bad and the need is desperate (and you're brave) back up Settings.pl for safekeeping then hand edit Settings.pl for your new settings. (Advanced Settings is down around line 300.)

This will at least buy you time while you look at the most recently added mods - I'd be looking at mods since some of them do require edits to various language files, Settings_Advanced.pl AND NewSettings.pl. (NewSettings.pl is the one that actually writes to Settings.pl and should trigger the return to AdminIndex.pl via a &redirectexit call to Subs.pl. But if the return info being sent to the redirectexit sub is bad in Settings_Advanced.pl, that will do it too.)

« Last Edit: Jun 11th, 2012 at 3:45pm by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
hhhoagie2
YaBB Newcomer
*
Offline



Posts: 3

None
Re: Can't save changes in advanced settings
Reply #4 - Jun 11th, 2012 at 2:50pm
Post Tools
Thanks for the advice but changing settings.pl to 755 didn't work.
I need to get this fixed...I have settings there that need to be changed. 
Thanks, Bob
  

YaBB 2.5AE
Linux
Apache 2.2.22
PHP 5.3.13, Perl 5.8.8
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,785
Location: Land of the Blazing Sun!

YaBB 2.6.0
Re: Can't save changes in advanced settings
Reply #3 - Jun 11th, 2012 at 2:21pm
Post Tools
make the permission 755.

Good Luck
Wink
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
hhhoagie2
YaBB Newcomer
*
Offline



Posts: 3

None
Re: Can't save changes in advanced settings
Reply #2 - Jun 11th, 2012 at 5:25am
Post Tools
I had settings.pl 644 and changed that to 666.  That was the only setting that was wrong.  I still have the problem
  

YaBB 2.5AE
Linux
Apache 2.2.22
PHP 5.3.13, Perl 5.8.8
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,169
Location: Earth

YaBB 2.6.0
Re: Can't save changes in advanced settings
Reply #1 - Jun 10th, 2012 at 3:35pm
Post Tools
Which version of YaBB are you running and what OS is on the server? (There's a place in your profile info here to put your YaBB version.)

When you look at Admin->Detailed Version Check, do all the files belong to the proper version of YaBB?

Have you checked the permissions on Settings_Advanced.pl? On some servers it may need to be set to 666 or even 755. Also check the permissions on the directory 'Variables'. Again, the non-.pl files might need to be set to 666 and Settings.pl set to 666 or 755.

Have you added any mods that should show up in Advanced Settings?

All the error message is saying is that, for some reason, a script (probably in Settings_Advanced.pl) is trying to go back to AdminIndex.pl on a return loop and doing it wrong. (We know the problem isn't really with AdminIndex.pl because you can get into the admin section.) The second error is that you don't have a 403 error page on your server.

« Last Edit: Jun 10th, 2012 at 3:42pm by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
HHHoagie
Junior Member
**
Offline



Posts: 97
Can't save changes in advanced settings
Jun 10th, 2012 at 5:02am
Post Tools
Forbidden
You don't have permission to access /cgi-bin/webboard/AdminIndex.pl on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
This is the error I get when trying to make a change in advanced settings. I can make other settings though.
Any help would be appreciated, Bob
  

YaBB v 2.5AE
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Topic Tools
 
  « Board Index ‹ Board  ^Top