Page Index Toggle Pages: 1 2 [3] 4 5 6
Topic Tools
Very Hot Topic (More than 25 Replies) Upgraded from 2.4 to 2.5 and now broken (Read 22,075 times)
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 4,031
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Upgraded from 2.4 to 2.5 and now broken
Reply #30 - Jun 12th, 2012 at 1:32pm
Post Tools
Are you using ActiveStates Perl? 

If so, what version and are you using it (Perl) as PerlISAPI or with a shebang line?

Otherwise - what Perl are you using???

Thanks
Smiley

  

I find your lack of faith disturbing.
Back to top
IP Logged
 
sausagenet
YaBB Newcomer
*
Offline



Posts: 25

None
Re: Upgraded from 2.4 to 2.5 and now broken
Reply #31 - Jun 12th, 2012 at 4:06pm
Post Tools
C:\Perl\bin>perl -v

This is perl, v5.10.0 built for MSWin32-x86-multi-thread
(with 5 registered patches, see perl -V for more detail)

Copyright 1987-2007, Larry Wall

Binary build 1004 [287188] provided by ActiveState http://www.ActiveState.com
Built Sep  3 2008 13:16:37


  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,732
Location: Los Angeles

YaBB 2.4
Re: Upgraded from 2.4 to 2.5 and now broken
Reply #32 - Jun 12th, 2012 at 4:21pm
Post Tools
sausagenet wrote on Jun 12th, 2012 at 12:51pm:
I'll going to follow the instruction mentioned above and see where I get,

cheers!

Considering the alternatives here, including my lack of any real knowledge about using a Windows server, I think your best course of action might be to again try a brand new install.

I admire your persistence.  Smiley

By the way, I have the same problem as you do, but on a UNIX server. Like you, I've followed YaBB's instructions to the letter, and I still have the same related problem that you have.

I'm beginning to think that both you and I may have installed a corrupted download of YaBB. I'm just reaching, but that is a possibility.

Maybe someone here with "actual substantial knowledge" can download YaBB's current YaBB 2.5 and do what will be for them a quick install to see if something's gotten corrupted.

Edited:
I'm not abandoning you, but since I don't have substantial knowledge about this subject, I'm going to step back so that you can concentrate on getting the expert help that you're seeking.

Good luck! I'm very curious about how this gets resolved.


***************************************

JonB wrote on Jun 12th, 2012 at 12:49pm:
If you do not have actual substantial knowledge to contribute to a support problem, kindly refrain from confusing the issue.


Wink



Ironically, if you look at my track record of helping people here in this forum, I seem to be able to help them even when people with knowledge about a subject aren't able to provide a solution. Go figure. I think it has to do more with trying than actually knowing what to do.

Also, I think it helps to have a fresh set of eyes on a problem from a regular user versus an expert who often can't see the forest because of the trees. I know that it's not uncommon for an expert to clue in on a solution after they've read through help that I've tried to give.

It's like, "No, no, no, Bill. That's not the way to do it. This is the way to do it." Wink

How someone helps shouldn't matter if that help provides a solution to any given problem, or it leads to a solution. So far, even a qualified expert like you can't seem to figure out what the real problem is. So neither one of us is helping much here; at least not yet.

So how are we different here? Wink

If it makes you feel any better, my money's on you since you actually have substantial knowledge, and as I've already qualified the help I've been trying to give, I do not.

In any case, give a guy a break for trying to help. You're seriously complaining about that? Roll Eyes
« Last Edit: Jun 12th, 2012 at 4:24pm by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 4,031
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Upgraded from 2.4 to 2.5 and now broken
Reply #33 - Jun 12th, 2012 at 6:21pm
Post Tools
In IIS Manager, Web Service Extensions -

Do you have entries like in this screenshot -

Smiley
  

IIS_WebServices.PNG ( 39 KB | 62 Downloads )
IIS_WebServices.PNG

I find your lack of faith disturbing.
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,484
Location: Earth

YaBB 2.6.1
Re: Upgraded from 2.4 to 2.5 and now broken
Reply #34 - Jun 12th, 2012 at 6:36pm
Post Tools
Since it was asked - I have a zipped copy of 2.5AE dated 6/21/11 (1635 kb zipped) and just now unzipped it, FTPed the files and directories to my Linux test site into cgi-bin/yabber, set the permissions on YaBB.pl, AdminIndex.pl and Setup.pl to 755, everything else is 644.

No problems. The hosting service is Knownhost.
Perl 5.8.8, Apache 2.2.16, unspecified Linux version.

The known issues with YaBB and Perl 5.10 are non-fatal warnings concerning some out-dated syntax. These warnings should not effect the install.

So, if you think you need a verified-as-good zipped file of 2.5AE, I have one.

Unfortunately, I don't have a 2.4 forum to transfer member or message files from to check if there's a complicating issue there.

And yes, I know this is not a Win server solution.  Wink
« Last Edit: Jun 12th, 2012 at 6:38pm by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 4,031
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Upgraded from 2.4 to 2.5 and now broken
Reply #35 - Jun 12th, 2012 at 6:52pm
Post Tools
Here's what a live YaBB looks like on IIS

Note you could use cgi-bin or cgi_bin for the folder name, on IIS it doesn't matter.

Smiley
  

LiveIISYaBB_folders.jpg ( 98 KB | 65 Downloads )
LiveIISYaBB_folders.jpg

I find your lack of faith disturbing.
Back to top
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 4,031
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Upgraded from 2.4 to 2.5 and now broken
Reply #36 - Jun 12th, 2012 at 7:08pm
Post Tools
Set Paths.pl to writable using IIS manager

  

Paths_pl.jpg ( 128 KB | 64 Downloads )
Paths_pl.jpg

I find your lack of faith disturbing.
Back to top
IP Logged
 
sausagenet
YaBB Newcomer
*
Offline



Posts: 25

None
Re: Upgraded from 2.4 to 2.5 and now broken
Reply #37 - Jun 12th, 2012 at 9:15pm
Post Tools
Okay, I have made some progress.

I have a completely fresh install of Yabb 2.5AE up and running.  The key to the whole thing was windows rights in the cgi directory (nothing to do with IIS rights)

Before I go any further, just a couple of questions.   This is a totally *new* 2.5 install in a different directory to the 2.4, yet the graphic shows 2.4, and the graphics on the gray background look a mess.  I want to make sure these problems are in fact an inherent problem with the 2.5 release rather than something else?

Getting there Smiley

cheers!
--ian
  
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 4,031
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Upgraded from 2.4 to 2.5 and now broken
Reply #38 - Jun 12th, 2012 at 9:36pm
Post Tools
I'm glad you are making progress.  Wink

If the URL of the new installation is the same as the old one:  you might want to flush your browser cache (the objects will have the same names)

Wink
« Last Edit: Jun 12th, 2012 at 9:38pm by JonB »  

I find your lack of faith disturbing.
Back to top
IP Logged
 
sausagenet
YaBB Newcomer
*
Offline



Posts: 25

None
Re: Upgraded from 2.4 to 2.5 and now broken
Reply #39 - Jun 12th, 2012 at 9:56pm
Post Tools
JonB wrote on Jun 12th, 2012 at 9:36pm:
If the URL of the new installation is the same as the old one:  you might want to flush your browser cache (the objects will have the same names)

Wink


Doh!.  I'm embarrassed now  Lips Sealed
Anyway - it's still *nasty* even when it's right;-)

I'm off to try the members/messages now... but I have a nasty feeling I might run into problems.  I have a vague recollection of using boardmod for stuff like "add more smilies" which I guess aren't gonna be there.

Let's see what happens.
cheers!
--ian
  
Back to top
 
IP Logged
 
sausagenet
YaBB Newcomer
*
Offline



Posts: 25

None
Re: Upgraded from 2.4 to 2.5 and now broken
Reply #40 - Jun 12th, 2012 at 10:03pm
Post Tools
Actually, I was just thinking... can I have the beta of Yabb Next Edition and I can run that?  Look smuch nicer and you'll get a production forum with live feedback?  My forum is 9 years old, and has 100s of 1000s of message, and 1000s of legacy users, but less than 100 actives now - I'm sure they wouldn't mind Smiley
  
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 4,031
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Upgraded from 2.4 to 2.5 and now broken
Reply #41 - Jun 13th, 2012 at 12:58am
Post Tools
AFAIK - In most cases, smilies just need to be copied over.

I will have to look, I may have a YaBB 2.4 blue template for YaBB 2.5 (not 'here' but on a remote server)

Good Luck
Cool

Edited:
I'll be sending you a PM after I get it on paper
« Last Edit: Jun 13th, 2012 at 1:02am by JonB »  

I find your lack of faith disturbing.
Back to top
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,732
Location: Los Angeles

YaBB 2.4
Re: Upgraded from 2.4 to 2.5 and now broken
Reply #42 - Jun 13th, 2012 at 1:17am
Post Tools
sausagenet wrote on Jun 12th, 2012 at 9:15pm:
Okay, I have made some progress.

...

I have a completely fresh install of Yabb 2.5AE up and running.  The key to the whole thing was windows rights in the cgi directory (nothing to do with IIS rights)

...

Getting there Smiley

cheers!
--ian

Excellent! Smiley

***************************************

Dandello wrote on Jun 12th, 2012 at 6:36pm:
Since it was asked - I have a zipped copy of 2.5AE dated 6/21/11 (1635 kb zipped) and just now unzipped it, FTPed the files and directories to my Linux test site into cgi-bin/yabber, set the permissions on YaBB.pl, AdminIndex.pl and Setup.pl to 755, everything else is 644.

No problems. The hosting service is Knownhost.
Perl 5.8.8, Apache 2.2.16, unspecified Linux version.

...


Thank you so much to going to the trouble to verify that the installation package works perfectly fine.
You've inspired me to give it another try.  Smiley

But not today ... had a really long one, and I'm having a hard time staying awake.

I'm very pleased that Ian's installation issues seem to pretty much be behind him. He seems to have figured out what was going on all on his own. Excellent!

So for anyone else who may have the same issues, "The key to the whole thing was windows rights in the cgi directory (nothing to do with IIS rights)."

This is actually very helpful for me as well even though I'm on a UNIX machine. Thanks Ian! Smiley

More clues to ponder while I get a good night's sleep.  Wink
  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
sausagenet
YaBB Newcomer
*
Offline



Posts: 25

None
Re: Upgraded from 2.4 to 2.5 and now broken
Reply #43 - Jun 13th, 2012 at 4:13pm
Post Tools
So I have everything restored as per the instructions and have hit a new problem.

On the page http://www.sausagenet.org/AdminIndex.pl?action=rebuildmesindex I am supposed to "rebuild the message index"

The click here links back to the same page, but with rebuild=1 at the end of the URL...

http://www.sausagenet.org/AdminIndex.pl?action=rebuildmesindex;rebuild=1

This link returns "page not found"

So I cannot rebuild the message index.

Any ideas?
cheeers!
--ian
  
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 4,031
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Upgraded from 2.4 to 2.5 and now broken
Reply #44 - Jun 13th, 2012 at 4:20pm
Post Tools
2 Questions:

Did you test posting before you brought over the data?

Can you post in the converted forum?

Thanks
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
Page Index Toggle Pages: 1 2 [3] 4 5 6
Topic Tools