Page Index Toggle Pages: 1
Topic Tools
Normal Topic message corrupted or lost? (Read 788 times)
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,785
Location: Land of the Blazing Sun!

YaBB 2.6.0
Re: message corrupted or lost?
Reply #2 - Jul 9th, 2012 at 1:31pm
Post Tools
To amplify on what Dandello has posted - what has happened is that the Topic chain is broken.

You should look in ./Messages for the xxx.txt file and its Topic thread management companion. xxx.ctb.

It would be better to view these files with a programmers editor, but wordpad or notepad will also work.

xxx.txt will contain the topic posts for the thread, one post/reply per line.  So if there are 4 posts, 4 lines in the .txt file. You can look at any other thread (nnnnnn.txt file) and see what should be in there.

xxx.ctb is what amounts to a status management file.  It keeps track of the last post/poster/post date, topic status (locked,sticky) # views, etc.

IF the .txt file is missing, you can restore it and the matching .ctb file from a backup. All the information needed for a complete topic thread is in those two files. Then rebuild the messages and counts.

It may be that the .txt file is corrupt and you have a matching .ctb file. In that case you should be able to delete the corrupt part, rebuild messsages, and you may have your post back. 

You will see its quite fixable, provided you have a backup.

A. - .txt file example --
Code
Select All
Welcome to your new YaBB 2.5 Anniversary Edition f|YaBB Administrator|webmaster@yoursite.com|1278201900|admin|xx|0|127.0.0.1|[size=12][b] Welcome to the first post on your new YaBB 2.5 Anniversary Edition forum. ;D[/b][/size]<br /><br />The YaBB team would like to greatly thank you for choosing Yet another Bulletin Board for your forum needs. We pride ourselves on the cost (FREE), the features, and the security. And now, with YaBB 2, the speed! Visit [url]http://www.yabbforum.com[/url] to view the latest development information, read YaBB news, and participate in community discussions.<br /><br />Make sure you login as an administrator and visit the Admin Center. From there, you can maintain your forum. You'll want to look at all of the settings, membergroups, categories/boards, and security options to make sure they are set properly according to your needs.<br /><br />||1341839032|admin|
Re: Welcome to your new YaBB 2.5 Anniversary Edition f|YaBB Adminy Guy|j_panadero@yahoo.com|1341839081|admin|xx|0|127.0.0.1|This is a test post for 'chaining'<br /><br /> 8-)||||CPAN_test.txt
Re: Welcome to your new YaBB 2.5 Anniversary Edition f|Testy|jonbfl@opera.com|1341839244|TestGuy|xx|0|127.0.0.1|I am so glad to be here!<br /><br /> [smiley=2vrolijk_08.gif]|||| 




B. - .ctb file example --
Code
Select All
### ThreadID: 1278201900, LastModified: Mon, 09 Jul 2012 09:09:39 -0500 ###

'board',"general"
'replies',"2"
'views',"7"
'lastposter',"TestGuy"
'lastpostdate',"1341839244"
'threadstatus',"0sl"
'repliers',"1341839369|admin|0"
 



In the Thread Status the 0sl  means (AFAIK) not hidden, locked, sticky...

Good Luck
Cool
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,165
Location: Earth

YaBB 2.6.0
Re: message corrupted or lost?
Reply #1 - Jul 8th, 2012 at 3:03pm
Post Tools
One - and hopefully only one - message has gone missing or gotten corrupted. Re-create that one (hopefully from a backup) and you should be okay. YaBB was kind enough to tell you which one. Wink
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Jimboat
YaBB Newcomer
*
Offline



Posts: 38

YaBB 2.5.2
message corrupted or lost?
Jul 8th, 2012 at 1:42pm
Post Tools
Yabb2.4 - somehow a thread or message has been lost or corrupted. 

when i select an existing board, i can't get the thread listing to show.  i only get a message "Unable to open ./Messages/xx.txt
Verbose: No such file or directory". 

if i select an individual thread or an individual post in a thread it shows ok.

is there a specific message text that is gone? or missing? 

a "Rebuild Message Index" fails.

is there a repair that i can do to get the thread index to show properly. 

/jimboat
  

/Jim
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Topic Tools
 
  « Board Index ‹ Board  ^Top