Page Index Toggle Pages: [1] 2 3 4
Topic Tools
Locked Topic Missing files on upload (Read 10,474 times)
Ludek
YaBB Newcomer
*
Offline



Posts: 19
Missing files on upload
Jul 12th, 2012 at 8:37pm
There are no actions to perform.
Hello All,

I've had an account with a particularly c****y web host for a few years now (too lazy to change I'm afraid). This year they offered me what sounded like a much better deal so like a (lazy) mug I signed up again.

What I didn't realise is that as part of the deal my old Yabb install and web site required deletion and I've now got to upload everything to a completely new server.

No great problems except that they've now decided as part of my new deal that I'm not allowed to change permissions myself and every request has to go through their support.

When I uploaded the latest Yabb and requested the permission changes they emailed back to say certain files were missing. They were:

chmod: cannot access `cgi-bin/yabb2/Modules/Digest/Perl': No such file or directory
chmod: cannot access `cgi-bin/yabb2/Modules/Digest/Perl/MD5.pm': No such file or directory
chmod: cannot access `cgi-bin/yabb2/Modules/Time': No such file or directory
chmod: cannot access `cgi-bin/yabb2/Modules/Time/HiRes.pm': No such file or directory
chmod: cannot access `cgi-bin/yabb2/Modules/Upload': No such file or directory
chmod: cannot access `cgi-bin/yabb2/Modules/Upload/CGI.pm': No such file or directory
chmod: cannot access `cgi-bin/yabb2/Modules/Upload/CGI': No such file or directory
chmod: cannot access `cgi-bin/yabb2/Modules/Upload/CGI/Util.pm': No such file or directory

I had a look around the forum and my understanding is that if I can get the site up then I can go into 'Admin' and use a tool to identify and install these. Is this correct?

If not is there an easy way I can supply these files to the web host so I can finally get my new Yabb install working.

Many thanks for any help you can offer.

Ludek  Smiley
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,591
Location: UK:Scotland/livingston

None
Re: Missing files on upload
Reply #1 - Jul 12th, 2012 at 9:33pm
There are no actions to perform.
Hi
Ludek

all the files you listed can be found in the yabb forum download here http://www.yabbforum.com/downloads.php for 2.5 or older here http://www.yabbforum.com/archives.php?currentpage=1

hope this helps you  Smiley
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online



Posts: 2,377
Location: Earth

YaBB 2.6.1
Re: Missing files on upload
Reply #2 - Jul 12th, 2012 at 10:41pm
There are no actions to perform.
And just to clarify - those files have to be uploaded through FTP or a file manager - not through YaBB's admin center. (And considering the trouble you're going through, I would run to a new hosting service. If they don't think you're competent to handle basic file permissions, how soon before they decide you're not competent to have Perl programs running at all?)
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,591
Location: UK:Scotland/livingston

None
Re: Missing files on upload
Reply #3 - Jul 12th, 2012 at 10:52pm
There are no actions to perform.
Hi
Ludek

sorry i just seen that you have

Ludek wrote on Jul 12th, 2012 at 8:37pm:
chmod: cannot access `cgi-bin/yabb2/Modules/Time': No such file or directorychmod: cannot access `cgi-bin/yabb2/Modules/Time/HiRes.pm': No such file or directorychmod: cannot access `cgi-bin/yabb2/Modules/Upload': No such file or directorychmod: cannot access `cgi-bin/yabb2/Modules/Upload/CGI.pm': No such file or directorychmod: cannot access `cgi-bin/yabb2/Modules/Upload/CGI': No such file or directorychmod: cannot access `cgi-bin/yabb2/Modules/Upload/CGI/Util.pm': No such file or directory


this is not part of yabb but Perl Modules for this see here http://www.yabbforum.com/codex/?num=1225217016
and as

Dandello wrote on Jul 12th, 2012 at 10:41pm:
And just to clarify - those files have to be uploaded through FTP or a file manager - not through YaBB's admin center. (And considering the trouble you're going through, I would run to a new hosting service. If they don't think you're competent to handle basic file permissions, how soon before they decide you're not competent to have Perl programs running at all?)



and also as Dandello pointed out its time to get a new host out of interest who is your host?
« Last Edit: Jul 12th, 2012 at 10:53pm by xnoddyx »  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Ludek
YaBB Newcomer
*
Offline



Posts: 19
Re: Missing files on upload
Reply #4 - Jul 12th, 2012 at 11:02pm
There are no actions to perform.
Hi All and thanks for the prompt replies,  Smiley

Let me tell you what I've done so far...

I downloaded Yabb 2.5 AE (I've just done it again to check) and for example there's no Time folder in Modules (and the rest don't exist either). I've checked that I've got the show hidden files option on. Am I missing something basic here?

Thanks again,

Ludek  Cool

PS I know my host sucks, the annoying thing is this nonsense with the permissions is new - I did it quite happily with the last install.  Sad
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,591
Location: UK:Scotland/livingston

None
Re: Missing files on upload
Reply #5 - Jul 12th, 2012 at 11:27pm
There are no actions to perform.
Hi
Ludek

Modules/Time
Modules/Time/HiRes.pm
Modules/Upload
Modules/Upload/CGI.pm
Modules/Upload/CGI
Modules/Upload/CGI/Util.pm

as in my last post thes are not part of yabb but part of the installed Perl Modules on the server
your shebang path to perl will look like this /usr/bin/perl line 1 of YaBB.pl and the parts in the list in this post
are meant to be in i think /usr/bin/lib/ but your host dont have thes Modules on the server so YaBB then checks /yabb2/Modules/ from what i can remember so you can ask your host to install them but i dont think they will  Roll Eyes or you can try the info here http://www.yabbforum.com/codex/?num=1225217016 to install them in /yabb2/Modules/  Cool
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Ludek
YaBB Newcomer
*
Offline



Posts: 19
Re: Missing files on upload
Reply #6 - Jul 12th, 2012 at 11:37pm
There are no actions to perform.
Hi,

No, I have asked my host if they can install the missing files themselves but apparently (and not surprisingly) they don't do things like that!

I've got to log off now for a while - I'll reply around this time tomorrow.

Thanks again,

Ludek  Cool
  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online



Posts: 2,377
Location: Earth

YaBB 2.6.1
Re: Missing files on upload
Reply #7 - Jul 13th, 2012 at 12:18am
There are no actions to perform.
As xnoddyx has correctly pointed out: the ones you've listed are Perl Modules that should already be installed as part of a standard Perl/server package. These files should already exist and be ready for use - but not in the Modules subdirectory. They belong to the host server

I think you indicated you can get into the Admin center - the Admin Center main screen lists the required Perl modules and indicates if YaBB can find them.

However, if any of these are not where your current installation of YaBB can find them, the fact that your host used to allow access to them and has now removed that access means they have no interest in allowing you to run basic Perl scripts. (The CGI.pm module is the backbone of many, if not most, Perl form utilities.) Removing that standard module means they are not supporting Perl. period.

Just out of curiosity, why did tech support think these files were  supposed to be in yabb2/Modules/?
« Last Edit: Jul 13th, 2012 at 12:27am by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Ludek
YaBB Newcomer
*
Offline



Posts: 19
Re: Missing files on upload
Reply #8 - Jul 13th, 2012 at 8:42pm
There are no actions to perform.
Hello and thanks for the helpful response,

I think they think they should be in Yabb because I sent them the list of permissions to change which includes all of the necessary files/folders and of course they could not find them.

The comment on the Admin page was my understanding also. If I can get to that page I was hoping the use Yabb's own tools to identify and correct any probs. Is this how it works?

I have taken another tack with my hosting company now also. I have asked them to either allow me access to my old installation so I can transfer it across or to recommend a bulletin board they are familiar with or thirdly to install Yabb themselves (meaning they can have access to the necessary help files).

Mind you I don't have much hope they will accept this invitation!  Undecided

Onwards and upwards...

PS I had a look at the CPAN site and could make out neither head nor tail of it I'm afraid. If I have to resort to using it I may need some further hand holding!

Thanks again to everyone,

Ludek  Cool
  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online



Posts: 2,377
Location: Earth

YaBB 2.6.1
Re: Missing files on upload
Reply #9 - Jul 14th, 2012 at 4:56am
There are no actions to perform.
What I'm trying to get at is where did that list come from? It's not the one in the YaBB Quick Start Guide.

The files you're having problems with are NOT part of the YaBB package. The files in question are standard Perl addons and should have been already installed as part of a standard Perl/web server package. (In fact, since YaBB was running previously, we know those modules were available.)

I seriously think that your host is deliberately making it impossible for you to run Perl applications so you will either pay them extra to do things, or leave because they don't want to bother with users with 'special web needs' - as in Perl support. (OR they are so incompetent that you're going to lose your entire site when they crash and burn.)

Knownhost.com has some very inexpensive hosting packages and I know they support YaBB.

Tech support on a paid host should not be that difficult. (And if they're not allowing you to change your own file permissions, they are NOT going to let you do what you'd need to do to install those modules.)
« Last Edit: Jul 14th, 2012 at 5:00am by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Derek Bullock
Ex Member


Re: Missing files on upload
Reply #10 - Jul 14th, 2012 at 9:36am
There are no actions to perform.
Ludek wrote on Jul 12th, 2012 at 8:37pm:
Hello All,

I've had an account with a particularly c****y web host for a few years now (too lazy to change I'm afraid). This year they offered me what sounded like a much better deal so like a (lazy) mug I signed up again.

What I didn't realise is that as part of the deal my old Yabb install and web site required deletion and I've now got to upload everything to a completely new server.

No great problems except that they've now decided as part of my new deal that I'm not allowed to change permissions myself and every request has to go through their support.

When I uploaded the latest Yabb and requested the permission changes they emailed back to say certain files were missing. They were:

chmod: cannot access `cgi-bin/yabb2/Modules/Digest/Perl': No such file or directory
chmod: cannot access `cgi-bin/yabb2/Modules/Digest/Perl/MD5.pm': No such file or directory
chmod: cannot access `cgi-bin/yabb2/Modules/Time': No such file or directory
chmod: cannot access `cgi-bin/yabb2/Modules/Time/HiRes.pm': No such file or directory
chmod: cannot access `cgi-bin/yabb2/Modules/Upload': No such file or directory
chmod: cannot access `cgi-bin/yabb2/Modules/Upload/CGI.pm': No such file or directory
chmod: cannot access `cgi-bin/yabb2/Modules/Upload/CGI': No such file or directory
chmod: cannot access `cgi-bin/yabb2/Modules/Upload/CGI/Util.pm': No such file or directory


I had a look around the forum and my understanding is that if I can get the site up then I can go into 'Admin' and use a tool to identify and install these. Is this correct?

If not is there an easy way I can supply these files to the web host so I can finally get my new Yabb install working.

Many thanks for any help you can offer.

Ludek  Smiley


Hi everyone.

This thread has been bothering me ever since it first started because I had seen all the files mentioned above in red before and could not figure out where.

Tonight it suddenly hit me that they were in older versions of YaBB so I downloaded version 2.2 and there they all were as listed above.

Not sure when the Module files all changed but they must have sometime after 2.2

So I guess the question needs to be asked Ludek, where did you get your file list from that you sent your host? Was it from your current 2.5 download or from your previous forum??

You need to get the file and chmod list from the Quick-Guide in the 2.5 download only.

Cheers


Derek
« Last Edit: Jul 14th, 2012 at 9:37am by »  
Back to top
 
IP Logged
 
Derek Bullock
Ex Member


Re: Missing files on upload
Reply #11 - Jul 14th, 2012 at 9:45am
There are no actions to perform.
By the way, a host that will not let you set your own permissions is well worth staying away from.  Wink
  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online



Posts: 2,377
Location: Earth

YaBB 2.6.1
Re: Missing files on upload
Reply #12 - Jul 14th, 2012 at 1:00pm
There are no actions to perform.
Derek - thank you for clarifying where that list might have possibly come from. I hadn't realized they were included in earlier editions (the change probably took place prior at 2.3 or earlier as I've been told that 2.3/2.4/2.5 are all pretty similar, code-wise and I know they weren't in 2.4.)

And yes - any host that so limits what should be a simple ftp and site admin function is one to get well away from.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,591
Location: UK:Scotland/livingston

None
Re: Missing files on upload
Reply #13 - Jul 14th, 2012 at 1:54pm
There are no actions to perform.
Quote:
Tonight it suddenly hit me that they were in older versions of YaBB so I downloaded version 2.2 and there they all were as listed above.Not sure when the Module files all changed but they must have sometime after 2.2

Cool now that is cleared up and as

Dandello wrote on Jul 14th, 2012 at 1:00pm:
Derek - thank you for clarifying where that list might have possibly come from. I hadn't realized they were included in earlier editions (the change probably took place prior at 2.3

they are also not in yabb 2.3.1 and in YaBB 1 Gold - SP 1.3.1 there is no Modules Dir at all

so a question for Ludek
what yabb are you running if it is 2.5 you dont need the files listed as your forum should be running fine.
and if it is one of the older yabbs you will need to download the one for your forum from the second link in my first post .
if this dont help we will see what we can do  Wink
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,679
Location: Los Angeles

YaBB 2.5
Re: Missing files on upload
Reply #14 - Jul 14th, 2012 at 3:57pm
There are no actions to perform.
To everyone who's been helping, thanks. This has been a learning experience for me, which is appreciated.

By the way, I can confirm that what's been stated about version 2.4 is correct. I guess I should also point out that our forum appears to be missing 3 perl modules, but we don't need them, so it's all good for us.

If it's of any help to anyone, the following perl modules are evidently what are missing for us, but again, not needed:

Net/SMTP/TLS.pm - "Used to send emails via SMTP::TLS."

Compress/Bzip2.pm - "Used for the Backup feature."

Crypt/SSLeay.pm - "Used by "GoogieSpell", our Spell Checker"

In any case, it seems the suggestion to consider KnownHost is a good one. While I can't vouch for them personally, it's my understanding that YaBB forums can be operated just fine.

Also, I think this forum is hosted by UK2, and it seems they have some great pricing plans.

Our domains are hosted on a dedicated server, which has its advantages, but that's at a higher cost of course. However, our operations needed that higher level of performance.

As for VPS hosting, I'm barely familiar with it, but it looks pretty terrific, and quite frankly, that would probably work with how I'm operating our company now, i.e., more or less in retirement mode; at least until our next project.

A year or so ago I moved all but one of our domains onto a brand new server. Thankfully, however, the technicians were apprised of our YaBB forum, and successfully migrated everything over per my instructions.

I mention this because I believe there was a temporary issue regarding perl, but of course that was resolved as expected. I admit that I did paid some overtime for a more thorough migration, but not because of YaBB; only because I wanted to make sure that our migration was perfectly enabled.

I'm wishing the best for Ludek.  Smiley
  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
Page Index Toggle Pages: [1] 2 3 4
Topic Tools
 
  « Board Index ‹ Board  ^Top