Page Index Toggle Pages: 1 [2] 3 4 
Topic Tools
Locked Topic Missing files on upload (Read 10,458 times)
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,372
Location: Earth

YaBB 2.6.1
Re: Missing files on upload
Reply #15 - Jul 14th, 2012 at 7:05pm
There are no actions to perform.
Those 3 modules are, in fact, optional in YaBB 2.x. If a mod needs one of them, it will have it listed.  

But any decent host that supports Perl should be willing to install those should you need them.

VPS is an excellent middle ground between dedicated and 'regular' hosting. But as with everything, it depends on the hosting company.

« Last Edit: Jul 14th, 2012 at 7:06pm by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Ludek
YaBB Newcomer
*
Offline



Posts: 19
Re: Missing files on upload
Reply #16 - Jul 14th, 2012 at 8:10pm
There are no actions to perform.
Hello to Everyone!  Cheesy

Phew! I think I'm a little clearer - I'm not sure I'm clearer but I think I may be...

Firstly the list of files I sent to the host came from the Yabb installation guide here: http://www.yabbforum.com/codex/YaBB.pl?num=1190660838

This guide doesn't mention any differences between the versions I don't think?

On an associated subject the host has just written to say that my old board is still available so I can request that they just transfer the whole thing across and then I'll update from there - at least I know the one I had worked!

Can I establish exactly what files I need for v2.5 and what permissions I need for them? Is this written somewhere?

Is the download version of 2.5 complete then and the permissions for the remaining files as shown in the install guide? And to complete the installation just set the correct permissions and hey presto?

Is that whole list of 'missing' files redundant? And therefore the site should work without them?

I would like to be absolutely clear about this as I'm relaying this to not very helpful people who are already mentally stretched by the whole exercise!

Thanks again to everyone who has taken the trouble to respond.

Ludek  Cool
  
Back to top
 
IP Logged
 
depablo
YaBB Moderators
YaBB Next Team
Beta Testers
***
Offline



Posts: 577
Location: UK

None
Re: Missing files on upload
Reply #17 - Jul 14th, 2012 at 9:42pm
There are no actions to perform.
Personally I would reinstall your old forum using your hosts backup. Then install latest version and follow the upgrade instructions in the 2.5 quick start guide.

Or PM xnoddyx to do it for you, he's a very helpful chap  Smiley
  

Taking a peek behind the mask Wink
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,591
Location: UK:Scotland/livingston

None
Re: Missing files on upload
Reply #18 - Jul 14th, 2012 at 10:37pm
There are no actions to perform.
Ludek wrote on Jul 14th, 2012 at 8:10pm:
Firstly the list of files I sent to the host came from the Yabb installation guide here: http://www.yabbforum.com/codex/YaBB.pl?num=1190660838


Edited:
Ludek wrote on Jul 14th, 2012 at 8:10pm:
Can I establish exactly what files I need for v2.5 and what permissions I need for them? Is this written somewhere?

all files in the YaBB 2.5 download is all you need and for Upgrading see here http://www.yabbforum.com/codex/YaBB.pl?board=upgrade


this is a general dir and file chmod list that has the chmod for most yabbs 1.x 2.x but not all.

so for 2.5 will look like this
KEY *.*=all dirs/files *.help= all files ending with .help and so forth i.e. *.pl

cgi-bin/yabb2   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/AdminIndex.pl   -rwxr-xr-x (chmod 755)
cgi-bin/yabb2/Setup.pl   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/YaBB.pl   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Paths.pl   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Admin   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Boards   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Boards/*.*   -rw-rw-rw- (chmod 666)
cgi-bin/yabb2/Help   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Help/English   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Help/English/Admin   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Help/English/Admin/*.help   -rw-rw-rw- (chmod 666)
cgi-bin/yabb2/Help/English/Gmod   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Help/English/Gmod/*.help   -rw-rw-rw- (chmod 666)
cgi-bin/yabb2/Help/English/Moderator   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Help/English/Moderator/*.help   -rw-rw-rw- (chmod 666)
cgi-bin/yabb2/Help/English/User   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Help/English/User/*.help   -rw-rw-rw- (chmod 666)
cgi-bin/yabb2/Languages   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Languages/English   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Languages/English/*.txt  -rw-rw-rw- (chmod 666)
cgi-bin/yabb2/Languages/English/*.lng  -rw-rw-rw- (chmod 666)
cgi-bin/yabb2/Members   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Members/admin.*   -rw-rw-rw- (chmod 666)
cgi-bin/yabb2/Members/*.ims   -rw-rw-rw- (chmod 666)
cgi-bin/yabb2/Members/*.log   -rw-rw-rw- (chmod 666)
cgi-bin/yabb2/Members/*.passes   -rw-rw-rw- (chmod 666)
cgi-bin/yabb2/Members/*.msg   -rw-rw-rw- (chmod 666)
cgi-bin/yabb2/Members/*.rlog   -rw-rw-rw- (chmod 666)
cgi-bin/yabb2/Members/*.ttl   -rw-rw-rw- (chmod 666)
cgi-bin/yabb2/Members/*.txt   -rw-rw-rw- (chmod 666)
cgi-bin/yabb2/Members/*.vars   -rw-rw-rw- (chmod 666)
cgi-bin/yabb2/Messages   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Messages/*.ctb   -rw-rw-rw- (chmod 666)
cgi-bin/yabb2/Messages/*.txt   -rw-rw-rw- (chmod 666)
cgi-bin/yabb2/Modules   drwxrwxrwx (chmod 755)

NOT IN THE general dir and file chmod list but in YaBB 2.5
cgi-bin/yabb2/Modules/Archive/    drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Modules/Archive/Tar.pm    drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Modules/Archive/Zip.pm    drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Modules/Archive/Tar   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Modules/Archive/Tar/Constant.pm   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Modules/Archive/Tar/File.pm   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Modules/Archive/Zip   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Modules/Archive/Zip/Archive.pm   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Modules/Archive/Zip/BufferedFileHandle.pm   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Modules/Archive/Zip/DirectoryMember.pm   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Modules/Archive/Zip/FAQ.pod   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Modules/Archive/Zip/FileMember.pm   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Modules/Archive/Zip/Member.pm   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Modules/Archive/Zip/MemberRead.pm   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Modules/Archive/Zip/MockFileHandle.pm   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Modules/Archive/Zip/NewFileMember.pm   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Modules/Archive/Zip/StringMember.pm   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Modules/Archive/Zip/Tree.pm   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Modules/Archive/Zip/ZipFileMember.pm   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Modules/Digest/HMAC.pm   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Modules/Digest/HMAC_MD5.pm   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Modules/Email/   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Modules/Email/Date/   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Modules/Email/Date/Format.pm   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Modules/MIME/   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Modules/MIME/Lite.pm   drwxrwxrwx (chmod 755)
--------------------------------------------------------------------------------
-----------------------
cgi-bin/yabb2/Sources   drwxr-xr-x (chmod 755)
cgi-bin/yabb2/Sources/*.pl   -rwxr-xr-x (chmod 755)
cgi-bin/yabb2/Templates   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Templates/default   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Templates/default/*.*   -rw-rw-rw- (chmod 666)
cgi-bin/yabb2/Variables   drwxrwxrwx (chmod 755)
cgi-bin/yabb2/Variables/*.*   -rw-rw-rw- (chmod 666)

Templates must be o+x so that YaBB can read the files inside. Variables must be o+wx because this is where variables are to be created.

public_html Files

The following files in your public_html directory need to have their permissions altered. Please note that this list does not include files for which no change is needed.

yabbfiles/ all *.js   -rw-rw-rw- (chmod 666)
yabbfiles/mediaplayer.swf   -rw-rw-rw- (chmod 666)
yabbfiles/Attachments   drwxrwxrwx (chmod 755)
yabbfiles/Buttons/English   drwxrwxrwx (chmod 755)
yabbfiles/Buttons/English/*.*   drwxrwxrwx (chmod 755)
yabbfiles/shjs   drwxrwxrwx (chmod 755)
yabbfiles/shjs/*.*   -rw-rw-rw- (chmod 666)
yabbfiles/shjs/styles   drwxrwxrwx (chmod 755)
yabbfiles/shjs/styles/sh_style.css   -rw-rw-rw- (chmod 666)
yabbfiles/smilies   drwxrwxrwx (chmod 755)
yabbfiles/smilies/*.*   drwxrwxrwx (chmod 755)
yabbfiles/Templates/Admin/default.css   -rw-rw-rw- (chmod 666)
yabbfiles/Templates/Forum   drwxrwxrwx (chmod 755)
yabbfiles/Templates/Forum/default.css   -rw-rw-rw- (chmod 666)

hope this is of more help to you and think i got most of it Smiley

depablo wrote on Jul 14th, 2012 at 9:42pm:
Or PM xnoddyx to do it for you, he's a very helpful chap  Smiley


thanks depablo  Embarrassed  Grin your not so bad yourself  Wink
« Last Edit: Jul 14th, 2012 at 10:43pm by xnoddyx »  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Derek Bullock
Ex Member


Re: Missing files on upload
Reply #19 - Jul 15th, 2012 at 12:37am
There are no actions to perform.
Ludek wrote on Jul 14th, 2012 at 8:10pm:
Hello to Everyone!  Cheesy

Phew! I think I'm a little clearer - I'm not sure I'm clearer but I think I may be...

Firstly the list of files I sent to the host came from the Yabb installation guide here: http://www.yabbforum.com/codex/YaBB.pl?num=1190660838 Delete it from your computer and ignore it

This guide doesn't mention any differences between the versions I don't think? As above

On an associated subject the host has just written to say that my old board is still available so I can request that they just transfer the whole thing across and then I'll update from there - at least I know the one I had worked! With your and your hosts lack of understanding of YaBB this may be a good idea

Can I establish exactly what files I need for v2.5 and what permissions I need for them? Is this written somewhere? Yes, this is written in the Quick Guide which is in the download from YaBB that you should have as you stated in your first post you uploaded the files. If not download it here -  http://www.yabbforum.com/downloads.php #### Note below

Is the download version of 2.5 complete then and the permissions for the remaining files as shown in the install guide? Yes And to complete the installation just set the correct permissions and hey presto? Yes

Is that whole list of 'missing' files redundant? Yes And therefore the site should work without them? On most hosts, yes

I would like to be absolutely clear about this as I'm relaying this to not very helpful people who are already mentally stretched by the whole exercise!

Thanks again to everyone who has taken the trouble to respond.

Ludek  Cool


#### Note: If you haven't already, download YaBB 2.5 as mentioned above. Unzip the package to your computer. When you do so you will have a structure like this:

cgi-bin
public_html
Quick-Guide
README
VERSION

Open the folder Quick-Guide. When it opens you will have a structure like this:

English
images
Quick-Guide
style

Open Quick-Guide (this will open in your browser). Click on English and it will open the whole installation instructions.

I would suggest you read the whole thing to familiarize yourself with it. Of course the important section for you is Step 3 CHMOD. In there you will find all that you need to send to your host in regards what files are in YaBB 2.5 and the required permissions. It is completely accurate so don't question it. You can copy and paste it into an email for your host.

Once again however a host who will not let you set your own permissions could always be a problem for you.

If financially you can I would cut your losses and get out. Find a host with Linux or Unix and who uses CPanel and will support YaBB and sign up. (CPanel can make it easier to manage your site) Send me your FTP details in a PM and I will install you a brand new working YaBB Forum. Then you can play with it. Smiley

Cheers


Derek
  
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,907
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Missing files on upload
Reply #20 - Jul 15th, 2012 at 3:09pm
There are no actions to perform.
I'd like to clarify a couple things - and this is to the extent of my knowledge only:

IF Perl is working correctly, even at a very basic level - you can add Perl modules (.pm) files to your ./Modules folder - and they should work.

A few things should be noted and explained.

A. This is possible because the include path is extended when YaBB.pl is loaded.

B. Some Perl Modules have their own 'support' folders. This is to resolve dependencies (other code the new module requires). These have to be uploaded as well.

C. Permissions -
 1. Linux/Unix/Mac hosts - The permissions should be 'at least' 755 - that is the 'owner' of the files and any members of the primary 'group' the owner belongs to can 'execute' the files (they are a special kind of Perl script in fact).  

  2. IIS - use the same permissions as set for ./Sources

The Perl version currently required AFAIK is Perl 5.8+ (anyone feel free to ocrrect me). I personally know of YaBB Forums on Perl 5.6, but they are older versions, and I don't know all the dependencies.  Perl Modules are different from PHP extensions, and are generally much less version dependent.

Good Luck to all
Cool
« Last Edit: Jul 15th, 2012 at 3:32pm by JonB »  

I find your lack of faith disturbing.
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,372
Location: Earth

YaBB 2.6.1
Re: Missing files on upload
Reply #21 - Jul 15th, 2012 at 3:28pm
There are no actions to perform.
When loading new Perl modules into ./Modules - note that the new modules have their own sub-folders. Time::Hi-res will actually be .Modules/Time/Hi-res.pm

But I'm still seriously bothered that CGI.pm is not being found as an installed Perl module and the hosting service is unwilling or unable to add it.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,907
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Missing files on upload
Reply #22 - Jul 15th, 2012 at 3:38pm
There are no actions to perform.
CGI.pm is indeed critical to YaBB (and most Perl scripts).  User Avatars and Attachment uploads won't work in YaBB without it, AFAIK.  In the back of my itty-bitty brain a chorus is quietly warming up for a version of 'O Where o where have my tempfiles gone??".  Cheesy

Be Cool -
Cool

  

I find your lack of faith disturbing.
Back to top
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,591
Location: UK:Scotland/livingston

None
Re: Missing files on upload
Reply #23 - Jul 15th, 2012 at 4:27pm
There are no actions to perform.
Dandello wrote on Jul 15th, 2012 at 3:28pm:
But I'm still seriously bothered that CGI.pm is not being found as an installed Perl module and the hosting service is unwilling or unable to add it.

this reminds me of some free hosts.

JonB wrote on Jul 15th, 2012 at 3:38pm:
In the back of my itty-bitty brain a chorus is quietly warming up for a version of 'O Where o where have my tempfiles gone??".  Cheesy

Be Cool -
Cool
 


oh no thats never good lol
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Ludek
YaBB Newcomer
*
Offline



Posts: 19
Re: Missing files on upload
Reply #24 - Jul 15th, 2012 at 9:14pm
There are no actions to perform.
Hello Everyone,  Cheesy

Wow! Well, to precis what I've done following all this wonderful assistance is:

I've basically started again. I've deleted everything I've done so far. I've reinstalled making doubly sure I've used the correct ASCII/Binary uploading options where appropriate.

I've sent the Support [sic] department the list of permissions as included in the Quick Start Guide.

I have also, as an extra technical feature, crossed all of my fingers and as many toes as I can manage!  Wink

Hang on to your hats and let's see what comes next!

Thank you all again for this marvellous assistance, I am really most grateful. And to reassure everyone this isn't going to be an annual exercise I have diarised the end of the hosting contract for next year so I can find myself another (proper) host in good time!

Regards,

Ludek  Cool
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,591
Location: UK:Scotland/livingston

None
Re: Missing files on upload
Reply #25 - Jul 15th, 2012 at 10:05pm
There are no actions to perform.
Ludek wrote on Jul 15th, 2012 at 9:14pm:
Hello Everyone,  Cheesy

Wow! Well, to precis what I've done following all this wonderful assistance is:

I've basically started again. I've deleted everything I've done so far. I've reinstalled making doubly sure I've used the correct ASCII/Binary uploading options where appropriate.

I've sent the Support [sic] department the list of permissions as included in the Quick Start Guide.

I have also, as an extra technical feature, crossed all of my fingers and as many toes as I can manage!  Wink

Hang on to your hats and let's see what comes next!

Thank you all again for this marvellous assistance, I am really most grateful. And to reassure everyone this isn't going to be an annual exercise I have diarised the end of the hosting contract for next year so I can find myself another (proper) host in good time!

Regards,

Ludek  Cool


Quote:
crossed all of my fingers and as many toes as I can manage!  Wink

Shocked wow i can only do my  fingers lol and thanks all we hope for is that you have a working forum at the end  Wink
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Derek Bullock
Ex Member


Re: Missing files on upload
Reply #26 - Jul 15th, 2012 at 11:09pm
There are no actions to perform.
Ludek wrote on Jul 15th, 2012 at 9:14pm:
Hello Everyone,  Cheesy

Wow! Well, to precis what I've done following all this wonderful assistance is:

I've basically started again. I've deleted everything I've done so far. I've reinstalled making doubly sure I've used the correct ASCII/Binary uploading options where appropriate.

I've sent the Support [sic] department the list of permissions as included in the Quick Start Guide.

I have also, as an extra technical feature, crossed all of my fingers and as many toes as I can manage!  Wink

Hang on to your hats and let's see what comes next!

Thank you all again for this marvellous assistance, I am really most grateful. And to reassure everyone this isn't going to be an annual exercise I have diarised the end of the hosting contract for next year so I can find myself another (proper) host in good time!

Regards,

Ludek  Cool


Well done, love your work Smiley
  
Back to top
 
IP Logged
 
Ludek
YaBB Newcomer
*
Offline



Posts: 19
Re: Missing files on upload
Reply #27 - Aug 10th, 2012 at 7:57pm
There are no actions to perform.
Well, this painful (and so far fruitless) installation journey continues.

It's been almost a month and we have arrived here
http://www.britishanzani.co.uk/cgi-bin/yabb2/YaBB.pl

They've so far had three attempts at getting these permissions correct and this is where we are.

I suppose the first question I should ask is is this a problem created by me? Have I got something wrong in the installation?

If someone could have a look and give me their opinion I'd be very grateful.

I'm loathed to have any more conversations with Support than I have to - relations are a little strained at the moment.

Thanks for your time,

Ludek  Cool
  
Back to top
 
IP Logged
 
depablo
YaBB Moderators
YaBB Next Team
Beta Testers
***
Offline



Posts: 577
Location: UK

None
Re: Missing files on upload
Reply #28 - Aug 10th, 2012 at 8:20pm
There are no actions to perform.
Ludek wrote on Aug 10th, 2012 at 7:57pm:
They've so far had three attempts at getting these permissions correct and this is where we are.

Can you not cut your losses and try a new host?
Concerns:
1/ You will need a domain name from Easily.co.uk to use with your web hosting.
2/ Unable to change your own permissions.
3/ Unlimited Bandwidth.

Can your current domain name be transferred to another registrar?

  

Taking a peek behind the mask Wink
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,676
Location: Los Angeles

YaBB 2.5
Re: Missing files on upload
Reply #29 - Aug 10th, 2012 at 8:31pm
There are no actions to perform.
If you're referring to how your forum isn't rendering properly ...

Ludek wrote on Aug 10th, 2012 at 7:57pm:
I'm loathed to have any more conversations with Support than I have to - relations are a little strained at the moment.

Sorry this has happened. I think the official support here is trying to do a better job. I'm trying to remain hopeful about it.

They don't really like me butting in to help ... still ...

I took a quick look at your forum, and got the formatting to render just fine.

The quick answer is that the css files you're referencing are incorrect. You currently have the following lines:

Code
Select All
<link rel="stylesheet" href="/Templates/Forum/default.css" type="text/css" />

<link rel="stylesheet" href="/shjs/styles/sh_style.css" type="text/css" /> 


For the rendering to work properly in your forum, replace the two lines you see above with the following:

Code
Select All
<link rel="stylesheet" href="http://www.britishanzani.co.uk/yabbfiles/Templates/Forum/default1.css" type="text/css" /> 


How you need to do this properly is another question. Hopefully YaBB's official support will answer that for you.

By the way, feel free to contact me directly if I get in trouble for trying to help online. At least with a rendering problem, I can more than likely help you to fix it.

Good luck!

  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
Page Index Toggle Pages: 1 [2] 3 4 
Topic Tools
 
  « Board Index ‹ Board  ^Top