Page Index Toggle Pages: 1
Topic Tools
Functionality Issue - "/me" (Read 1,465 times)
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,085
Location: Earth

YaBB 2.6.0
Re: Functionality Issue - "/me"
Reply #4 - Nov 6th, 2012 at 9:33pm
Post Tools
This Topic was moved here from YaBB 2 - Bugs [Need Verification] [move by] Dandello.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,085
Location: Earth

YaBB 2.6.0
Re: Functionality Issue - "/me"
Reply #3 - Aug 10th, 2012 at 1:40am
Post Tools
Not when I have to make it compatible with everybody else. Now on my hyper-modded boards it's
Code
Select All
class="red" 

like it should be. (But then my hyper-modded board also has 5 style sheets and the javascript to render those cute code blocks only loads on Message Display and the posting screens.)

And if you want to make PerlCritic happy, the line should read:
Code
Select All
    $message =~ s/\/me\s+(.*)/<span class="red"><i><b>$displayname  says:<\/b> '$1'<\/i><\/span>/igsm;
 


Cheesy Roll Eyes
« Last Edit: Aug 10th, 2012 at 3:02pm by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,584
Location: UK:Scotland/livingston

None
Re: Functionality Issue - "/me"
Reply #2 - Aug 10th, 2012 at 12:48am
Post Tools
Dandello wrote on Aug 9th, 2012 at 7:30pm:
style="color: #FF0000;"

lol thort you was going to move all the style tags from the code to the css   Tongue lol
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,085
Location: Earth

YaBB 2.6.0
Re: Functionality Issue - "/me"
Reply #1 - Aug 9th, 2012 at 7:30pm
Post Tools
Is this on my todo list of bug fixes?  Huh

BTW, it looks like you're having way too much fun looking for bugs... Swat! Swat! Pssst...  Cheesy (Can we get a bug spray smiley?)

Okay, to put it back exactly the way it was in ./Sources/YaBBC.pl find:
Code
Select All
	$message =~ s~/me ~<i>$displayname</i> ~ig; 


and replace with this (from 2.3.1):
Code
Select All
	$message =~ s~/me\s+(.*)~<span style="color: #FF0000;"><i>* $displayname $1</i></span>~ig; 



but if you want to get clever:
Code
Select All
	$message =~ s~/me\s+(.*)~<span style="color: #FF0000;"><i><b>$displayname  says:</b> '$1'</i></span>~ig; 


Wink
« Last Edit: Aug 9th, 2012 at 7:52pm by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,768
Location: Land of the Blazing Sun!

YaBB 2.6.0
Functionality Issue - "/me"
Aug 9th, 2012 at 3:44pm
Post Tools
In YaBB versions prior to 2.4 the /me element in the compose window italicized the entire line and set the text color to #FF0000.  Deti changed it literally on a whim. (I know because Corey asked him directly).

Stylistically, I much prefer the older rendering.

Current

* JonB says 'geee that was a dumb idea'.

Traditional:

/me says 'geee that was a dumb idea'.

JMHO -
Cool

BTW - I just used it & I have no idea if everyone 'now present' knows we have a 'noparse' tag:
Code
Select All
[ noparse ]/me[ /noparse ]  



OOPS!  another one - noparse should NOT be parsed inside a 'code' tag...

Cheesy
« Last Edit: Aug 9th, 2012 at 3:46pm by JonB »  

I find your lack of faith disturbing.
Back to top
IP Logged
 
Page Index Toggle Pages: 1
Topic Tools
 
  « Board Index ‹ Board  ^Top