Page Index Toggle Pages: 1 [2] 3 
Topic Tools
 25 testing new anti-spam mod (Read 6,896 times)
westwegoman
Ex Member
**




None
Re: testing new anti-spam mod
Reply #17 - Aug 13th, 2012 at 7:11am
Post Tools
Dandello wrote on Aug 13th, 2012 at 12:31am:
Here spam-bot, here little spam-bot... Smiley

Over here http://testbed.dandello.net/cgi-bin/yabb252/YaBB.pl ya dumb programs...

Lol.  Grin

On the subject of a random pic, if we're on the same page here, I use something similar on segnette.com forum registration. A photo at the top that has to be identified, although it doesn't change.

Between that and Spam Fruits, bam! Stopped darn near cold!  Smiley

Merv and anti-spam mod writers - 1
Spamtards - 0  Grin
  
<div class=
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,080
Location: Earth

YaBB 2.6.0
Re: testing new anti-spam mod
Reply #16 - Aug 13th, 2012 at 12:31am
Post Tools
Here spam-bot, here little spam-bot... Smiley

Over here http://testbed.dandello.net/cgi-bin/yabb252/YaBB.pl ya dumb programs...
« Last Edit: Aug 13th, 2012 at 12:33am by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,584
Location: UK:Scotland/livingston

None
Re: testing new anti-spam mod
Reply #15 - Aug 13th, 2012 at 12:21am
Post Tools
Dandello wrote on Aug 12th, 2012 at 11:31pm:
The bots stopped attacking one of my boards they were trying to get into just Friday - turned off everything, even cleaned out the SFS banned list to lure them in. 2 errors since Friday.  

Is this a new anti-spam thing we didn't know about - announce you're open for spam-bots and they run away?   Shocked

that or a spam botnet is down lol
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,080
Location: Earth

YaBB 2.6.0
Re: testing new anti-spam mod
Reply #14 - Aug 12th, 2012 at 11:31pm
Post Tools
The bots stopped attacking one of my boards they were trying to get into just Friday - turned off everything, even cleaned out the SFS banned list to lure them in. 2 errors since Friday. 

Is this a new anti-spam thing we didn't know about - announce you're open for spam-bots and they run away?   Shocked
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,584
Location: UK:Scotland/livingston

None
Re: testing new anti-spam mod
Reply #13 - Aug 11th, 2012 at 6:05pm
Post Tools
lol then some i have seen some spam bots probe for admin passwords and that as well
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,080
Location: Earth

YaBB 2.6.0
Re: testing new anti-spam mod
Reply #12 - Aug 11th, 2012 at 5:04pm
Post Tools
That works - I'm surprised they haven't shown up yet - they attack everything with a register form.  Grin
« Last Edit: Aug 11th, 2012 at 5:05pm by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,584
Location: UK:Scotland/livingston

None
Re: testing new anti-spam mod
Reply #11 - Aug 11th, 2012 at 4:49pm
Post Tools
Dandello wrote on Aug 11th, 2012 at 3:56pm:
Depending on the anti-spam results over the next week, I'll post the honeypot over in BoardMod with the warning that it's an Alpha in need of testing. So far I haven't had anything trip it, but it's early days yet.

if you want i can post the url for it on some places i know that will get spam bots checking the link out
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,080
Location: Earth

YaBB 2.6.0
Re: testing new anti-spam mod
Reply #10 - Aug 11th, 2012 at 3:56pm
Post Tools
Depending on the anti-spam results over the next week, I'll post the honeypot over in BoardMod with the warning that it's an Alpha in need of testing. So far I haven't had anything trip it, but it's early days yet.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,584
Location: UK:Scotland/livingston

None
Re: testing new anti-spam mod
Reply #9 - Aug 11th, 2012 at 12:50am
Post Tools
Dandello wrote on Aug 11th, 2012 at 12:43am:
Exactly - of course how many forums want a random picture of a world landmark in their header? Hmm ...  Cheesy  
Code
Select All
if ($action eq 'Register2' ) {
my $rand = int rand 10;
 $headerimg = $testimg[$rand]...}
else {$headerimg = qq{ $imagedir/yabblogo.png }; } 


The dots signify 'add detail here'.  Wink

lol i see we are thinking the same when i put header to use the yabblogo.png place  Grin
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,080
Location: Earth

YaBB 2.6.0
Re: testing new anti-spam mod
Reply #8 - Aug 11th, 2012 at 12:43am
Post Tools
Exactly - of course how many forums want a random picture of a world landmark in their header? Hmm ...  Cheesy  
Code
Select All
if ($action eq 'Register2' ) {
my $rand = int rand 10;
 $headerimg = $testimg[$rand]...}
else {$headerimg = qq{ $imagedir/yabblogo.png }; } 


The dots signify 'add detail here'.  Wink
« Last Edit: Aug 11th, 2012 at 12:44am by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,584
Location: UK:Scotland/livingston

None
Re: testing new anti-spam mod
Reply #7 - Aug 11th, 2012 at 12:28am
Post Tools
Dandello wrote on Aug 10th, 2012 at 11:21pm:
And that would be a good idea to try as well  - a random picture outside the form that has to identified - with Perl it's not that hard to link the picture with a hidden identifier field. (or even in PHP) Maybe even set the picture as the background element in a div - that much harder to get at.

or even in the header
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,080
Location: Earth

YaBB 2.6.0
Re: testing new anti-spam mod
Reply #6 - Aug 10th, 2012 at 11:21pm
Post Tools
And that would be a good idea to try as well  - a random picture outside the form that has to identified - with Perl it's not that hard to link the picture with a hidden identifier field. (or even in PHP) Maybe even set the picture as the background element in a div - that much harder to get at.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,584
Location: UK:Scotland/livingston

None
Re: testing new anti-spam mod
Reply #5 - Aug 10th, 2012 at 11:05pm
Post Tools
sounds good to me i also know that most bots will also not load pics from the page but will load pics if its in the form field
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,080
Location: Earth

YaBB 2.6.0
Re: testing new anti-spam mod
Reply #4 - Aug 10th, 2012 at 10:45pm
Post Tools
I turned off everything except the honeypot and admin review. (The honeypot isn't set to be turned off yet. No sense wasting time if it doesn't work. If it does work, the next addition will be to add a randomizer to the field name so if they catch on that one field name is a trap, they may not realize that a different one is too - at least that's what some of the spam experts claim. We'll see.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,584
Location: UK:Scotland/livingston

None
Re: testing new anti-spam mod
Reply #3 - Aug 10th, 2012 at 10:38pm
Post Tools
cool i did note that the cipher was missing Though
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Page Index Toggle Pages: 1 [2] 3 
Topic Tools
 
  « Board Index ‹ Board  ^Top