Page Index Toggle Pages: 1
Topic Tools
Normal Topic YaBB.js Called Twice (YaBB 2.5) (Read 1,778 times)
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,270
Location: Earth

YaBB 2.6.1
Re: YaBB.js Called Twice (YaBB 2.5)
Reply #5 - Nov 6th, 2012 at 9:31pm
Post Tools
This Topic was moved here from YaBB 2 - Bugs [Need Verification] [move by] Dandello.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: YaBB.js Called Twice (YaBB 2.5)
Reply #4 - Aug 29th, 2012 at 4:04pm
Post Tools
Dandello wrote on Aug 29th, 2012 at 2:39pm:
I don't think this one would show up in Debug

it was worth a try  Smiley
Dandello wrote on Aug 29th, 2012 at 2:39pm:
and it may not do anything to load times as compared to loading all the 'code' display javascripts into pages that don't need them.

this is true  Undecided
Dandello wrote on Aug 29th, 2012 at 2:39pm:
and MSIE is really sensitive about things like that.

Smiley you dont need to tell me Smiley
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,270
Location: Earth

YaBB 2.6.1
Re: YaBB.js Called Twice (YaBB 2.5)
Reply #3 - Aug 29th, 2012 at 2:39pm
Post Tools
I don't think this one would show up in Debug - and it may not do anything to load times as compared to loading all the 'code' display javascripts into pages that don't need them.

And running rendered pages through the various developer-browser tools didn't catch it either - and MSIE is really sensitive about things like that.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: YaBB.js Called Twice (YaBB 2.5)
Reply #2 - Aug 29th, 2012 at 10:44am
Post Tools
do you not have Debug Mode turnd on for admins on the testbed? i always have it on when adding mods to check load - work times  Grin
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,270
Location: Earth

YaBB 2.6.1
Re: YaBB.js Called Twice (YaBB 2.5)
Reply #1 - Aug 28th, 2012 at 8:57pm
Post Tools
You know, I've gone over Subs.pl more than once and missed that one.  Huh
(And this maybe one more source of slow loading in 2.5.)
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Derek Barnstorm
Support Team
YaBB Next Team
Development Team
Beta Testers
****
Offline



Posts: 1,269
Location: United Kingdom

None
YaBB.js Called Twice (YaBB 2.5)
Aug 28th, 2012 at 6:25pm
Post Tools
YaBB.js is being called twice. It crept in when the Syntax Highlighter mod was added.

In Sources/Subs.pl find and remove:

Code
Select All
<script language="JavaScript1.2" type="text/javascript" src="$yyhtml_root/YaBB.js"></script> 

« Last Edit: Aug 28th, 2012 at 6:35pm by Derek Barnstorm »  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Topic Tools
 
  « Board Index ‹ Board  ^Top